Subject: [urn] URN for hash namespaces

From: "Kemp, David P." <[email-masked]>
Date: Wed, 9 Mar 2011 10:05:30 -0500

URN guys,

To support a new proposal for the PKIX working group, it would be useful
to have a standard syntax for unique identifiers based on cryptographic
hashes.  An Internet Draft was published in 2003 defining a suitable URN
namespace (http://tools.ietf.org/id/draft-thiemann-hash-urn-01.txt), but
it was never published as an RFC.

Does anyone remember this draft, or know the reasons for its failure to
progress (issues to be resolved, or simple lack of follow-up)?   If it
were submitted today, I'd suggest using base64 encoding instead of
base32, but otherwise it appears to perfectly fit a need.

Thanks,

Dave Kemp

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 09 Mar 2011 09:44:33 -0700

On 3/9/11 8:05 AM, Kemp, David P. wrote:
> were submitted today, I’d suggest using base64 encoding instead of

I don't know the history, but feel free to resurrect it. :)

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: "MILLER, TIMOTHY J CTR USAF AFMC ESC/HNCDP" <[email-masked]>
Date: Wed, 9 Mar 2011 10:21:36 -0600

Personally I think UUID version 5 suffices, for which there is already an RFC defining URN syntax, but it would be nice to extend it for hash agility.  I did once track down an ITU-T area representative to discuss the idea, but I got the impression it would be more work than it was probably worth.

//SIGNED// 

Timothy J. Miller, FFRDC, ESC/HNCDP 
(The MITRE Corporation)

> -----Original Message-----
> From: Kemp, David P. [mailto:[email-masked]]
> Sent: Wednesday, March 09, 2011 9:06 AM
> To: [email-masked]; [email-masked]
> Cc: Kemp, David P.; MILLER, TIMOTHY J CTR USAF AFMC ESC/HNCDP
> Subject: URN for hash namespaces
> 
> URN guys,
> 
> 
> 
> To support a new proposal for the PKIX working group, it would be useful to have a standard syntax for unique
> identifiers based on cryptographic hashes.  An Internet Draft was published in 2003 defining a suitable URN
> namespace (http://tools.ietf.org/id/draft-thiemann-hash-urn-01.txt), but it was never published as an RFC.
> 
> 
> 
> Does anyone remember this draft, or know the reasons for its failure to progress (issues to be resolved, or
> simple lack of follow-up)?   If it were submitted today, I'd suggest using base64 encoding instead of base32,
> but otherwise it appears to perfectly fit a need.
> 
> 
> 
> Thanks,
> 
> Dave Kemp

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 09 Mar 2011 11:55:30 -0700

On 3/9/11 9:21 AM, MILLER, TIMOTHY J CTR USAF AFMC ESC/HNCDP wrote:

> Personally I think UUID version 5 suffices, for which there is
> already an RFC defining URN syntax, but it would be nice to extend it
> for hash agility.  I did once track down an ITU-T area representative
> to discuss the idea, but I got the impression it would be more work
> than it was probably worth.

You mean RFC 4122? Yes, that would serve the same purpose.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/