Subject: [urn] I-D Action: draft-ietf-urnbis-rfc3187bis-isbn-urn-01.txt

From: [email-masked]
Date: Mon, 17 Oct 2011 15:16:11 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Uniform Resource Names, Revised Working Group of the IETF.

	Title           : Using International Standard Book Numbers as Uniform Resource Names
	Author(s)       : Maarit Huttunen
                          Juha Hakala
                          Alfred Hoenes
	Filename        : draft-ietf-urnbis-rfc3187bis-isbn-urn-01.txt
	Pages           : 20
	Date            : 2011-10-17

   The International Standard Book Number, ISBN, is a widely used
   identifier for monographic publications.  Since 2001, the URN
   (Uniform Resource Name) namespace &quot;ISBN&quot; has been reserved for ISBNs.
   The namespace registration was performed in RFC 3187 and applied only
   to the ISBN as specified in the ISO Standard 2108-1992, now known as
   &quot;ISBN-10&quot;.  To allow for further growth in use, the successor ISO
   Standard, ISO 2108:2005, has defined an expanded format for the ISBN,
   known as &quot;ISBN-13&quot;.  This document defines how both of these ISBN
   standard versions can be supported within the URN framework.
   Moreover, additional syntax related information required by the RFC
   2141[bis] has been included.  An updated namespace registration is
   provided.  It describes how both the old and the new ISBN format can
   share the same namespace.

   This document replaces RFC 3187; it also obsoletes and moves to
   Historic status the predecessor thereof, RFC 2288.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-urnbis-rfc3187bis-isbn-urn-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-urnbis-rfc3187bis-isbn-urn-01.txt

---

From: Alfred Hönes <[email-masked]>
Date: Tue, 18 Oct 2011 00:29:14 +0200 (MESZ)

URNbis folks,
the IETF draft submission system has announced the availability
of an updated WG draft:

> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Uniform Resource Names, Revised
> Working Group of the IETF.
>
> _______________________________________________
> urn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/urn

[[ speaking as a co-author and editor of the draft ]]

The draft as well as a HTML diff to its predecessor version will soon
be available via the WG's "home page", http://tools.IETF.ORG/wg/urnbis/

The major differences of this draft version from its predecessor are
listed in Appendix A.2 of the new draft as follows:

A.2.  draft-ietf-urnbis-rfc3187bis-isbn-urn-00 to -01

   - discussion on persistence altered, based on list discussion;
   - changes and amendments to discussion of URN resolution services;
   - discussion of fragment part usage added;
   - broken link to ISBN manual fixed based on feedback from [ISBNORG];
   - various editorial fixes and enhancements.

Best regards,
  Alfred.

-- 

+------------------------+--------------------------------------------+
| TR-Sys Alfred Hoenes   |  Alfred Hoenes   Dipl.-Math., Dipl.-Phys.  |
| Gerlinger Strasse 12   |  Phone: (+49)7156/9635-0, Fax: -18         |
| D-71254  Ditzingen     |  E-Mail:  [email-masked]                     |
+------------------------+--------------------------------------------+

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 18 Oct 2011 11:26:35 -0600

> be available via the WG's "home page", http://tools.IETF.ORG/wg/urnbis/

That would be:

http://tools.ietf.org/rfcdiff?url2=draft-ietf-urnbis-rfc3187bis-isbn-urn-01.txt

/psa

---

From: Larry Masinter <[email-masked]>
Date: Tue, 18 Oct 2011 12:18:16 -0700

A few quick comments:

The draft talks about "the URN resolver" in a way that I would prefer "a URN resolver", i.e., not imply there are many.

The normative language looks odd in some places. For example, "a large union catalog CAN be used ..."
But "CAN" is not a 2119 term.  A digital copy "MAY be found with the ISBN of the printed material.
But this is not a normative requirement or directive for any implementation, I don't think.
Similarly with "the national bibliography MAY be able ..."  
"Some users MAY prefer ..."

I'd say that at least in the part of the document I glanced at, the most of the uses of 2119 terms look quite suspicious.

Larry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Peter Saint-Andre
Sent: Tuesday, October 18, 2011 10:27 AM
To: Alfred �
Cc: [email-masked]
Subject: Re: [urn] I-D Action: draft-ietf-urnbis-rfc3187bis-isbn-urn-01.txt

That would be:

/psa