Subject: [urn] The namespace registration trainsition draft, version 04

From: John C Klensin <[email-masked]>
Date: Mon, 16 Feb 2015 16:58:30 -0500

Hi.

As the last of this round of document postings, I've just
submitted draft-ietf-urnbis-ns-reg-transition.

For those familiar with prior versions, there are really no
substantive changes.  The major ones reflect the transition from
a separate 3406bis to the consolidated 2141bis.  So it is
probably reasonable to look at a diff.

I have also made a number of editorial changes that, I hope,
will make the document somewhat more precise.

In addition to a general review of the draft, WG participants
should note that the placeholder "[[CREF3" in Section 2
effectively asks a substantive question about whether there is
content in the now-expired draft-ietf-urnbis-rfc3187bis-isbn-urn
and draft-ietf-urnbis-rfc3044bis-issn-urn that needs to be moved
into either this documents or 2141bis.  If such content is not
identified soon, we will assume the answer is "no" and will
remove the placeholder.

The immediately-following "[[CREF4" ask a similar question about
other registered namespaces that might need specific transition
information.  Again, if there are such issues, please comment
soon or the placeholder will simply be removed.

Note that these placeholders have now been present in versions
of this document for well over a year and there have been no
comments in response to either.

best,
   john

---

From: John C Klensin <[email-masked]>
Date: Mon, 16 Feb 2015 17:05:35 -0500

Hi.

One thing I didn't mention in my earlier note and should have.
Because the changes are small and should be non-substantive, I
did not ask Juha to review this version before it was posted,
so, if it introduced any new problems, they are my fault alone.

    john

---

From: Peter Saint-Andre - &yet <[email-masked]>
Date: Fri, 20 Feb 2015 20:35:45 -0700

> submitted draft-ietf-urnbis-ns-reg-transition.

Hi John & Juha,

Thanks again for writing this document.

> probably reasonable to look at a diff.

Given that it's been a while since I first review the document, I've 
decided to read it again. Here are a few small comments.

First, I sense a small ambiguity in the Introduction:

    Those
    potential problems included the possibility of the same name being
    used to identify different namespaces with different rules.

I tripped slightly over the word "name" given that we're talking about 
Uniform Resource Names. Perhaps "string" or "namespace identifier" would 
be better than "name" here.

> identified soon, we will assume the answer is "no" and will

Although I have not yet looked at those expired I-Ds in detail (they are 
rather long), I trust Juha to do the right thing about the information 
contained in them.

> soon or the placeholder will simply be removed.

My feeling is that it would be best to focus this document on ISBN and 
ISSN only. I also doubt that we have the energy here to complete a 
review of all the registered namespaces. However, I would be happy to 
glance at them to see if any need special attention.

Peter

-- 
Peter Saint-Andre
https://andyet.com/