Subject: Re: [urn] Moving ahead with draft-spinosa-urn-lex

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 1 May 2018 21:25:21 -0600

No objections here!

On 4/30/18 11:08 PM, Barry Leiba wrote:
> Thanks for this, Dale: this seems like a reasonable way forward to me,
> at this time.
> Do others agree?
> 
> Barry
> 
> On Mon, Apr 30, 2018 at 8:39 PM Dale R. Worley <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     My apologies for not working on this earlier.
> 
>     The current draft of "urn-lex" is draft-spinosa-urn-lex-12.  People have
>     criticized its proposed URN system in many ways, but it seems to me that
>     most of the criticisms are "bibliographic", they concern good ways to
>     create identifiers for written works.  As such, the IETF is not a good
>     forum for correcting most of those problems.
> 
>     My proposal is that we implement "rough consensus and running code" --
>     obtain a usable registration of the "lex" URN namespace so that the
>     authors and ITTIG can put the "lex" URNs into practice.  The process of
>     using the URNs will educate the authors regarding the correct resolution
>     of the various problems, and will likely cause them to later submit a
>     revised registration.
> 
>     That is, the registration we create at this time will be understood to
>     be experimental in nature.
> 
>     In order to be suitable as an "experimental" registration, there are a
>     few problems that must be resolved:
> 
>     1. The URN syntax must conform to the generic URN syntax.
> 
>     2. The requirements of uniqueness and persistence must be met.  (That
>     is, any URN designates at most one resource, and the resource that it
>     designates must not change over time.  However, it is permissible to
>     have multiple URNs designate the same resource.)
> 
>     3. The process or authority that assigns each URN must be well-defined.
> 
>     Item 1 is taken care of, in that the syntax in -12 conforms (as far as I
>     can tell) to the URN syntax in RFC 8141.
> 
>     Item 2 is the responsibility of the Jurisdictional Registrars, in the
>     same way that the naming authorities of many other URN namespaces are
>     responsible for uniqueness and persistence.
> 
>     Item 3 requires that a registry of jurisdiction codes and Jurisdictional
>     Registrars be maintained.  Section 11.2 of the -12 draft proposes that
>     IANA maintain the registry.  Given the experimental nature of the URN
>     registration, it seems to me to be premature to involve IANA, especially
>     since the principles that the Designated Export must implement are
>     likely to change over time.  Instead, it seems to me that the best
>     choice for registrar is ITTIG-CNR, the proposer and developer of the URN
>     namespace.
> 
>     When the namespace definition is transitioned to a non-experimental
>     status (including fixing a good set of policies to assign jurisdiction
>     codes), the registry can be transferred to IANA to implement the proven
>     policies.
> 
>     Following this path requires only small changes for -13, viz., updating
>     section 11.2.
> 
>     Dale
>     ----------------------------------------------------------------------
>     Archived discussions:
> 
>     https://www.ietf.org/mail-archive/web/urn/current/msg03828.html
>     16 Nov 2017
>     "urn:lex draft v. 12"
> 
>     https://www.ietf.org/mail-archive/web/urn/current/msg03811.html
>     starting 20 Sep 2017
>     "Request for new URN namespace review: LEX"
>     Message-Id:
>     <[email-masked]
>     <mailto:[email-masked]>>
> 
>     https://www.ietf.org/mail-archive/web/urn-nid/current/msg01270.html
>     starting 29 Apr 2014
>     "Publication request for draft-spinosa-urn-lex"
>     Message-Id:
>     <CALaySJJk5YiCQZqt6WoWkqfAzi2A04HEAH=[email-masked]
>     <mailto:[email-masked]>>
> 
>     https://www.ietf.org/mail-archive/web/urn-nid/current/msg01204.html
>     starting 27 Mar 2013
>     "Application for a formal URN NID"
>     Message-Id: <23A64284-6B03-4B24-B680-54A61E96BECA at ittig.cnr.it
>     <http://ittig.cnr.it>>
> 
>     https://www.ietf.org/mail-archive/web/urn-nid/current/msg01059.html
>     15 Oct 2009
>     "URN LEX Namespace submission"
> 
> -- 
> Barry
> --
> Barry Leiba  ([email-masked] <mailto:[email-masked]>)
> http://internetmessagingtechnology.org/

---

From: "Hakala, Juha E" <[email-masked]>
Date: Wed, 2 May 2018 04:41:09 +0000

Hello, 

no objections from me either. 

Juha

-----Original Message-----
From: Peter Saint-Andre <[email-masked]> 
Sent: keskiviikko 2. toukokuuta 2018 6.25
To: Barry Leiba <[email-masked]>; Dale R. Worley <[email-masked]>
Cc: Alexey Melnikov <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Hakala, Juha E <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: Moving ahead with draft-spinosa-urn-lex

No objections here!

---

From: "Svensson, Lars" <[email-masked]>
Date: Wed, 2 May 2018 07:10:25 +0000

Fine with me, too.

Best,

Lars

> From: Hakala, Juha E [mailto:[email-masked]]
> Sent: Wednesday, May 02, 2018 6:41 AM
> To: Peter Saint-Andre <[email-masked]>; Barry Leiba
> <[email-masked]>; Dale R. Worley <[email-masked]>
> Cc: Alexey Melnikov <[email-masked]>; Svensson, Lars
> <[email-masked]>; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Subject: RE: Moving ahead with draft-spinosa-urn-lex
> 
> Hello,
> 
> Cc: Alexey Melnikov <[email-masked]>; [email-masked];
> [email-masked]; [email-masked]; [email-masked]; Hakala,
> Juha E <[email-masked]>; [email-masked]; [email-masked]