Subject: [urn] URN registration request for SCTE

From: Gary Hughes <[email-masked]>
Date: Tue, 20 Aug 2019 12:17:26 -0400

The Society of Cable Telecommunications Engineers (SCTE), an
ANSI-accredited SDO, is requesting fast track registration for the 'scte'
namespace identifier. The completed template follows.

regards,

Gary Hughes

=========================================================

IETF URN Registration for SCTE

*Namespace Identifier*:

scte

*Version*:

1

*Date*:*.*

2019-08-19

*Registrant*:

The Society of Cable Telecommunications Engineers (SCTE) standards program
is an ANSI-accredited Standards Development Organization for the
development of technical specifications supporting cable
telecommunications.  SCTE standards work includes: data and telephony over
cable; application platform development; digital video; emergency alert
systems; network monitoring systems; cables, connectors and amplifiers;
construction and maintenance practices;  energy management, and more.

Name:

Society of Cable Telecommunications Engineers

140 Philips Road, Exton, PA 19341-1318, USA

Designated contact:

 Role: Manager, Standards

 Email: [email-masked]

*Purpose*:*.*

Occasionally, SCTE specification efforts require identifiers in a managed
namespace so that they are unique and persistent.  To ensure that the
uniqueness is absolute, the registration of a specific Uniform Resource
Name (URN) Namespace Identifier (NID) for use by SCTE is being specified in
RFC8141, in full conformance with the NID registration process specified in
RFC8141 [RFC8141]

When SCTE specifications require the use of data models, URN Namespaces are
key constructs to manage the definitions of those data models reliably with
persistence and uniqueness.

The use of URNs should also help specification authors to maintain
different versions of URNs and dependencies between URNs across different
versions of SCTE specifications if they so wish.

*Syntax*:

The Namespace Specific String (NSS) of all URNs that use the "scte" NID
will have the following structure:

         urn:scte:{SCTEresource}:{ResourceSpecificString}

where the "SCTEresource" is a US-ASCII string that conforms to the URN
syntax requirements of [RFC8141].

SCTE publishes information regarding the registered resources in the
corresponding SCTE standards. The “SCTEresource” may be used to identify
the SCTE standard or the project which defined the URN. The
“ResourceSpecificString” specifies the name and optionally the edition
(year) of the standard that first defined the URN.

For example:

urn:scte:dash:essential-event:2015

Event essentiality, first defined in the 2015 edition of the SCTE DASH
specifications

urn:scte:scte35:2013:xml

XML representation of SCTE 35 commands, first defined in the 2013 edition
of ANSI/SCTE 35

Published SCTE standards are freely downloadable from the SCTE web site at:
https://www.scte.org/SCTE/Standards/Download_SCTE_Standards.aspx.

*Assignment**: *

SCTE will maintain a naming authority, the SCTE Assigned Names and Numbers
[SANN] specification, that will contain the assignment of SCTE resource
classes and the specific registration values assigned for each resource
class.  This specification will be published on the SCTE Standards Program
website (
https://www.scte.org/SCTE/Standards/SCTE_Assigned_Names_and_Numbers_specification.aspx)
and updated as needed.

The SANN specification will only document URNs defined in SCTE standards.

*Security and Privacy*:

There are no additional security considerations other than those normally
associated with the use and resolution of URNs in general, which are
described in [RFC8141].

*Interoperability**: *

SCTE standards are referenced by other SDOs and industry groups. Formally
registering the “scte” NID will help ensure that collisions do not occur.

*Resolution*:

The namespace is not listed with a resolution discovery system; this is not
applicable for this URN registration.

*Documentation*:

The SCTE Assigned Names and Numbers [SANN] specification will describe the
use of “scte” namespace and procedures for requesting assignment of new
resources and values in that namespace. This will be available at
https://www.scte.org/SCTE/Standards/SCTE_Assigned_Names_and_Numbers_specification.aspx

*Additional Information*:

Participants involved in the development and usage of SCTE specifications
and cable industry deployments will benefit from the publication of this
namespace by providing consistent and reliable   names for the XML
namespaces, schema locations, and similar identifiers of physical data
models published within SCTE specifications.

The SCTE specifications are publicly available and are licensed to
manufacturers on a nondiscriminatory basis.  SCTE will maintain the
corresponding specifications where the registered resources are referenced
or used.

*Revision Information*:

This application is a revision and resubmission of
draft-dthakore-scte-urn-00

---

From: [email-masked] (Dale R. Worley)
Date: Wed, 21 Aug 2019 21:39:18 -0400

Here are my comments on the registration.  There are a few places where
the text could be clarified.

Dale

There are some extra words in that last sentence.  I think you can
omit "RFC8141, in".

I'm not sure, but I think you want to replace "different versions of
URNs and dependencies between URNs" with "different versions of
identifiers and dependencies between ideentifiers" -- because of
course, the use of URNs is helpful in maintaining different versions
*of URNs*.  It's more interesting that use of URNs is helpful in
maintaining different versions of *identifiers* generally.

    *Syntax*:

The NSS is the part after "urn:scte:", so the above needs to be
edited.  (The definition of NSS is in RFC 8141, but it's not
particularly well pointed out.  The critical parts are:
      assigned-name = "urn" ":" NID ":" NSS
      ["assigned-name" is roughtly the same as "URN" as used here]
      NID           = (alphanum) 0*30(ldh) (alphanum)
      ldh           = alphanum / "-"
      NSS           = pchar *(pchar / "/")

One correct alternative is:
    All URNs that use the "scte" NID will have the following structure:

    where "{SCTEresource}" and "{ResourceSpecificString}" are
    US-ASCII strings such that the URN conforms to the syntax
    requirements of [RFC8141].

Is it intended that "SCTEresource" will never contain ":"?  If that is
true, then it is guaranteed that an SCTE URN can be uniquely parsed
into SCTEresource and ResourceSpecificString.  And if that restriction
is true, it would be helpful to state it here.

It would be particularly helpful to give a specific grammar for
SCTEresource and ResourceSpecificString.  In SCTE's case, I think this
is what you want:

    SCTEresource = ( unreserved / pct-encoded / sub-delims / "@" )
        *( unreserved / pct-encoded / sub-delims / "@" / "/" )

    ResourceSpecificString = *( pchar / "/" )

--

    SCTE publishes information regarding the registered resources in the
    corresponding SCTE standards. The "SCTEresource" may be used to identify
    the SCTE standard or the project which defined the URN. The
    "ResourceSpecificString" specifies the name and optionally the edition
    (year) of the standard that first defined the URN.

    For example:

The examples would be easier to read if the two example lines were
indented.  (Note that the recorded version of the registration will be
the *text* version.)

This is unclear.  Is "event essentiality" a property of some thing not
described here?  If so, it would help to say "A URN which designates
the property 'event essentiality' of XYZs ...".

    urn:scte:scte35:2013:xml

This is unclear.  In what sense is "XML representation" to be taken?
As phrased, it sounds like an abstract concept.  I suspect what you
mean is "The name of an XML namespace used to represent SCTE 35
commands".

    *Assignment**: *

Is this meant to imply that SCTE URNs can only be assigned via SCTE
standards -- or can they also be assigned in other ways, but only the
ones assigned in standards will be documented at
https://www.scte.org/SCTE/Standards/SCTE_Assigned_Names_and_Numbers_specification.aspx?
This needs to be clarified both here and in the Purpose and
Documentation sections.  And if the latter is intended, you need to
clarify how assignment of URNs not defined in standards is managed.

[END]

---

From: "Hakala, Juha E" <[email-masked]>
Date: Thu, 22 Aug 2019 10:27:14 +0000

Hello, 

I have only one additional comment to what Dale has already said. 

"When SCTE specifications require the use of data models, URN Namespaces are key constructs to manage the definitions of those data models reliably with persistence and uniqueness."

You are registering (and you will only ever need) a single URN Namespace which can be sub-divided further according to SCTE requirements. So you could say something like 

"When SCTE specifications require the use of data models, a registered URN Namespace which can sub-divided according to our requirements is a key construct to manage the definitions of those data models reliably with persistence and uniqueness."

Best regards, 

Juha

-----Original Message-----
From: urn <[email-masked]> On Behalf Of Dale R. Worley
Sent: torstai 22. elokuuta 2019 4.39
To: Gary Hughes <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [urn] URN registration request for SCTE

Here are my comments on the registration.  There are a few places where the text could be clarified.

Dale

There are some extra words in that last sentence.  I think you can omit "RFC8141, in".

I'm not sure, but I think you want to replace "different versions of URNs and dependencies between URNs" with "different versions of identifiers and dependencies between ideentifiers" -- because of course, the use of URNs is helpful in maintaining different versions *of URNs*.  It's more interesting that use of URNs is helpful in maintaining different versions of *identifiers* generally.

    *Syntax*:

The NSS is the part after "urn:scte:", so the above needs to be edited.  (The definition of NSS is in RFC 8141, but it's not particularly well pointed out.  The critical parts are:

Is it intended that "SCTEresource" will never contain ":"?  If that is true, then it is guaranteed that an SCTE URN can be uniquely parsed into SCTEresource and ResourceSpecificString.  And if that restriction is true, it would be helpful to state it here.

It would be particularly helpful to give a specific grammar for SCTEresource and ResourceSpecificString.  In SCTE's case, I think this is what you want:

--

    For example:

The examples would be easier to read if the two example lines were indented.  (Note that the recorded version of the registration will be the *text* version.)

This is unclear.  Is "event essentiality" a property of some thing not described here?  If so, it would help to say "A URN which designates the property 'event essentiality' of XYZs ...".

    urn:scte:scte35:2013:xml

This is unclear.  In what sense is "XML representation" to be taken?
As phrased, it sounds like an abstract concept.  I suspect what you mean is "The name of an XML namespace used to represent SCTE 35 commands".

    *Assignment**: *

Is this meant to imply that SCTE URNs can only be assigned via SCTE standards -- or can they also be assigned in other ways, but only the ones assigned in standards will be documented at https://www.scte.org/SCTE/Standards/SCTE_Assigned_Names_and_Numbers_specification.aspx?
This needs to be clarified both here and in the Purpose and Documentation sections.  And if the latter is intended, you need to clarify how assignment of URNs not defined in standards is managed.

[END]

_______________________________________________
urn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/urn

---

From: [email-masked]
Date: Fri, 23 Aug 2019 12:30:52 +0200

From me just a minor comment on Dale's comment:

> maintaining different versions of *identifiers* generally.

I read this not so much as "different versions of identifiers" but as "different versions of specifications [identified by identifiers/URNs]", so clarification really seems needed here.

Apart from that I agree with Dale's and Juha's comments.

Best,

Lars

---

From: Gary Hughes <[email-masked]>
Date: Mon, 26 Aug 2019 12:52:42 -0400

Dale, Juha, Lars,

thank you for the feedback and suggestions. I will shortly post a revised
version incorporating those changes.

Regarding the examples, my intent was to show examples of syntax, but I
will try to add some context without
going too far into the weeds.

Regarding "Is this meant to imply that SCTE URNs can only be assigned via
SCTE
standards"

Yes. This ensures that URN assignments are subject to the same review and
voting process as the standard. I
will clarify that.

regards,

gary

On Fri, Aug 23, 2019 at 6:30 AM <[email-masked]> wrote:

> I read this not so much as "different versions of identifiers" but as
> "different versions of specifications [identified by identifiers/URNs]", so
> clarification really seems needed here.
>

---

From: Gary Hughes <[email-masked]>
Date: Tue, 27 Aug 2019 15:52:00 -0400

Below is a revised version of the SCTE URN request form, hopefully
incorporating all of the comments and feedback.

regards,

gary

===============================================================================
IETF URN Registration for SCTE

Namespace Identifier:
scte

Version:
2

Date:
2019-08-27

Registrant:

Name:

Designated contact:
 Role: Manager, Standards

Purpose:
full conformance with the NID registration process specified in RFC8141
[RFC8141].

When SCTE specifications require the use of data models, a registered URN
Namespace which can be sub-divided according to our requirements is a key
construct to manage the definitions of those data models reliably with
persistence and uniqueness.

The use of URNs should also help specification authors to maintain
different versions of identifiers and dependencies between identifiers
across different versions of SCTE specifications if they so wish.

Specific URNs assigned in the ‘scte’ namespace are documented in the
defining SCTE standards.

Syntax:

Identifiers assigned in the ‘scte’ namespace will have the format

Identifier = “urn” “:” “scte” “:” NSS

       {SCTEresource}:{ResourceSpecificString}

where the "{SCTEresource}" and “{ResourceSpecificString}” are US-ASCII
strings such that the URN conforms to syntax requirements of [RFC8141].

The grammar for SCTEresource and ResourceSpecificString is as follows:

       SCTEresource = unreserved  *( unreserved / pct-encoded / sub-delims
/ "@" / "/" )

This precludes the use of “:” in “SCTEresource”.

SCTE publishes information regarding the registered resources in the
corresponding SCTE standards. The “SCTEresource” may be used to identify
the SCTE standard or the project which defined the URN. The
“ResourceSpecificString” specifies the resource name and optionally the
edition (year) of the standard that first defined the URN.

For example:

urn:scte:224:audience
Identifier of an XML namespace for audience-related metadata, defined in
ANSI/SCTE 224.

urn:scte:dash:essential-event:2015
Identifier used in an MPEG DASH EssentialProperty element to indicate that
a specified event stream is essential to the media presentation, first
defined in the 2015 edition of the SCTE DASH specifications

urn:scte:scte35:2013:xml
Identifier used in an MPEG DASH EventStream element to indicate that the
event message payloads are XML representations of SCTE 35 commands, as
first defined in the 2013 edition of ANSI/SCTE 35

Assignment:
All URNs that use the ‘scte’ NID are defined in SCTE standards.

SCTE will maintain a naming authority, the SCTE Assigned Names and Numbers
[SANN] specification, that will document the assignment of SCTE resource
classes and the specific registration values assigned for each resource
class along with references to the defining specification(s).  The SANN
 specification will be published on the SCTE Standards Program website (
https://www.scte.org/SCTE/Standards/SCTE_Assigned_Names_and_Numbers_specification.aspx
).

The SANN specification will be updated as needed after the defining
specification(s) have been balloted and approved.

Security and Privacy:

Interoperability:

Resolution:

Documentation:
The SCTE Assigned Names and Numbers [SANN] specification will describe the
use of ‘scte’ namespace and assigned identifiers in the ‘scte’ namespace
and the defining SCTE standard. This will be available at
https://www.scte.org/SCTE/Standards/SCTE_Assigned_Names_and_Numbers_specification.aspx

Details of URNs assigned in the ‘scte’ namespace are documented in the
defining SCTE standards.

Additional Information:

Revision Information:
v2: revised to incorporate feedback
v1: This application is a revision and resubmission of
draft-dthakore-scte-urn-00

---

From: [email-masked]
Date: Wed, 28 Aug 2019 09:37:01 +0200

Gary,

My comment has been addressed and I have no further comments.

Best,

Lars

Gesendet: Dienstag, 27. August 2019 um 21:52 Uhr

Von: "Gary Hughes" <[email-masked]>

An: [email-masked]

Cc: "Dean Stoneback" <[email-masked]>, [email-masked], "Paul Woidke" <[email-masked]>

Betreff: Re: [urn] URN registration request for SCTE

Below is a revised version of the SCTE URN request form, hopefully incorporating all of the comments and feedback.

regards,

gary

Namespace Identifier:

scte

Version:

2

Date:

2019-08-27

Registrant:

The Society of Cable Telecommunications Engineers (SCTE) standards program is an ANSI-accredited Standards Development Organization for the development of technical specifications supporting cable telecommunications.  SCTE standards work includes: data and telephony over cable; application platform development; digital video; emergency alert systems; network monitoring systems; cables, connectors and amplifiers; construction and maintenance practices; energy management, and more.

Name:

Designated contact:

Role: Manager, Standards

Purpose:

Occasionally, SCTE specification efforts require identifiers in a managed namespace so that they are unique and persistent.  To ensure that the uniqueness is absolute, the registration of a specific Uniform Resource Name (URN) Namespace Identifier (NID) for use by SCTE is being specified in full conformance with the NID registration process specified in RFC8141 [RFC8141].

When SCTE specifications require the use of data models, a registered URN Namespace which can be sub-divided according to our requirements is a key construct to manage the definitions of those data models reliably with persistence and uniqueness.

The use of URNs should also help specification authors to maintain different versions of identifiers and dependencies between identifiers across different versions of SCTE specifications if they so wish.

Specific URNs assigned in the ‘scte’ namespace are documented in the defining SCTE standards..

Syntax:

The Namespace Specific String (NSS) of all URNs that use the "scte" NID will have the following structure:

where the "{SCTEresource}" and “{ResourceSpecificString}” are US-ASCII strings such that the URN conforms to syntax requirements of [RFC8141].

SCTEresource = unreserved  *( unreserved / pct-encoded / sub-delims / "@" / "/" )

SCTE publishes information regarding the registered resources in the corresponding SCTE standards. The “SCTEresource” may be used to identify the SCTE standard or the project which defined the URN. The “ResourceSpecificString” specifies the resource name and optionally the edition (year) of the standard that first defined the URN.

For example:

urn:scte:224:audience

Identifier of an XML namespace for audience-related metadata, defined in ANSI/SCTE 224.

Identifier used in an MPEG DASH EssentialProperty element to indicate that a specified event stream is essential to the media presentation, first defined in the 2015 edition of the SCTE DASH specifications

urn:scte:scte35:2013:xml

Identifier used in an MPEG DASH EventStream element to indicate that the event message payloads are XML representations of SCTE 35 commands, as first defined in the 2013 edition of ANSI/SCTE 35

Published SCTE standards are freely downloadable from the SCTE web site at: https://www.scte.org/SCTE/Standards/Download_SCTE_Standards.aspx.

Assignment:

SCTE will maintain a naming authority, the SCTE Assigned Names and Numbers [SANN] specification, that will document the assignment of SCTE resource classes and the specific registration values assigned for each resource class along with references to the defining specification(s).  The SANN  specification will be published on the SCTE Standards Program website (https://www.scte.org/SCTE/Standards/SCTE_Assigned_Names_and_Numbers_specification.aspx).

The SANN specification will be updated as needed after the defining specification(s) have been balloted and approved.

Security and Privacy:

There are no additional security considerations other than those normally associated with the use and resolution of URNs in general, which are described in [RFC8141].

Interoperability:

SCTE standards are referenced by other SDOs and industry groups. Formally registering the “scte” NID will help ensure that collisions do not occur.

Resolution:

The namespace is not listed with a resolution discovery system; this is not applicable for this URN registration.

Documentation:

The SCTE Assigned Names and Numbers [SANN] specification will describe the use of ‘scte’ namespace and assigned identifiers in the ‘scte’ namespace and the defining SCTE standard. This will be available at https://www.scte.org/SCTE/Standards/SCTE_Assigned_Names_and_Numbers_specification.aspx

Details of URNs assigned in the ‘scte’ namespace are documented in the defining SCTE standards.

Additional Information:

Participants involved in the development and usage of SCTE specifications and cable industry deployments will benefit from the publication of this namespace by providing consistent and reliable   names for the XML namespaces, schema locations, and similar identifiers of physical data models published within SCTE specifications.

The SCTE specifications are publicly available and are licensed to manufacturers on a nondiscriminatory basis. SCTE will maintain the corresponding specifications where the registered resources are referenced or used.

Revision Information:

v1: This application is a revision and resubmission of draft-dthakore-scte-urn-00

Dale, Juha, Lars,

thank you for the feedback and suggestions. I will shortly post a revised version incorporating those changes.

Regarding the examples, my intent was to show examples of syntax, but I will try to add some context without

Regarding "Is this meant to imply that SCTE URNs can only be assigned via SCTE

standards"

Yes. This ensures that URN assignments are subject to the same review and voting process as the standard. I

will clarify that.

regards,

gary

Best,

Lars

_______________________________________________ urn mailing list [email-masked] https://www.ietf.org/mailman/listinfo/urn