Subject: Re: [urn] new draft 10 - new form (RE: new draft 9 - RE: new urn PWID draft (7) with corrections)

From: "Henry S. Thompson" <[email-masked]>
Date: Wed, 04 Dec 2019 14:21:27 +0000

Eld Zierau <[email-masked]> writes:

> Please see my comments below

>> -----Original Message-----
>> From: Henry S. Thompson <[email-masked]> 

>> The fourth constituent of a PWID, the *precision-spec*, now has only
>> two possible values, 'part' and 'page', which appear to be attempting
>> to distinguish between, respectively,
>>
>>  1) the representation that is/was retrievable for the archived-uri as
>>     at the archival-time;

> Eld: I guess you mean 'part' here, which in the specification is
> described as:
> "*  'part'
> ...

Yes.

> And I must admit that I do not see anything that can be interpreted
> as representation in this description, so I cannot follow you point
> here.

The relevant RFCs (3986, 7231, 8141) all use "representation" for the
actual result of a successful retrieval, that is, a message consisting
of a media type and an encoded character sequence interpretable with
respect to that media type.  That's precisely what you are talking about
in defining what you mean by 'part'.

> Please also note that introduction say that
>    "The purpose of the PWID URN is also to express a web archive
>    reference as simple as possible and at the same time meet the
>    requirements for sustainability, usability and scope.  Therefore, the
>    PWID URN is focused on having only the minimum required information
>    to make a precise identification of a resource in an arbitrary web
>    archive.  Recent research have shown that this can be obtained by the
>    following information [ResawRef]:
>
>    o  Identification of web archive
>
>    o  Identification of source:
>       *  Archived URI
>       *  Archival timestamp
>
>    o  Intended precision (page, part/file)"
>
> I could of course make it sharper by saying that 
>       *  Archival timestamp (the archives timestamp for when the URI was archived)
> But I must admit that I do not see it add value, and it is described several places throughout the specification
> (and therefore not included in attached version).

>>  2) a (Content-type conformant?) rendering of that representation
>>     (with all other digital objects implicated in that rendering
>>     ...

> Eld: I guess you mean 'page' here, which in the specification is described as:
> "* 'page'

Yes.

> ...

> So it is up to browser software to tell whether it is something that
> is interpreted as a page.

> And yes a page is "with all other digital objects implicated in that
> rendering (e.g. scripts, stylesheets, icons, graphics, fonts ...)",
> where I have used terms that are less technical "parts (display
> templates, images etc.)"

Precisely.  So it's a matter of rendering, or presentation, as
implemented by a browser, or any application appropriate to interpreting
the retrieved representation.

But, and again according to the relevant specifications, what you _do_
with a representation of a resource is a matter for the recipient of
that resource, which will be different for different users/uses at
different times.  The URI itself has nothing to say about that.

So now I can express more succinctly what I was confused about: the
*precision-spec* doesn't make sense, it's trying to pre-judge what
someone may want to do with a URI.

Insofar as one can state what a PWID identifies, it identifies

   the archival record maintained by the *archive-domain* for the
   representation retrieved at the *archival-time* of the state of the
   resource identified by the *archived-uri*.

So, if we construct a PWID with

   *archive-domain* web.archive.org
   *archived-uri*   https://link.springer.com/article/10.1007/JHEP12(2018)098
   *archival-time*  2019-11-18T06:00:21

it identifies such an archival record at the Internet Archive, whose
current representation can be retrieved via an HTTP GET request for

   https://web.archive.org/web/20191118060021/https://link.springer.com/article/10.1007/JHEP12(2018)098

If that GET request is performed using, say, the curl or wget
command-line tools, you will get what you call the 'part' as a file on
your local 'disk'.

If that GET request is performed using, say, Chrome or Safari, you will
see a presentation of what you call the 'page' on your screen.

>> How does this distinction survive a change of media type?  To
>> image/png, or application/pdf, or audio/ogg?

> Eld: The PWID is for referencing purposes, it is not concerned with
> types. The PWID is a reference to something that has been harvested
> from the internet and is supposed to be rendered by a browser, - so
> this is a concern of the original publisher of the element and the
> browser software.

URIs are not just for browsers!  Surely you don't want to restrict PWIDs
to URIs "that are supposed to be rendered by browsers".  All the talk in
your drafts about browsers and "View Source" is at best misleading, and
at worst suggests that PWIDs are only applicable to a very narrow view
of what archives may contain.

Consider PWIDs constructed from

   *archive-domain* web.archive.org
   *archived-uri*   https://media.springernature.com/w306/springer-static/cover/journal/13130/2018/12.jpg
   *archival-time*  2019-11-18T05:35:49

and

   *archive-domain* web.archive.org
   *archived-uri*   https://link.springer.com/content/pdf/10.1007%2FJHEP12%282018%29098.pdf
   *archival-time*  2019-11-18T06:00:05

which identify other archival records at the Internet Archive, whose
current representations can be retrieved via an HTTP GET request for

   https://web.archive.org/web/20191118053549im_/https://media.springernature.com/w306/springer-static/cover/journal/13130/2018/12.jpg

and

   https://web.archive.org/web/20191118060005/https://link.springer.com/content/pdf/10.1007%2FJHEP12%282018%29098.pdf

Perfectly useful, but the 'page'/'part' distinction doesn't make any
sense here, and 'View Source' is literally unusable.

Your spec would be much shorter, simpler and easier to understand, and
its potential utility much greater, if you removed the *precision-spec*
altogether, and made more use of the descriptive terminology and its
underlying semantics as found in the relevant RFCs mentioned above.

ht
-- 
       Henry S. Thompson, School of Informatics, University of Edinburgh
      10 Crichton Street, Edinburgh EH8 9AB, SCOTLAND -- (44) 131 650-4440
                Fax: (44) 131 650-4587, e-mail: [email-masked]
                       URL: http://www.ltg.ed.ac.uk/~ht/
 [mail from me _always_ has a .sig like this -- mail without it is forged spam]

The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.

---

From: "Henry S. Thompson" <[email-masked]>
Date: Wed, 04 Dec 2019 14:24:28 +0000

[resending with a elision of more original text which I didn't directly
respond to -- please ignore the preceding version]

Yes.

Yes.

and

and

ht

---

From: Eld Zierau <[email-masked]>
Date: Tue, 10 Dec 2019 13:19:24 +0000

Forgot to reply all - so therefore forwarded
Best Regards, Eld
-----Original Message-----
From: Eld Zierau 
Sent: Tuesday, December 10, 2019 11:55 AM
To: 'Henry S. Thompson' <[email-masked]>
Subject: RE: [urn] new draft 10 - new form (RE: new draft 9 - RE: new urn PWID draft (7) with corrections)

Hi

The PWID has been developed in collaboration with digital humanity researchers (literate and historian), who have requirements for precise and persistent references. The precision part is for specification of how precise a reference is, and what the purpose with the reference is. It is needed because of the nature of web material where a web page usually consist of many different parts that are harvested and archived individually. In the example of https://www.dr.dk, the differences are:
* 'Page':
       urn:pwid:archive.org:2016-01-22T10:08:23Z:page:https://www.dr.dk
    is a short hand of the archived version of the harvest of the file https://www.dr.dk on 2016-01-22T10:08:23Z 
    together with all the elements (existing in the web archive) needed in order to render it as a web page in a browser, 
    where the version of the elements is the ones with archiving date closest to 2016-01-22T10:08:23Z

* 'Part':
       urn:pwid:archive.org:2016-01-22T10:08:23Z:part:https://www.dr.dk
    is the exact file harvested of the file https://www.dr.dk on 2016-01-22T10:08:23Z

Both references are highly relevant, - 'page' because this is what is needed for most referencing purposes today, and part because it can be the code that is of interest or it can be part of a collection specification (see my response to Juha 11th of October 2019 15:44).

It is two very different things, and therefore it cannot be the same references. Furthermore, it provides the possibility for digital humanity researcher to make the precision. Please note that what you say "it's trying to pre-judge what someone may want to do with a URI" is NOT the case, it is telling you what the person making the reference want you to see if you use the reference.

If you want to view a web page consisting of different elements, the way to do that today is by use of a browser and a web archive tool to calculate the elements. And yes, there will be differences between browsers, just like Word documents looks very different depending on version fonts etc. That is nothing that a reference can or should solve. 

Please note, that use of the words "browser" and "View page source" are only used in explanation of how you can assign a PWID and resolve a PWID, and explanation of what part means for a coded page. There is nothing that suggests, that this is the only way to see it. The explanation/examples are needed, since the PWID is for all, including non-technical persons without knowledge of coded web pages and that there are different parts from different files. So I cannot see that the specification as it is now restrict PWIDs to URIs "that are supposed to be rendered by browsers", but since we are talking about web material it is likely that this is what the PWID will be used for.
Please also note, that both the examples that you give are files and therefore there will not be any "View page source" (I don't know whether that is why you say that "'View Source' is literally unusable", - since its absence is actually use for determination of the reference as a part) as explained in the instruction of how to creation a PWID in section "Assignment":
"precision-spec (part or page):
      The precision specification specifies how the referred item should
      be regarded.  A typical PWID URN reference in a paper would be
      'page', where a tool will be needed to render the web page.
      Alternatively, the precision-spec can be 'part', which is the most
      precise reference since it reference a specific file where no
      additional calculations are needed (e.g. as part of a collection,
      a specific html file with hidden links or to indicate that a
      single image is referenced).  In order to see whether a viewed
      browser page is a computed web page or a single file, browsers
      have a function "View page source" which is not activated if for
      single files). 
Best regards, Eld
-----
Eld Zierau
Digital Preservation Specialist PhD
The Royal Danish Library
Digital Cultural Heritage
P.O. Box 2149, 1016 Copenhagen K
Ph. +45 9132 4690
Email: [email-masked]

-----Original Message-----
From: Henry S. Thompson <[email-masked]>
Sent: Wednesday, December 4, 2019 3:24 PM
To: Eld Zierau <[email-masked]>
Cc: Hakala, Juha E <[email-masked]>; Peter Saint-Andre <[email-masked]>; [email-masked]
Subject: Re: [urn] new draft 10 - new form (RE: new draft 9 - RE: new urn PWID draft (7) with corrections)

[resending with a elision of more original text which I didn't directly respond to -- please ignore the preceding version]

Yes.

> And I must admit that I do not see anything that can be interpreted as 
> representation in this description, so I cannot follow you point here.

The relevant RFCs (3986, 7231, 8141) all use "representation" for the actual result of a successful retrieval, that is, a message consisting of a media type and an encoded character sequence interpretable with respect to that media type.  That's precisely what you are talking about in defining what you mean by 'part'.

Yes.

> where I have used terms that are less technical "parts (display 

Precisely.  So it's a matter of rendering, or presentation, as implemented by a browser, or any application appropriate to interpreting the retrieved representation.

But, and again according to the relevant specifications, what you _do_ with a representation of a resource is a matter for the recipient of that resource, which will be different for different users/uses at different times.  The URI itself has nothing to say about that.

So now I can express more succinctly what I was confused about: the
*precision-spec* doesn't make sense, it's trying to pre-judge what someone may want to do with a URI.

it identifies such an archival record at the Internet Archive, whose current representation can be retrieved via an HTTP GET request for

If that GET request is performed using, say, the curl or wget command-line tools, you will get what you call the 'part' as a file on your local 'disk'.

If that GET request is performed using, say, Chrome or Safari, you will see a presentation of what you call the 'page' on your screen.

> this is a concern of the original publisher of the element and the 

URIs are not just for browsers!  Surely you don't want to restrict PWIDs to URIs "that are supposed to be rendered by browsers".  All the talk in your drafts about browsers and "View Source" is at best misleading, and at worst suggests that PWIDs are only applicable to a very narrow view of what archives may contain.

and

which identify other archival records at the Internet Archive, whose current representations can be retrieved via an HTTP GET request for

and

Perfectly useful, but the 'page'/'part' distinction doesn't make any sense here, and 'View Source' is literally unusable.

Your spec would be much shorter, simpler and easier to understand, and its potential utility much greater, if you removed the *precision-spec* altogether, and made more use of the descriptive terminology and its underlying semantics as found in the relevant RFCs mentioned above.

ht
-- 
       Henry S. Thompson, School of Informatics, University of Edinburgh
      10 Crichton Street, Edinburgh EH8 9AB, SCOTLAND -- (44) 131 650-4440
                Fax: (44) 131 650-4587, e-mail: [email-masked]
                       URL: http://www.ltg.ed.ac.uk/~ht/  [mail from me _always_ has a .sig like this -- mail without it is forged spam]

The University of Edinburgh is a charitable body, registered in Scotland, with registration number SC005336.