Subject: Re: [urn] META URN namespace registration

From: [email-masked] (Dale R. Worley)
Date: Sun, 24 May 2020 11:23:01 -0400

"Hakala, Juha E" <[email-masked]> writes:
> I have received no feedback to the heavily revised urn:meta
> registration request which I posted in March, and without further
> comments there is not much I can do.

My apologies for not attending to this sooner.

I believe that the urn:meta proposal should be approved after the
following editorial issues have been resolved:

1. At different places in the document two alternative schemes for
delimiters in the syntax are specified or used.  The alternatives are:
(a) the prefix is subdivided using colons, and separated from the
meta-string by a hyphen, and (b) the prefix is subdivided using
hyphens, and separated from the meta-string by a colon.  Instances
are:

1A. The natural-language specification of the syntax uses (a):

    Syntax:  

    The Namespace-Specific String (NSS) consists of three parts:

       o a prefix consisting of a code identifying the metadata format and
	  optional sub-namespace code(s) separated by a colon(s); 

       o a hyphen (-) as the delimiting character; and,

    a string assigned under the auspices of the format maintenance agency. 

1B. The ABNF specification of the syntax uses (b):

	meta-nss     = prefix ":" meta-string

	prefix      = format-code *( "-" subspc )
		    ; The entire prefix is case insensitive.

1C. Some examples use (a):

    (and as a default) URNs http://example.com/urn:meta:marc-<nss>

    is http://example.com/, urn:meta:marc-bd245 would be resolved by

    http://example.com/urn:meta:marc-bd245 

    is http://example.com/, urn:meta:marc-ad100 would be resolved by

    http://example.com/urn:meta:marc-ad100  

Some examples use (b):

    Namespace URN:META:MARC: contains URNs which identify the tags of

    http://example.com/, urn:meta:dc-terms:title would be resolved by

    http://example.com/urn:meta:dc-terms:title 

2. The document recommends using hyphen as an internal delimiter in
meta-string.  This does not conflict with either (a) or (b), but the
author may want to coordinate this choice with the resolution of item 1.

    Within the meta-string, it is recommended that a hyphen is used
    for separating different sections of the identifier from one
    another in order to improve the human readability of the string.

3. The text uses the term "sub-namespace" but does not define it.  It
appears to mean the same as the ABNF symbol "subspc" (which is also
nused in the text).  I think the clearest solution is to replace
"subspc" in all three locations with "sub-namespace".

       o a prefix consisting of a code identifying the metadata format and
	  optional sub-namespace code(s) separated by a colon(s); 

	prefix      = format-code *( "-" subspc )
		    ; The entire prefix is case insensitive.
	subspc      = 1*(ALPHA / DIGIT)
		    ; As assigned by the respective format maintenance agency.

    Sub-namespaces may
    be used to differentiate formats within these format families if
    necessary.

    A registrant may provide additional base URLs for
    prefixes composed of that format-code and one or more following
    subspc's.

4. Comparing this usage of the example.com URL with the others, I
believe that it was intended to end with "/":

    In this example, URNs are expressed as HTTP URIs which use
    (non-existent) URN resolver located http://example.com.

5. In this example, "<nss>" should be "<meta-string>", unless I am
completely misreading its intention:

    (and as a default) URNs http://example.com/urn:meta:marc-<nss>

Dale

---

From: "Hakala, Juha E" <[email-masked]>
Date: Tue, 26 May 2020 10:05:28 +0000

Hello Dale, 

thank you for carefully reviewing the draft! 

Please find attached a version of URN:META URN namespace registration request in which the errors you found have been corrected. 

All: please let me know if there is anything else that still needs to be done before this request can be approved. 

Some details below. 

-----Alkuperäinen viesti-----
Lähettäjä: urn <[email-masked]> Puolesta Dale R. Worley
Lähetetty: sunnuntai 24. toukokuuta 2020 18.23
Vastaanottaja: [email-masked]
Aihe: Re: [urn] META URN namespace registration

I believe that the urn:meta proposal should be approved after the following editorial issues have been resolved:

1. At different places in the document two alternative schemes for delimiters in the syntax are specified or used.  The alternatives are:
(a) the prefix is subdivided using colons, and separated from the meta-string by a hyphen, and (b) the prefix is subdivided using hyphens, and separated from the meta-string by a colon.  

Juha: the text has been corrected now so that it uses just alternative (a) in ABNF and examples. 

Instances
are:

    Syntax:  

Some examples use (b):

2. The document recommends using hyphen as an internal delimiter in meta-string.  This does not conflict with either (a) or (b), but the author may want to coordinate this choice with the resolution of item 1.

Juha: this should be OK in its present form. 

3. The text uses the term "sub-namespace" but does not define it.  It appears to mean the same as the ABNF symbol "subspc" (which is also nused in the text).  I think the clearest solution is to replace "subspc" in all three locations with "sub-namespace".

Juha: I have made this change. 

    Sub-namespaces may

4. Comparing this usage of the example.com URL with the others, I believe that it was intended to end with "/":

Juha: correct, and the URI ends with / now. 

5. In this example, "<nss>" should be "<meta-string>", unless I am completely misreading its intention:

Juha: you are of course right. I replaced nss with meta-string.  

All the best, 

Juha
_______________________________________________
urn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/urn

---

From: [email-masked] (Dale R. Worley)
Date: Tue, 26 May 2020 22:55:00 -0400

This looks good to me, except possibly these:

You almost certainly don't want the final ":", as that presupposes that
a sub-namespace code will follow.  Other examples use "URN:META:MARC".

    Assuming that the registered resolver base URL for urn:meta:dc is
    http://example.com/, urn:meta:dc:terms-title would be resolved by
    fetching

    http://example.com/urn:meta:dc:terms-title

After looking at these again, I realize that there is an open question
whether the prefix is "dc:terms" or "dc".  There is no mention in the
registrations that "dc:terms" is a defined sub-namespace, but nothing
rules out that it exists.  If the intended prefix is "dc", then the URN
should be "urn:meta:dc-terms-title".  If the intended prefix is
"dc:terms", it would prevent the reader from making this mistake if you
state that explicitly.  Indeed, if "dc" is expected to have
sub-namespaces, it might be useful to annotate its registration with
their names.

Dale

---

From: "Hakala, Juha E" <[email-masked]>
Date: Wed, 27 May 2020 05:49:32 +0000

Hello Dale; all, 

I have made two changes to the registration request (see below). Please let me know if any further changes are required.  

-----Alkuperäinen viesti-----
Lähettäjä: Dale R. Worley <[email-masked]> 
Lähetetty: keskiviikko 27. toukokuuta 2020 5.55
Vastaanottaja: Hakala, Juha E <[email-masked]>
Kopio: [email-masked]
Aihe: Re: [urn] META URN namespace registration

You almost certainly don't want the final ":", as that presupposes that a sub-namespace code will follow.  Other examples use "URN:META:MARC".

Juha: I have removed the final ":" from the attached version. 

After looking at these again, I realize that there is an open question whether the prefix is "dc:terms" or "dc".  There is no mention in the registrations that "dc:terms" is a defined sub-namespace, but nothing rules out that it exists.  If the intended prefix is "dc", then the URN should be "urn:meta:dc-terms-title".  If the intended prefix is "dc:terms", it would prevent the reader from making this mistake if you state that explicitly.  Indeed, if "dc" is expected to have sub-namespaces, it might be useful to annotate its registration with their names.

Juha: Dublin Core has currently two namespaces, /terms/ and /elements/1.1/. In the registration request, there are now two Dublin Core -related sub-namespaces in the expanded Example 2, urn:meta:dc:terms and urn:meta:dc:elements1.1. 

FYI, elements from /elements/1.1/ are replicated as properties in /terms/, but definitions of these properties differ slightly from those used for elements in /elements/1.1/. Therefore property Title in /terms/ is not exactly the same as element Title in /elements/1.1/. 

Best regards, 

Juha