Subject: [urn] URN:DOI namespace registration request

From: "Hakala, Juha E" <[email-masked]>
Date: Fri, 2 Oct 2020 05:26:59 +0000

Hello all,

please find attached a URN namespace registration request for DOI, Digital Object Identifier. I have assisted Paul Jessop in writing the request and therefore shall exempt myself from evaluating the request. Any questions should be sent to Paul and Jonathan Clark.

Handle.Net resolver (http://www.handle.net/download_hnr.html) already supports URN representation of DOIs (https://doi.org/urn:doi:<doi<https://doi.org/urn:doi:%3cdoi>>) so every DOI is actionable also as URN. The resolver does not support URN R- or Q-components, but such functionality may be added to a future version.

Handles may be presented and resolved as URNs as well, with the NID HANDLE. I do not know if DONA Foundation (https://www.dona.net/) intends to request a URN namespace for Handles. However, NID "HANDLE" should not be granted to some other community.

All the best,

Juha

PS. The National Library of Finland has rebuilt its URN resolver. Following a beta test last summer, we are currently in the process of taking the new resolver into production. As far as I know, it is the first one supporting R component. The first service implemented was linking of a single URN to multiple URLs.

Once the resolver is "battle proven" and there is basic documentation available in English, the resolver will be made freely available in GitHub.

Juha Hakala
Senior advisor
Library Network Services, The National Library of Finland
P.O.Box 15 (Yliopistonkatu 1), 00014 Helsingin yliopisto
email [email-masked]<mailto:[email-masked]>

---

From: Julian Reschke <[email-masked]>
Date: Fri, 2 Oct 2020 16:43:59 +0200

Am 02.10.2020 um 07:26 schrieb Hakala, Juha E:
> Hello all,
>
> please find attached a URN namespace registration request for DOI,
> Digital Object Identifier. I have assisted Paul Jessop in writing the
> request and therefore shall exempt myself from evaluating the request.
> Any questions should be sent to Paul and Jonathan Clark.
> ...

How does this relate to the already registered "doi" URI scheme?

Best regards, Julian

---

From: "Hakala, Juha E" <[email-masked]>
Date: Wed, 14 Oct 2020 06:24:34 +0000

Hello Julian; all, 

please find attached Paul Jessop's response to your question on how URN namespace registration relates to the "doi" URI scheme.

Best regards,  

Juha

--------------------------------------------

The registration of a provisional scheme for DOI was made without the knowledge or consent of the DOI Foundation and we found out about it only once it had been done. We are not currently supporting it and remain sceptical that the ambitions of the group that has done this will result (as they hope) in the identifiers they have selected becoming resolvable in browsers. 

It seems that the provisional registration with our name on it has the effect of blocking anyone else using the string "doi" as a URI scheme for a different purpose and it will not go forward without our consent - so it is not in general harmful at the moment. We are tracking progress in case this group is able to do now what many failed to deliver in the past: create a table of schemes and action rules for use in browsers and get the competing applications to use it. This would not be a stupid thing to do as it would (for instance) have allowed the migration from dx.doi.org to doi.org to happen by pushing a revised rule to browsers rather than changing the presentation rules in every DOI system handbook.

But the focus of The DOI Foundation is on the registration of a URN namespace to allow DOI to be recognised as a technology independent identifier alongside NBN and the other namespaces that are used operationally.

Incidentally, one unexpected effect of the registration has been that some people looking at the IANA list think that the DOI system itself is "provisional" - rather than its registration as a URI scheme! Not much we can do about that I fear.

With best regards,

Paul Jessop
Technology Adviser, The DOI Foundation

-----Alkuperäinen viesti-----
Lähettäjä: urn <[email-masked]> Puolesta Julian Reschke
Lähetetty: perjantai 2. lokakuuta 2020 17.44
Vastaanottaja: [email-masked]
Aihe: Re: [urn] URN:DOI namespace registration request

Best regards, Julian

_______________________________________________
urn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/urn

---

From: Julian Reschke <[email-masked]>
Date: Wed, 14 Oct 2020 15:15:16 +0200

Am 14.10.2020 um 08:24 schrieb Hakala, Juha E:
> ... > The registration of a provisional scheme for DOI was made without the
knowledge or consent of the DOI Foundation and we found out about it
only once it had been done. We are not currently supporting it and
remain sceptical that the ambitions of the group that has done this will
result (as they hope) in the identifiers they have selected becoming
resolvable in browsers.
> It seems that the provisional registration with our name on it has the effect of blocking anyone else using the string "doi" as a URI scheme for a different purpose and it will not go forward witho…

Observation: the "reference" column for "doi" currently says:

    	[Frédéric_Wang][International_DOI_Foundation]

...so for some reason the entry *does* include the DOI foundation.

It would be good if people looking at the registry would actually get
some information about what the state of the entry actually is. I
recommend that the DOI foundation publishes a statement about what it is
and asks IANA to link to that in the "reference" column instead.

Best regards, Julian