Subject: Re: [urn] LEI namespace registration request

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 17 Dec 2021 13:47:41 -0700

Hi Ivan,

Thanks for your work on this and your patience with the review team.

Here are a few small suggestions regarding your request.

"Namespace Identifier:  Requested of IANA (formal)"

Presumably this should be:

"Namespace Identifier:  LEI"

We can probably shorten the "Purpose" section but it's fine as is 
(although let's remove the questions/guidance copied over from the 
template itself).

With regard to the syntax and equivalence, urn:LEI:foo should be 
equivalent to urn:lei:foo and in general we have not specified that the 
Namespace Identifier is uppercase (e.g., "LEI") with past registrations:

https://www.iana.org/assignments/urn-namespaces/urn-namespaces.xhtml

Everything else looks fine to me and I can work with IANA to add this 
NID to the registry.

Peter

On 9/21/21 2:21 AM, Ivan Marin wrote:
> Hi,
> 
> we have generated a new version attached adding some more information of 
> the existing LEI system (which we are asking the namespace registration 
> for) that is mature and providing already service world wide.
> 
> Let us know please if you need further information and what else is 
> needed from our side to get the namespace released.
> 
> Thanks,
> 
> *Ivan Marin*
> GLEIF Business Development
> . . . . . . . . . . . . . . . . . . . . . . . . . . .. . . . . . . . . .
> Global Legal Entity IdentifierFoundation (GLEIF)
> Bleichstrasse 59, 60313, Frankfurtam Main, Germany
> Work Phone: +49 69 9074999-22
> Cell phone: +34 670 246 255
> Email: [email-masked] <mailto:[email-masked]>
> Web: www.gleif.org <http://www.gleif.org>
> 
> 
> . . . . . . . . . . . . . . . . . . . . . . . . . . .. . . . . . . . . .
> Global Legal Entity IdentifierFoundation (GLEIF)
> St. Alban-Vorstadt 5, PO Box,4002 Basel, Switzerland
> Chairman of the Board: StevenJoachim
> CEO: Stephan Wolf
> Commercial-Register-No.: CHE-200.595.965
> LEI: 506700GE1G29325QX363
> 
> This message may containconfidential and/or privilegedinformation. If 
> you are not theintended recipient or if you havereceived this message in 
> error,please notify the sender anddelete this message. Anyunauthorised 
> copying, disclosureor distribution of this message is strictly forbidden.
> 
>> On 13 Sep 2021, at 10:01, Ivan Marin <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> Thanks for your feedback Mr. Worley.
>>
>> Besides the document shared, you can also find all the information 
>> regarding LEI here: 
>> https://www.gleif.org/en/about-lei/introducing-the-legal-entity-identifier-lei 
>> <https://www.gleif.org/en/about-lei/introducing-the-legal-entity-identifier-lei>
>>
>> Indeed as you have stated the LEI system is already well-developed and 
>> standardized and all the LEI namespace registration provides is a 
>> systematic way of mapping existing LEIs into URNs.
>>
>> We are willing to read your revised version. Let us know any question 
>> you may have.
>>
>> Regards,
>> Ivan Marin
>> GLEIF Business Development
>>
>>
>>
>> On 11/9/21, 04:10, "Dale R. Worley" <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>>    Please consider revising your descriptions to emphasize certain points
>>    which I only fully grasped as I had nearly finished reading the
>>    document.
>>
>>    When I started reading the document, I was unaware of the system of 
>> LEIs
>>    that already exists, and so without thinking I assumed that all of what
>>    you describe is a proposed system.  Instead, the LEI system is already
>>    well-developed and standardized and all the LEI namespace registration
>>    provides is a systematic way of mapping existing LEIs into URNs.
>>
>>    I suspect that this misunderstanding is due to minor matters of 
>> wording,
>>    combined with the fact that I was reading the registration quite
>>    quickly.  But as you prepare a revised version please consider my
>>    mistake.
>>
>>    Dale
>>
>>
> 
> 
> _______________________________________________
> urn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/urn

---

From: Ivan Marin <[email-masked]>
Date: Mon, 20 Dec 2021 09:01:01 +0000

Thanks Peter for your comments.

I have added suggested modifications:
- amended the title to: "Namespace Identifier:  LEI"
- urn:LEI:foo is equivalent to urn:lei:foo ... as the "LEI" name is not case sensitive.
- As is correct, I keep the template titles for easier reference in further reviews. 

Find version 7 attached.

Following your statement: "Everything else looks fine to me and I can work with IANA to add this NID to the registry."
We understand that you push it through the IANA registration process.

Which dates can we expect for its final release or publication?
Let us know please if further actions are needed on our side at this stage to make it happen.

Thanks for your support.

Regards,
Ivan Marin 

On 17/12/21, 21:47, "Peter Saint-Andre" <[email-masked]> wrote:

    Hi Ivan,

    

    

    
    
    Peter

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 20 Dec 2021 11:54:02 -0700

> We understand that you push it through the IANA registration process.

Yes, this is my responsibility because I am the team lead for the expert 
reviewers.

> Which dates can we expect for its final release or publication?

Although I'm not sure about the end-of-year schedule at IANA, I would 
say we can update the registry in the next few weeks (perhaps sooner).

> Let us know please if further actions are needed on our side at this stage to make it happen.

If you could send me a plaintext (non-PDF) version that would be great, 
because this is the format that we post at the registry (click on any of 
the "template" links):

Thanks!

Peter

---

From: Ivan Marin <[email-masked]>
Date: Tue, 21 Dec 2021 07:27:38 +0000

Hi Peter,
Find attached a text version as requested.

Let as you if this is enough for moving it forward in the process, please.

Thanks again for your support.

Ivan Marin
GLEIF Business Development
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Global Legal Entity Identifier Foundation (GLEIF)
Bleichstrasse 59, 60313, Frankfurt am Main, Germany
Work Phone: +49 69 9074999-22
Cell phone: +34 670 246 255
Email: [email-masked]<mailto:[email-masked]>
Web: www.gleif.org<http://www.gleif.org>

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Global Legal Entity Identifier Foundation (GLEIF)
St. Alban-Vorstadt 5, PO Box, 4002 Basel, Switzerland
Chairman of the Board: Steven Joachim
CEO: Stephan Wolf
Commercial-Register-No.: CHE-200.595.965
LEI: 506700GE1G29325QX363

This message may contain confidential and/or privileged information. If you are not the intended recipient or if you have received this message in error, please notify the sender and delete this message. Any unauthorised copying, disclosure or distribution of this message is strictly forbidden.

On 20 Dec 2021, at 19:54, Peter Saint-Andre <[email-masked]<mailto:[email-masked]>> wrote:

Yes, this is my responsibility because I am the team lead for the expert reviewers.

Although I'm not sure about the end-of-year schedule at IANA, I would say we can update the registry in the next few weeks (perhaps sooner).

If you could send me a plaintext (non-PDF) version that would be great, because this is the format that we post at the registry (click on any of the "template" links):

Thanks!

Peter

Thanks for your support.
Regards,
Ivan Marin
   On 17/12/21, 21:47, "Peter Saint-Andre" <[email-masked]<mailto:[email-masked]>> wrote:
         On 9/21/21 2:21 AM, Ivan Marin wrote:
    > Email: [email-masked]<mailto:[email-masked]> <mailto:[email-masked]>
    > Web: www.gleif.org<http://www.gleif.org> <http://www.gleif.org>
    >
    >
    >> On 13 Sep 2021, at 10:01, Ivan Marin <[email-masked]<mailto:[email-masked]>
    >> On 11/9/21, 04:10, "Dale R. Worley" <[email-masked]<mailto:[email-masked]>
    > [email-masked]<mailto:[email-masked]>

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 21 Dec 2021 07:59:19 -0700

Thanks, I can work with this and will proceed with IANA today.

On 12/21/21 12:27 AM, Ivan Marin wrote:
>>> Following your statement: "Everything else looks fine to me and I can 
>>> work with IANA to add this NID to the registry."
>> If you could send me a plaintext (non-PDF) version that would be 
>> great, because this is the format that we post at the registry (click 
>> on any of the "template" links):
>>
>> <https://www.iana.org/assignments/urn-namespaces/urn-namespaces.xhtml>
>>
>> Thanks!
>>
>> Peter
>>
>>> Thanks for your support.
>>> Regards,
>>> Ivan Marin
>>> <https://www.iana.org/assignments/urn-namespaces/urn-namespaces.xhtml>
>>>     > Hi,
>>>     >
>>>     > we have generated a new version attached adding some more 
>>> information of
>>>     > the existing LEI system (which we are asking the namespace 
>>> registration
>>>     > for) that is mature and providing already service world wide.
>>>     >
>>>     > Let us know please if you need further information and what else is
>>>     > needed from our side to get the namespace released.
>>>     >
>>>     > Thanks,
>>>     >
>>>     > *Ivan Marin*
>>>     > GLEIF Business Development
>>>     > . . . . . . . . . . . . . . . . . . . . . . . . . . .. . . . . 
>>> . . . . .
>>>     > Global Legal Entity IdentifierFoundation (GLEIF)
>>>     > Bleichstrasse 59, 60313, Frankfurtam Main, Germany
>>>     > Work Phone: +49 69 9074999-22
>>>     > Cell phone: +34 670 246 255
>>>     > Email: [email-masked] <mailto:[email-masked]> 
>>> <mailto:[email-masked] <mailto:[email-masked]>>
>>>     > Web: www.gleif.org <http://www.gleif.org> <http://www.gleif.org 
>>> <http://www.gleif.org>>
>>>     >
>>>     >
>>>     > . . . . . . . . . . . . . . . . . . . . . . . . . . .. . . . . 
>>> . . . . .
>>>     > Global Legal Entity IdentifierFoundation (GLEIF)
>>>     > St. Alban-Vorstadt 5, PO Box,4002 Basel, Switzerland
>>>     > Chairman of the Board: StevenJoachim
>>>     > CEO: Stephan Wolf
>>>     > Commercial-Register-No.: CHE-200.595.965
>>>     > LEI: 506700GE1G29325QX363
>>>     >
>>>     > This message may containconfidential and/or 
>>> privilegedinformation. If
>>>     > you are not theintended recipient or if you havereceived this 
>>> message in
>>>     > error,please notify the sender anddelete this message. 
>>> Anyunauthorised
>>>     > copying, disclosureor distribution of this message is strictly 
>>> forbidden.
>>>     >
>>>     >> On 13 Sep 2021, at 10:01, Ivan Marin <[email-masked] 
>>> <mailto:[email-masked]>
>>>     >> <mailto:[email-masked] <mailto:[email-masked]>>> 
>>> wrote:
>>>     >>
>>>     >> Thanks for your feedback Mr. Worley.
>>>     >>
>>>     >> Besides the document shared, you can also find all the information
>>>     >> regarding LEI here:
>>>     >>https://www.gleif.org/en/about-lei/introducing-the-legal-entity-identifier-lei 
>>>     >> 
>>> <https://www.gleif.org/en/about-lei/introducing-the-legal-entity-identifier-lei 
>>> <https://www.gleif.org/en/about-lei/introducing-the-legal-entity-identifier-lei>>
>>>     >>
>>>     >> Indeed as you have stated the LEI system is already 
>>> well-developed and
>>>     >> standardized and all the LEI namespace registration provides is a
>>>     >> systematic way of mapping existing LEIs into URNs.
>>>     >>
>>>     >> We are willing to read your revised version. Let us know any 
>>> question
>>>     >> you may have.
>>>     >>
>>>     >> Regards,
>>>     >> Ivan Marin
>>>     >> GLEIF Business Development
>>>     >>
>>>     >>
>>>     >>
>>>     >> On 11/9/21, 04:10, "Dale R. Worley" <[email-masked] 
>>> <mailto:[email-masked]>
>>>     >> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>>>     >>
>>>     >>    Please consider revising your descriptions to emphasize 
>>> certain points
>>>     >>    which I only fully grasped as I had nearly finished reading the
>>>     >>    document.
>>>     >>
>>>     >>    When I started reading the document, I was unaware of the 
>>> system of
>>>     >> LEIs
>>>     >>    that already exists, and so without thinking I assumed that 
>>> all of what
>>>     >>    you describe is a proposed system.  Instead, the LEI system 
>>> is already
>>>     >>    well-developed and standardized and all the LEI namespace 
>>> registration
>>>     >>    provides is a systematic way of mapping existing LEIs into 
>>> URNs.
>>>     >>
>>>     >>    I suspect that this misunderstanding is due to minor matters of
>>>     >> wording,
>>>     >>    combined with the fact that I was reading the registration 
>>> quite
>>>     >>    quickly.  But as you prepare a revised version please 
>>> consider my
>>>     >>    mistake.
>>>     >>
>>>     >>    Dale
>>>     >>
>>>     >>
>>>     >
>>>     >
>>>     > _______________________________________________
>>>     > urn mailing list
>>>     >[email-masked] <mailto:[email-masked]>
>>>     >https://www.ietf.org/mailman/listinfo/urn 
>>> <https://www.ietf.org/mailman/listinfo/urn>
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 22 Dec 2021 11:58:57 -0700

This is now done:

https://www.iana.org/assignments/urn-namespaces

Peter

On 12/21/21 7:59 AM, Peter Saint-Andre wrote:
>> you are not theintended recipient or if you havereceived this message 
>> in error,please notify the sender anddelete this message. 
>> Anyunauthorised copying, disclosureor distribution of this message 
>> is strictly forbidden.
>>
>>>> Following your statement: "Everything else looks fine to me and I 
>>>> can work with IANA to add this NID to the registry."
>>>>     > Web: www.gleif.org <http://www.gleif.org> 
>>>> <http://www.gleif.org <http://www.gleif.org>>
>>>>     >
>>>>     >
>>>>     >>    that already exists, and so without thinking I assumed 
>>>> that all of what
>>>>     >>    you describe is a proposed system.  Instead, the LEI 
>>>> system is already

---

From: Ivan Marin <[email-masked]>
Date: Wed, 22 Dec 2021 20:53:24 +0000

Great news Peter!

Thanks for your support!

Regards,

Ivan Marin

> On 22 Dec 2021, at 19:59, Peter Saint-Andre <[email-masked]> wrote:
> 
> This is now done:
> 
>>> This message may containconfidential and/or privilegedinformation. If you are not theintended recipient or if you havereceived this message in error,please notify the sender anddelete this message. Anyunauthorised copying, disclosureor distribution of this message is strictly forbidden.
>>> 
>>>> On 20 Dec 2021, at 19:54, Peter Saint-Andre <[email-masked] <mailto:[email-masked]>> wrote:
>>>> 
>>>> https://www.iana.org/assignments/urn-namespaces/urn-namespaces.xhtml <https://www.iana.org/assignments/urn-namespaces/urn-namespaces.xhtml>
>>>> 
>>>> Thanks!
>>>> 
>>>> Peter
>>>> 
>>>>> Thanks for your support.
>>>>> Regards,
>>>>> Ivan Marin
>>>>>    On 17/12/21, 21:47, "Peter Saint-Andre" <[email-masked] <mailto:[email-masked]>> wrote:
>>>>>     Hi Ivan,
>>>>> https://www.iana.org/assignments/urn-namespaces/urn-namespaces.xhtml <https://www.iana.org/assignments/urn-namespaces/urn-namespaces.xhtml>
>>>>>     > Email: [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>>>>>     > Web: www.gleif.org <http://www.gleif.org> <http://www.gleif.org <http://www.gleif.org>>
>>>>>     >
>>>>>     >
>>>>>     >> On 13 Sep 2021, at 10:01, Ivan Marin <[email-masked] <mailto:[email-masked]>
>>>>>     >> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>>>>>     >>
>>>>>     >>https://www.gleif.org/en/about-lei/introducing-the-legal-entity-identifier-lei <https://www.gleif.org/en/about-lei/introducing-the-legal-entity-identifier-lei> 
>>>>>     >> <https://www.gleif.org/en/about-lei/introducing-the-legal-entity-identifier-lei <https://www.gleif.org/en/about-lei/introducing-the-legal-entity-identifier-lei>> 
>>>>>     >>
>>>>>     >> On 11/9/21, 04:10, "Dale R. Worley" <[email-masked] <mailto:[email-masked]>
>>>>>     >> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>>>>>     >>
>>>>>     >[email-masked] <mailto:[email-masked]>
>>>>>     >https://www.ietf.org/mailman/listinfo/urn <https://www.ietf.org/mailman/listinfo/urn>
>>>