Subject: Re: [Uta] Updated MTA-STS & TLSRPT

From: "Brotman, Alexander" <[email-masked]>
Date: Mon, 2 Oct 2017 20:33:01 +0000

James, 

Do you mean the section where the policy-string was declared?  There are other references to RFC7493.  If you'd like, I can add another reference to RFC7159 in the document as well.  It was originally there to explicitly reference the section about the serialization for including the STS policy (which was a JSON body itself, which no longer is the case).

--
Alex Brotman
Sr. Engineer, Anti-Abuse
Comcast

-----Original Message-----
From: James Cloos [mailto:[email-masked]] 
Sent: Friday, September 29, 2017 2:54 PM
To: Brotman, Alexander <[email-masked]>
Cc: [email-masked]
Subject: Re: [Uta] Updated MTA-STS & TLSRPT

>>>>> "BA" == Brotman, Alexander <[email-masked]> writes:

BA> TLSRPT: Changed the domains associated with reporting, added 
BA> examples for policy-strings, and added a MUST for not using l= for 
BA> the DKIM signature

Looking at the diff, I noticed that the reference to RFC7159 (JSON) got dropped.  Given that json is still in the draft, I can't tell whether that was intentional.

-JimC
-- 
James Cloos <[email-masked]>         OpenPGP: 0x997A9F17ED7DAEA6

---

From: James Cloos <[email-masked]>
Date: Mon, 02 Oct 2017 20:20:05 -0400

>>>>> Brotman, Alexander <[email-masked]> writes:

> Do you mean the section where the policy-string was declared?

I read the side-by-side diff and noticed that the json rfc ws no longer
in the references list, but the string json still showed up several
places.

Hense the q as to whether that change was intentional or inadvertent.

Especially since you'd added a ref the to case-insensitive rfc.  I
couldn't tell whether something typo-ish had occurred.

> It was originally there
> to explicitly reference the section about the serialization for
> including the STS policy (which was a JSON body itself, which no
> longer is the case).

But that looks like the change was intentional.

-JimC