Subject: [Uta] Typo in MTA-STS policy definition (draft-ietf-uta-mta-sts-21)

From: Richard Gray <[email-masked]>
Date: Wed, 5 Sep 2018 21:49:49 +1200

Is there a typo in the formal definition of an MTA-STS policy in 
draft-ietf-uta-mta-sts-21 section 3.2?

Specifically, sts-policy-mx is not referenced from anywhere else in the 
ABNF definition. It seems that this was referenced by sts-policy-field 
in version 20 of the draft, but went missing in version 21. The 
identifiers sts-policy-mx-label and sts-policy-mx-toplabel also seem to 
be "orphaned" in this way.

Regards,
-- 

*Richard Gray* | Operations Technical Lead
*DDI:* +64 9 950 2196 *Fax:* +64 9 302 0518
*Mobile:* +64 21 050 8178 *Freephone:*0800 SMX SMX (769 769)
*SMX Limited:* Level 10, 19 Victoria Street West, Auckland, New Zealand
*Web:* http://smxemail.com
SMX | Cloud Email Hosting & Security

_____________________________________________________________________________

This email has been filtered by SMX. For more info visit http://smxemail.com
_____________________________________________________________________________

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 5 Sep 2018 12:02:51 +0100

Hi Richard,

> On 5 Sep 2018, at 10:49, Richard Gray <[email-masked]> wrote:
> 
> Is there a typo in the formal definition of an MTA-STS policy in draft-ietf-uta-mta-sts-21 section 3.2?
> 
> Specifically, sts-policy-mx is not referenced from anywhere else in the ABNF definition. It seems that this was referenced by sts-policy-field in version 20 of the draft, but went missing in version 21. The identifiers sts-policy-mx-label and sts-policy-mx-toplabel also seem to be "orphaned" in this way.
You are correct. There were a few more typos found, which should be fixed before the final RFC is published.

I recorded some of the issues found so far at <https://datatracker.ietf.org/doc/draft-ietf-uta-mta-sts/writeup/>

Best Regards,
Alexey
> 
> Regards,
> -- 
> Richard Gray | Operations Technical Lead 
> DDI: +64 9 950 2196 Fax: +64 9 302 0518 
> Mobile: +64 21 050 8178 Freephone:0800 SMX SMX (769 769) 
> SMX Limited: Level 10, 19 Victoria Street West, Auckland, New Zealand 
> Web: http://smxemail.com 
> 
> 
> This email has been filtered by SMX. For more information visit smxemail.com.
> _______________________________________________
> Uta mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uta