Subject: [Uta] Adoption call for draft-tschofenig-uta-tls13-profile-04

From: "Valery Smyslov" <[email-masked]>
Date: Fri, 15 May 2020 10:53:12 +0300

Hi, 

during the last  virtual interim meeting the
draft-tschofenig-uta-tls13-profile-04
was discussed. The authors of the draft asked for its adoption by the WG and
a 
quick poll during the meeting indicated that participants were in favor of
the adoption.

This message starts a two weeks call for adoption of the
draft-tschofenig-uta-tls13-profile-04 draft to confirm the results we saw at
the meeting.
The call will end up 30 May 2020. Please send your opinions to the list
before this date.

Please if possible include any reasons supporting your opinion. If you
support this adoption, 
please indicate whether you are ready to review this draft if it becomes a
WG document.

Regards,
Leif & Valery.

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 15 May 2020 11:38:42 +0000

Thanks, Valery for starting the call for adoption.

Let me provide a bit of context for those who weren't able to attend the virtual interim meeting*.

RFC 7925 provided profiles for IoT devices concerning the use of TLS and DTLS 1.2. These profiles are used today in deployments and other SDOs are referencing that RFC for their IoT protocol specifications.

While there were many aspects to consider in 1.2 there are far fewer in 1.3 because the TLS 1.3 specification was only finished mid 2018 and the DTLS 1.3 RFC is about to get finalized now. However, there are two areas were definitely need to say something about 1.3 usage in IoT environments, namely
* Algorithm recommendations (because those are different than the algorithms used on the web), and
* the use of 0-RTT in IoT protocols like CoAP and MQTT.

In addition to those points there are some recommendations that would be helpful to cover in  draft-tschofenig-uta-tls13-profile-04, which are relevant for 1.2 as well as 1.3, such as the use of alternative certificate formats (using CBOR encoding). This was a point raised by John. Other aspects include the use of CIDs and how they relate to CoAP and CoAP Observe, the use of "unlimited" certificate lifetime for certificates that are part of the root of trust on those devices, and there are more items in the slide deck*.

The participants at the call asked for the scope to be restricted to TLS/DTLS and not to focus on cTLS because it would otherwise take longer to complete this work.

I believe this work is useful for the IoT community since TLS/DTLS is used by all major IoT device management providers.

Ciao
Hannes

(*): Slides presented at the virtual interim meeting are here:
https://datatracker.ietf.org/meeting/interim-2020-uta-01/materials/slides-interim-2020-uta-01-sessa-tlsdtls-profiles-for-the-internet-of-things

-----Original Message-----
From: Valery Smyslov <[email-masked]>
Sent: Friday, May 15, 2020 9:53 AM
To: [email-masked]
Cc: [email-masked]; Hannes Tschofenig <[email-masked]>; Thomas Fossati <[email-masked]>
Subject: Adoption call for draft-tschofenig-uta-tls13-profile-04

Hi,

during the last  virtual interim meeting the
draft-tschofenig-uta-tls13-profile-04
was discussed. The authors of the draft asked for its adoption by the WG and a quick poll during the meeting indicated that participants were in favor of the adoption.

This message starts a two weeks call for adoption of the
draft-tschofenig-uta-tls13-profile-04 draft to confirm the results we saw at the meeting.
The call will end up 30 May 2020. Please send your opinions to the list before this date.

Please if possible include any reasons supporting your opinion. If you support this adoption, please indicate whether you are ready to review this draft if it becomes a WG document.

Regards,
Leif & Valery.

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Eric Rescorla <[email-masked]>
Date: Sat, 23 May 2020 10:49:45 -0700

I am in favor of adoption and am willing to review.

I note that this requires CCM8. ISTM that the analysis of this we just
landed in DTLS should call this into question.

-Ekr

On Fri, May 15, 2020 at 12:54 AM Valery Smyslov <[email-masked]> wrote:

> _______________________________________________
> Uta mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uta
>

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 25 May 2020 16:18:39 +1000

I want to second that.  I will note that RFC 7925 doesn't really point to any drawbacks of a short authentication tag, implying only that they are better because of their smaller size.  The recent analysis we've done suggests that the small tag forces a tough trade-off between DoS resistance and forgery protection.  I think that the mandatory suite should be more conservatively selected, even if the non-recommended suite is used for a more narrow set of cases.

---

From: Loganaden Velvindron <[email-masked]>
Date: Mon, 25 May 2020 10:44:10 +0400

> quick poll during the meeting indicated that participants were in favor of
I support adoption and i'm willing to review.

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 27 May 2020 06:28:03 +0000

Hi Loganaden,

> I support adoption and i'm willing to review.

Thanks for your support and your willingness to review the spec.

Ciao
Hannes

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 27 May 2020 06:29:41 +0000

Hi Ekr, Hi Martin,

Thanks for  support.

The algorithm selection (specifically the topic of CCM_8 vs. plain CCM) is something to debate.

Ciao
Hannes

From: Eric Rescorla <[email-masked]>
Sent: Saturday, May 23, 2020 7:50 PM
To: Valery Smyslov <[email-masked]>
Cc: [email-masked]; [email-masked]; Hannes Tschofenig <[email-masked]>; Thomas Fossati <[email-masked]>
Subject: Re: [Uta] Adoption call for draft-tschofenig-uta-tls13-profile-04

I note that this requires CCM8. ISTM that the analysis of this we just landed in DTLS should call this into question.

-Ekr

On Fri, May 15, 2020 at 12:54 AM Valery Smyslov <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,
Leif & Valery.

_______________________________________________
Uta mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/uta
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: "Valery Smyslov" <[email-masked]>
Date: Thu, 28 May 2020 11:21:03 +0300

Hi,

this is just a reminder that the call for adoption is still in progress.
So far we have received few replies comparing to the number of 
people who hummed for the adoption at the meeting.
For those who haven't done it yet - please confirm your hum on the list.

Regards,
Leif & Valery.

> was discussed. The authors of the draft asked for its adoption by the WG
and a
> quick poll during the meeting indicated that participants were in favor of
the
> adoption.
> draft-tschofenig-uta-tls13-profile-04 draft to confirm the results we saw
at the
> meeting.
before
> this date.
support
> this adoption, please indicate whether you are ready to review this draft
if it
> becomes a WG document.