Subject: [V3] LB / Failure Detection

From: "Asveren, Tolga" <[email-masked]>
Date: Mon, 30 Mar 2020 19:19:55 -0400

A basic question about how RIPT would make things better compared to RTP in terms of making use of Public Cloud Load-balancers:

With RTP: One can use L4 LB distributing traffic to a Redundancy Group. The pain point is that LB is slow in detecting failures of Redundancy Group members.
With RIPT media: One can use HTTP LB distributing traffic a Redundancy Group. I would think failure detection characteristics will be similar to L4 LB and delayed failure detection issue would continue to be an issue.

In a nutshell, what would one gain by using a HTTP LB instead of L4 LB?

Thanks,
Tolga

-----------------------------------------------------------------------------------------------------------------------
Notice: This e-mail together with any attachments may contain information of Ribbon Communications Inc. that
is confidential and/or proprietary for the sole use of the intended recipient.  Any review, disclosure, reliance or
distribution by others or forwarding without express permission is strictly prohibited.  If you are not the intended
recipient, please notify the sender immediately and then delete all copies, including any attachments.
-----------------------------------------------------------------------------------------------------------------------

---

From: "Mo Zanaty (mzanaty)" <[email-masked]>
Date: Wed, 1 Apr 2020 05:35:26 +0000

> In a nutshell, what would one gain by using a HTTP LB instead of L4 LB?

There are many reasons why HTTP apps use HTTP LB instead of (or in addition to) L4 LB, such as flexibility, programmability, feature rich ecosystem, etc. The HTTP list may be a better place for such a question and discussion though, since this is not specific to RIPT, but applies to all HTTP apps.

Thanks,
Mo

On 3/30/20, 7:19 PM, "V3 on behalf of Asveren, Tolga" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Thanks,
Tolga

________________________________
Notice: This e-mail together with any attachments may contain information of Ribbon Communications Inc. that is confidential and/or proprietary for the sole use of the intended recipient. Any review, disclosure, reliance or distribution by others or forwarding without express permission is strictly prohibited. If you are not the intended recipient, please notify the sender immediately and then delete all copies, including any attachments.
________________________________