Subject: Re: [V3] RIPT BoF approved for IETF 107 - Draft charter below

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 2 Mar 2020 16:23:16 +0000

Thanks Roni. I think its clear we want datagrams for media in general. The trick here is how to get them while utilizing http3 as the transport.

From: Roni Even (A) <[email-masked]>
Sent: Saturday, February 29, 2020 2:51 AM
To: Jonathan Rosenberg <[email-masked]>; [email-masked]
Cc: Cullen Jennings (fluffy) <[email-masked]>
Subject: RE: RIPT BoF approved for IETF 107 - Draft charter below

Hi,
I read the drafts. I like the idea of having the endpoint capabilities known in advance making call establishment simpler. We have the must support codecs in RTCweb and this is a step forwards. Maybe it is also about time to deprecate the "MUST support H.261/G.711" in older documents (H.323,...).
As for media transport, I think that Jorge and Colin document provide good starting point and motivation why to use datagrams for the media and it is my preference for conversional services to have the application layer decide if to retransmit.  My view is that for audio it is not needed (use redundancy, the best retransmission is for the listener to say "I could not hear it, can you please repeat".
As for video my view is that the requirement is not retransmission but re-synchronize. For "talking heads" video conference just resynch and continue.

Roni

From: V3 [mailto:[email-masked]] On Behalf Of Jonathan Rosenberg
Sent: Saturday, February 15, 2020 12:00 AM
To: [email-masked]<mailto:[email-masked]>
Cc: Cullen Jennings (fluffy)
Subject: [V3] RIPT BoF approved for IETF 107 - Draft charter below

Good news folks - RIPT bof was approved for IETF107 and we'll be meeting. Goal is to try and get a WG formed. As such, charter discussion is in order. Cullen, myself and Justin worked a draft charter. Comments please:

This working group will standardize a protocol, capable of operating
atop HTTP/3, which supports real-time voice and video communications,
including signaling, media negotiation, and transmission of media
packets.

The primary rationale for this new protocol is to enable deployment of
real-time communications services on modern "cloud" systems. These
systems are built around HTTP, and for HTTP-based applications, they
enable load balancing, HA, auto-scaling, and so on. However, real-time
communications protocols are based on SIP and RTP, and they cannot take
advantage of these HTTP-based capabilities.

It is a non-goal of this working group to replicate all of SIP and its
many extensions into HTTP. The group will limit itself to supporting the
functionality in widespread actual usage today.

The protocol uses HTTP techniques for authentication and authorization
(notably OAuth), and requires hop by hop encryption (i.e., https). The
protocol will also allow for e2e media encryption, although keying is
out of scope, and is expected to be handled by other protocols such as
MLS. This extension will also utilize STIR for callerID.

This protocol should be implementable in browsers, thick desktop
clients, mobile apps and servers.

The group will standardize an extension to the baseline protocol that
automates the configuration necessary to achieve calling between on
organization which is a customer of the other (for example, enterprise
to service provider).

[OPEN ISSUE: Is P2P media in or out? If in, ICE or something else ?]

The group will do its work in conjunction with active software
development efforts, so that implementation experience feeds directly
into protocol development.

The group will coordinate with the Webtranport, QUIC, HTTPbis and STIR
working groups.

Milestones:

Dec 2020: Submit baseline protocol to IESG
Mar 2021: Submit autoconfiguration protocol to IESG

Thx,
Jonathan R.

--
Jonathan Rosenberg
CTO and Head of AI, Five9

________________________________

CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain confidential information of Five9 and/or its affiliated entities. Access by the intended recipient only is authorized. Any liability arising from any party acting, or refraining from acting, on any information contained in this e-mail is hereby excluded. If you are not the intended recipient, please notify the sender immediately, destroy the original transmission and its attachments and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Copyright in this e-mail and any attachments belongs to Five9 and/or its affiliated entities.

________________________________

CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain confidential information of Five9 and/or its affiliated entities. Access by the intended recipient only is authorized. Any liability arising from any party acting, or refraining from acting, on any information contained in this e-mail is hereby excluded. If you are not the intended recipient, please notify the sender immediately, destroy the original transmission and its attachments and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Copyright in this e-mail and any attachments belongs to Five9 and/or its affiliated entities.

---

From: "Roni Even (A)" <[email-masked]>
Date: Tue, 3 Mar 2020 07:02:32 +0000

Hi Jonathan,
I think we also need to look how to convey the RTP extensions that may be needed (RFC5104) and the RTCP feedback, I found Jorge and Colin suggestion to use the QUIC reliable streams as a good direction, also unlike UDP when using QUIC you create a bi-directional connection.
I am not that good with HTTP3, I probably need to learn more
Regards
Roni

From: V3 [mailto:[email-masked]] On Behalf Of Jonathan Rosenberg
Sent: Monday, March 02, 2020 6:23 PM
To: Roni Even (A); [email-masked]
Cc: Cullen Jennings (fluffy)
Subject: Re: [V3] RIPT BoF approved for IETF 107 - Draft charter below

From: Roni Even (A) <[email-masked]<mailto:[email-masked]>>
Sent: Saturday, February 29, 2020 2:51 AM
To: Jonathan Rosenberg <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Cullen Jennings (fluffy) <[email-masked]<mailto:[email-masked]>>
Subject: RE: RIPT BoF approved for IETF 107 - Draft charter below

Hi,

Roni

Milestones:

Thx,
Jonathan R.