Subject: [v4tov6transition] troubling survey

From: Ed Jankiewicz <[email-masked]>
Date: Thu, 16 Sep 2010 16:32:21 -0400

http://gcn.com/articles/2010/09/14/adoption-of-ipv6-is-slow.aspx

as the article notes, something like 10% of ISPs responded "No plans to 
implement IPv6" as in not even thinking about EVER doing it.  Overall, 
including end-user organizations there is still a lackluster interest in 
doing IPv6 now or soon.  And big reasons include "lack of knowledgeable 
staff", "lack of experience", "no business case/user demand" and 
"technical problems".   Real or perceived, getting better information 
out to marketplace about what you really need to know and need to do 
would help.  I hope that's what this list is about.

http://www.nro.net/documents/GlobalIPv6SurveySummaryv2.pdf

-- 
Ed Jankiewicz - SRI International
Fort Monmouth Branch Office - IPv6 Research
Supporting DISA Standards Engineering Branch
732-389-1003 or  [email-masked]

---

From: "Yiu L. Lee" <[email-masked]>
Date: Thu, 16 Sep 2010 17:30:31 -0400

Hi Ed,

Thanks for sharing this information to the list.

When I read the data in the PDF file, it shows some good uptake. On Page 11,
57.6% ISP responded "YES" and 32.7% responded "Maybe" to consider promoting
IPv6. Only 9.7% said "NO". On Page 13, 84.3% responded they would consider
to allocate IPv6 in 2010. This is pretty high number. What disappointed me a
little is only 55% responded to make sure IPv6 supported in their products.

On Page 17, 60% out of 84% who indicated to consider to support IPv6
responded worry about vendor support of IPv6. This high number may reflect
the lack of IPv6 support for back office systems and applications. But I
don't find the detailed breakdown.

According to this survey, it seems the adoption rate is improving but still
not as high as we wish. From the data, I would guess the transition period
may take some good years.

Thanks,
Yiu

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 17 Sep 2010 13:20:19 +1200

This is very compatible with the more detailed answers that
we got in draft-ietf-v6ops-isp-scenarios, which is now
in the RFC Editor queue.

In particular, the hard core of 10% of ISPs who have no plan
or intention for IPv6 is exactly the same.

Regards
   Brian Carpenter

On 2010-09-17 09:30, Yiu L. Lee wrote:
> _______________________________________________
> v4tov6transition mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v4tov6transition
>

---

From: Fred Baker <[email-masked]>
Date: Thu, 16 Sep 2010 23:00:26 -0500

On Sep 16, 2010, at 3:32 PM, Ed Jankiewicz wrote:

> as the article notes, something like 10% of ISPs responded "No plans to implement IPv6" as in not even thinking about EVER doing it.  Overall, including end-user organizations there is still a lackluster interest in doing IPv6 now or soon.  And big reasons include "lack of knowledgeable staff", "lack of experience", "no business case/user demand" and "technical problems".   Real or perceived, getting better information out to marketplace about what you really need to know and need to do would help.  I hope that's what this list is about.
> 

I think you will find this list is about operator questions regarding IPv6 deployment, and very much overlaps the v6ops list. It's not marketing. It's operational technology questions, many of them appropriate to your favorite *NOG.

There are a couple of ways to look at IPv6 adoption. There is a serious level of whistling in the dark regarding the IPv6 address space; I hear a lot of "I have enough addresses for another year; if I'm not out of addresses, why worry?" That, of course, is a lot like saying "I'm driving the car at 200 kph and I still have pavement ahead; why should that brick wall I see concern me?".

The other way to look at 10% of ISPs asleep at the wheel is that 90% aren't. Yes, they would like more customer demand - people waving money would really excite them, and at this point it's mostly a cost, not a revenue opportunity.  http://www.oecd.org/dataoecd/48/8/44961688.pdf suggests, however, that ISPs - especially in North America, long rumored to be the last place on earth anyone would deploy IPv6 - have been quietly deploying it in their networks and are preparing to deploy services to customers. Some, as Cameron noted the other day, are even going IPv6-only within specified domains.

We're having amusing conversations with our customers as they come up short. One salesman contacted me a couple of weeks ago when his customer was preparing their request to ARIN and had been told that they would get a pretty small allocation. They sales guy wanted to know what arguments for a larger allocation the company should offer: "would it make a difference if they said 'but we really need it, guys!'"? Of the options the salesman offered me, an incredulous "Deploy IPv6?!?" was the fourth, and yes, that's the realization the customer was having - feeling very much like his pants had just dropped down around his ankles. I suspect that as these stories become more common, we're going to suddenly find people wanting to deploy "right now", and and angry if everything doesn't work just perfectly out of the box.

---

From: Ed Jankiewicz <[email-masked]>
Date: Fri, 17 Sep 2010 12:56:47 -0400

I can see how my "marketplace" comment sounded like a call to 
"marketing".  That's not what I meant - I just lumped the target 
audience into that term.

Yes, it's good that 90% of the survey respondents had some idea about 
IPv6.  It is just very surprising that at this point in time anyone 
could respond "no plans to make plans."  And folks are still surprised 
to find out "no, we really mean it.  No more big chunks of IPv4 
available."   Sadly, we still have an educational role to play.

---

From: james woodyatt <[email-masked]>
Date: Fri, 17 Sep 2010 10:12:33 -0700

On Sep 17, 2010, at 09:56, Ed Jankiewicz wrote:
> 
> Yes, it's good that 90% of the survey respondents had some idea about IPv6.  It is just very surprising that at this point in time anyone could respond "no plans to make plans."

To be fair, we don't know how many of those 10%, who profess to have no plans to implement IPv6, are saying that because they plan to shut down their ISP business before the IPv6 wave can possibly crash on their heads.  It's probably a non-zero percentage.  Some may be perfectly happy to continue providing IPv4-only service on the cheap, into the foreseeable future, to subscribers with no plans to expand or to keep up with the rest of the world.  It's going to be a niche.  Not sure how big it will be.

> And folks are still surprised to find out "no, we really mean it.  No more big chunks of IPv4 available."   Sadly, we still have an educational role to play.

- You cannot awaken someone who is pretending to be asleep.
- You cannot educate someone whose salary depends on their remaining ignorant.
- The plainest print cannot be read through a solid gold sovereign.

I don't see our job in IETF to educate or to sound any alarms on this.  I'd prefer to see us concentrate on engineering efforts to make transitioning go more smoothly.

--
james "cassandra" woodyatt <[email-masked]>
member of technical staff, communications engineering

---

From: Ed Jankiewicz <[email-masked]>
Date: Fri, 17 Sep 2010 14:49:22 -0400

Sad but true.  90% awareness is actually very encouraging, and I'm 
more concerned about providing the information about the tools that 
those folks need to move forward.   There is a lot of relevant work in 
IETF, but may not be as widely recognized as it could be.  Some small 
effort to organize and catalog that to remove some of the FUD wouldn't hurt.

As to the last 10% a line I've used a couple places is " Nothing compels 
the elimination of IPv4; no protocol police will forbid its use in the 
foreseeable future.  IPv4 may disappear due to irrelevance when IPv6 is 
so pervasive to make it redundant."

Over time the cost, complexity and inconvenience of coexistence should 
shift from the burden being on the "early adopters" of IPv6 to the IPv4 
dead-enders.

On 9/17/2010 1:12 PM, james woodyatt wrote:
> james "cassandra" woodyatt<[email-masked]>

---

From: <[email-masked]>
Date: Fri, 17 Sep 2010 16:40:18 -0400

Airport layover thoughts...

Rural muni network provider. Currently serves 4500 subs. That number has grown from 3900 over the last five years. Their allocation from provider/ARIN will last them at least another 5. Benefit from upgrading today in their view=0. The only argument you can make here is that new apps/content will be served IPv6-only...someday. That is a hard position to stand behind to push adoption in the near-term.

Jason

On 9/17/10 1:12 PM, "james woodyatt" wrote:

---

From: Mikael Abrahamsson <[email-masked]>
Date: Sat, 18 Sep 2010 07:07:50 +0200 (CEST)

On Thu, 16 Sep 2010, Fred Baker wrote:

> ankles. I suspect that as these stories become more common, we're going 
> to suddenly find people wanting to deploy "right now", and and angry if 
> everything doesn't work just perfectly out of the box.

The "right now" has been seen popping up quite a few times already from 
ISPs coming into the IETF when they started doing research and found 
things lacking for some reason or another.

Due to this, I'd say the past 1-2 years things are improving, but I 
totally agree with Fred here, we're going to be in for quite a storm in a 
couple of years when users realise the same thing.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Fred Baker <[email-masked]>
Date: Sat, 18 Sep 2010 10:46:54 -0700

> Rural muni network provider. Currently serves 4500 subs. That number has grown from 3900 over the last five years. Their allocation from provider/ARIN will last them at least another 5. Benefit fro…

No argument from his present viewpoint. He can sleep tonight, and tomorrow night too.

I have two thoughts for him. 

(1) while he is not alone in this viewpoint, his larger competitors are in the process of enabling IPv6 access, and at some point, as Cameron likes to point out, will no longer have a good reason to maintain the IPv4 network. We can have a long and fruitless discussion about how far out that is; given business pressures that force some level of IPv6 adoption, I would be *very* hesitant to presume that it recedes into the indefinite future. It will be bounded by software and hardware life cycles at the very farthest, which depending on your business model is a number somewhere between three and twenty years. Five years from now, in view of the already-spent lifetime of any deployed PC that doesn't support IPv6 out of the box and perhaps prefer it, is a very reasonable guess.

(2) So let's presume that he installs an IPv4/IPv6 translator somewhere between himself and his upstream, which means that the rest of the network can access him and he has limited ability to access the IPv6 side of the network. Five years from now, when he runs out of IPv4 addresses, will he have a running IPv6 network to keep his business running, or will he be like the operator I mentioned, who had a wake-up call and considered it very rude? 

If he has any view of continuity of business in the long term, planning for the event in the medium term is time well spent on his behalf - just like it was for the operators on this list five years ago. That's a "fear sale", if you will, and I'm sorry. But if five years from now his AM comes to me describing a customer with his pants around his ankles, I'm not going to be very sympathetic. It's his business, and his choice.

http://www.aesops-fables.org.uk/aesop-fable-the-ant-and-the-grasshopper.htm