Subject: [v4tov6transition] V0.4 Agenda for WebEx meeting on Sep 20/21

From: Tina TSOU <[email-masked]>
Date: Mon, 20 Sep 2010 11:18:55 +0800

Hi all,
This is the V0.4 Agenda for WebEx meeting on Sep 20/21. I just realized there is v02 for the PS I-D.

Agenda: Version 0.4 (draft)
Meeting : IETF WebEx
Date    : September 21st 2010, China Time (Beijing, GMT+08:00)
Time    : 10:00 am, China Time (Beijing, GMT+08:00)
Location: WebEx

=========================================================
1. Welcome & Administrivia (3 minutes)
Bluesheets: http://v4v6transeproster.wikispaces.com/ 
Jabber:
Room: v4v6tran
Server: conference.jabber.org
Jabber scribe: Philip Matthews? Brian Carpenter is the backup scribe.
Minute Takers: Edward Jankiewicz

2. Problem Statements of IPv6 Transition of ISP
draft-lee-v4v6tran-problem-02
Authors:
Y. Lee, Ed.
Comcast
K. Kuarsingh
Rogers Communications
G. Yang
China Telecom
G. Chen
China Mobile
Presenter: Yiu Lee (one or two slides and 3 minutes to explain it)
Questions for clarification (5 minutes) (More slides can help when the authors answer the questions in these 5 minutes.)

3. Framework for IP Version Transition Scenarios
draft-carpenter-v4v6tran-framework-00
Presenter: Brian Carpenter (one or two slides and 3 minutes to explain it) 
Questions for clarification (5 minutes) (More slides can help when the authors answer the questions in these 5 minutes.)

4. Use Case For IPv6 Transition For a Large-Scale Broadband Network
draft-huang-v4v6tran-broadband-usecase-00
Presenter: Can-Can Huang (one or two slides and 3 minutes to explain it)
Questions for clarification (5 minutes) (More slides can help when the authors answer the questions in these 5 minutes.)

5. IPv6 Transition Guide For A Large ISP Providing Broadband Access
draft-yang-v4v6tran-ipv6-transition-guide-01
Presenter: Jason Lin (one or two slides and 3 minutes to explain it)
Questions for clarification (5 minutes) (More slides can help when the authors answer the questions in these 5 minutes.)

6. IPv6 Transition Cable Access Network Use Cases
draft-lee-v4v6tran-usecase-cable-00
Presenter: Victor Kuarsingh (one or two slides and 3 minutes to explain it)
Questions for clarification (5 minutes) (More slides can help when the authors answer the questions in these 5 minutes.)

7. Use Case for Mobile scenarios
draft-zhou-v4v6tran-mobile-use-case
Presenter: Cathy Zhou (one or two slides and 3 minutes to explain it)
Questions for clarification (5 minutes) (More slides can help when the authors answer the questions in these 5 minutes.)

8. IPv6 Transition Guide For A Large Mobile Operator
draft-tsou-v4v6tran-mobile-transition
Presenter: Tom Taylor (one or two slides and 3 minutes to explain it)
Questions for clarification (5 minutes) (More slides can help when the authors answer the questions in these 5 minutes.)

9. Use case for ISPs that provide CPEs and offer DS via IPv4-only or DS via IPv6-only
Presenter: Remi Despres (one or two slides and 3 minutes to explain it)
Questions for clarification (5 minutes) (More slides can help when the authors answer the questions in these 5 minutes.)

10. Internet Routing Overlay Network (IRON):
draft-templin-iron-12
Presenter: Fred.L.Templin (one or two slides and 3 minutes to explain it)
Questions for clarification (2 minutes) (More slides can help when the authors answer the questions in these 2 minutes.)

11. General Discussion and Work Program Discussion
All (48 minutes)

B. R.
Tina
http://tinatsou.weebly.com

---

From: Joel Jaeggli <[email-masked]>
Date: Sun, 19 Sep 2010 23:01:01 -0700

As a point of order.

I have some concerns about the level of review that can be lodged
against documents submitted on the 17th-19th.

It seems rather unrealistic that informed discussion by the participants
would ensue from them.

That said I have no suggestion as to what to do about that.

On 9/19/10 8:18 PM, Tina TSOU wrote:
> Questions for clarification (5 minutes) (More slides can help when the
> authors answer the questions in these 5 minutes.)
>  
> Questions for clarification (5 minutes) (More slides can help when the
> authors answer the questions in these 5 minutes.)
>  
> Questions for clarification (5 minutes) (More slides can help when the
> authors answer the questions in these 5 minutes.)
>  
> Questions for clarification (5 minutes) (More slides can help when the
> authors answer the questions in these 5 minutes.)
>  
> Questions for clarification (5 minutes) (More slides can help when the
> authors answer the questions in these 5 minutes.)
>  
> Questions for clarification (5 minutes) (More slides can help when the
> authors answer the questions in these 5 minutes.)
>  
> Questions for clarification (5 minutes) (More slides can help when the
> authors answer the questions in these 5 minutes.)
> 
> Questions for clarification (5 minutes) (More slides can help when the
> authors answer the questions in these 5 minutes.)
>  
> Questions for clarification (2 minutes) (More slides can help when the
> authors answer the questions in these 2 minutes.)
> 
> _______________________________________________
> v4tov6transition mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v4tov6transition

---

From: Tina TSOU <[email-masked]>
Date: Mon, 20 Sep 2010 14:23:51 +0800

The -00 of PS I-D was submitted on 30 Aug 2010. The later updates reflect 
the discussion in the lists.

B. R.
Tina

---

From: Joel Jaeggli <[email-masked]>
Date: Sun, 19 Sep 2010 23:29:05 -0700

On 9/19/10 11:23 PM, Tina TSOU wrote:
> The -00 of PS I-D was submitted on 30 Aug 2010. The later updates
> reflect the discussion in the lists.

draft-lee-v4v6tran-usecase-cable-00 was submitted sunday...

draft-tsou-v4v6tran-mobile-transition-guide-00 was submitted friday...

> ----- Original Message ----- From: "Joel Jaeggli" <[email-masked]>

---

From: Tina TSOU <[email-masked]>
Date: Mon, 20 Sep 2010 16:40:28 +0800

You are right.

B. R.
Tina

---

From: jouni korhonen <[email-masked]>
Date: Mon, 20 Sep 2010 12:19:23 +0300

Hi,

I had a quick look at some of these documents. See comments below.

On Sep 20, 2010, at 6:18 AM, Tina TSOU wrote:

[snip]

> Questions for clarification (5 minutes) (More slides can help when the authors answer the questions in these 5 minutes.)

The use of GTP-U vs PMIPv6 terminology gives on impression that those are exchangeable just like that. However, GTP also has the control part GTP-C. Therefore, the text should be more careful when it means GTP as a whole (both -U & -C), or just  -U or -C part of it.

The draft could actually reference to draft-korhonen-v6ops-3gpp-eps on parts where it explains the basic EPC/GPRS architecture. That part is rather well covered in the mentioned draft.

> Questions for clarification (5 minutes) (More slides can help when the authors answer the questions in these 5 minutes.)

o Section 1:

   strategies and tools for migration. 3GPP has decided to use Gateway-
   Initiated DS-lite [ID_GI_DS_lite] as the primary tool for subscriber
   migration.  Details as far as they have been thought out are provided 
   in [3GPP_TR_23_975].  However, they cover only a small part of the
   total problems.

I think this statement is making a forward step from 3GPP process point of view. GI-DS-Lite is still in a public Technical Report.. there is no any mandatory specification work done in 3GPP yet.

o Section 2.2:

      A key use of this DNS system is to allow the Serving Gateway to
      locate a PDN Gateway providing access to the core network that the
      subscriber will use.  This may be operator's own core network or
      the subscriber's home network.

I assume the above refers to 3GPP EPC. There the Serving GW does not do any DNS queries to locate the PDN-GW. It is MME that does it and locates a PDN-GW for a Serving GW.

And a PDN-GW does not provide access to core network for the subscriber. In 3GPP terminology that is more like an access to a PDN.

o Section 2.4:

   3GPP specifications for mobile devices have required dual stack
   support for at least a year (i.e., as of Release 8.)  The operator

As far as I know, "required" is too strong. Dual-Stack in devices is still an optional feature in Release-8 and it is possible to ship single IP version capable stacks e.g. IPv6 only device. If the device stack does both IPv4 & IPv6 then IPv4v6 bearer is required.

   user devices and sharing public IPv4 addresses between multiple users
   using some system of block port allocation as proposed in
   [ID_natx4-log-reduction].

What about draft-ietf-dime-nat-control ?

   DNS access is an issue with Gateway-Initiated DS-lite.  The original
   DS-lite proposal had a point (the B4) at which all DNS queries could
   be intercepted and sent to an IPv6 DNS.  From here IPv4 queries could
   be forwarded to an IPv4 DNS, or the IPv6 DNS could maintain both AAAA
   and A records.  It is not so obvious that such interception can be

In DS-Lite the DNS issue was different compared to this i.e. a provisioning and IP transport version issue. I don't see the relation to GI-DS-Lite here. In GPRS/EPS the mobile can be provisioned with both IPv4 and IPv6 DNS server addresses during bearer setup, and these DNS servers are then both behind (S)Gi. Are you mixing IP transport version and DNS configuration information here..?

- Jouni

[snap]

---

From: Ronald Bonica <[email-masked]>
Date: Mon, 20 Sep 2010 14:40:45 -0400

Joel,

I share your misgivings regarding these documents. I don't know what kind of review we can expect for two documents that were posted one workday before the meeting.

                                                Ron
                                                /speaking as individual contributor

> -----Original Message-----
> From: [email-masked] [mailto:v4tov6transition-
> [email-masked]] On Behalf Of Tina TSOU
> Sent: Monday, September 20, 2010 4:40 AM
> To: Joel Jaeggli
> Cc: [email-masked]
> >>>> This is the V0.4 Agenda for WebEx meeting on Sep 20/21. I just
> realized
> >>>> there is v02 for the PS I-D.
> >>>>
> >>>> Presenter: Can-Can Huang (one or two slides and 3 minutes to
> explain
> >>>> it)
> >>>> 9. Use case for ISPs that provide CPEs and offer DS via IPv4-only
> or DS
> >>>> via IPv6-only
> >>>> Presenter: Fred.L.Templin (one or two slides and 3 minutes to
> explain
> >>>> it)

---

From: Joel Jaeggli <[email-masked]>
Date: Mon, 20 Sep 2010 11:52:48 -0700

On 9/20/10 11:40 AM, Ronald Bonica wrote:
> Joel,
> 
> I share your misgivings regarding these documents. I don't know what
> kind of review we can expect for two documents that were posted one
> workday before the meeting.

notwithstanding the short timeline I solicited and got a review, of

draft-tsou-v4v6tran-mobile-transition-guide-00

which was sent to the list by jouni.

I'm not entirely up to speed on.

> Ron /speaking as individual contributor
> 
> 
>> -----Original Message----- From: [email-masked]
>> [mailto:v4tov6transition- [email-masked]] On Behalf Of Tina TSOU 
>> Sent: Monday, September 20, 2010 4:40 AM To: Joel Jaeggli Cc:
>> [email-masked] Subject: Re: [v4tov6transition] V0.4
>> Agenda for WebEx meeting on Sep 20/21
>> 
>> You are right.
>> 
>> B. R. Tina http://tinatsou.weebly.com
>> 
>> ----- Original Message ----- From: "Joel Jaeggli"
>> <[email-masked]> To: "Tina TSOU" <[email-masked]> Cc:
>> <[email-masked]> Sent: Monday, September 20, 2010 2:29
>> PM Subject: Re: [v4tov6transition] V0.4 Agenda for WebEx meeting on
>> Sep 20/21
>> 
>> 
>>>> The -00 of PS I-D was submitted on 30 Aug 2010. The later
>>>> updates reflect the discussion in the lists.
>>> 
>>>> B. R. Tina http://tinatsou.weebly.com
>>>> 
>>>> ----- Original Message ----- From: "Joel Jaeggli"
>>>> <[email-masked]> To: "Tina TSOU" <[email-masked]> Cc:
>>>> <[email-masked]> Sent: Monday, September 20, 2010
>>>> 2:01 PM Subject: Re: [v4tov6transition] V0.4 Agenda for WebEx
>>>> meeting on Sep 20/21
>>>> 
>>>> 
>>>>> As a point of order.
>>>>> 
>>>>> I have some concerns about the level of review that can be
>>>>> lodged against documents submitted on the 17th-19th.
>>>>> 
>>>>>> Hi all, This is the V0.4 Agenda for WebEx meeting on Sep
>>>>>> 20/21. I just
>> realized
>>>>>> Agenda: Version 0.4 (draft) Meeting : IETF WebEx Date    :
>>>>>> September 21st 2010, China Time (Beijing, GMT+08:00) Time
>>>>>> : 10:00 am, China Time (Beijing, GMT+08:00) Location:
>>>>>> WebEx
>>>>>> 
>>>>>> 1. Welcome & Administrivia (3 minutes) Bluesheets:
>>>>>> http://v4v6transeproster.wikispaces.com/ Jabber: Room:
>>>>>> v4v6tran Server: conference.jabber.org Jabber scribe:
>>>>>> Philip Matthews? Brian Carpenter is the backup
>> scribe.
>>>>>> draft-lee-v4v6tran-problem-02 Authors: Y. Lee, Ed. Comcast 
>>>>>> K. Kuarsingh Rogers Communications G. Yang China Telecom G.
>>>>>> Chen China Mobile Presenter: Yiu Lee (one or two slides and
>>>>>> 3 minutes to explain it) Questions for clarification (5
>>>>>> minutes) (More slides can help when
>> the
>>>>>> draft-carpenter-v4v6tran-framework-00 Presenter: Brian
>>>>>> Carpenter (one or two slides and 3 minutes to explain it) 
>>>>>> Questions for clarification (5 minutes) (More slides can
>>>>>> help when
>> the
>>>>>> 4. Use Case For IPv6 Transition For a Large-Scale
>>>>>> Broadband
>> Network
>>>>>> draft-huang-v4v6tran-broadband-usecase-00 Presenter:
>>>>>> Can-Can Huang (one or two slides and 3 minutes to
>> explain
>>>>>> it) Questions for clarification (5 minutes) (More slides
>>>>>> can help when
>> the
>>>>>> 5. IPv6 Transition Guide For A Large ISP Providing
>>>>>> Broadband
>> Access
>>>>>> draft-yang-v4v6tran-ipv6-transition-guide-01 Presenter:
>>>>>> Jason Lin (one or two slides and 3 minutes to explain
>> it)
>>>>>> Questions for clarification (5 minutes) (More slides can
>>>>>> help when
>> the
>>>>>> draft-lee-v4v6tran-usecase-cable-00 Presenter: Victor
>>>>>> Kuarsingh (one or two slides and 3 minutes to explain it) 
>>>>>> Questions for clarification (5 minutes) (More slides can
>>>>>> help when
>> the
>>>>>> draft-zhou-v4v6tran-mobile-use-case Presenter: Cathy Zhou
>>>>>> (one or two slides and 3 minutes to explain
>> it)
>>>>>> Questions for clarification (5 minutes) (More slides can
>>>>>> help when
>> the
>>>>>> draft-tsou-v4v6tran-mobile-transition Presenter: Tom Taylor
>>>>>> (one or two slides and 3 minutes to explain
>> it)
>>>>>> Questions for clarification (5 minutes) (More slides can
>>>>>> help when
>> the
>>>>>> via IPv6-only Presenter: Remi Despres (one or two slides
>>>>>> and 3 minutes to
>> explain it)
>>>>>> Questions for clarification (5 minutes) (More slides can
>>>>>> help when
>> the
>>>>>> draft-templin-iron-12 Presenter: Fred.L.Templin (one or two
>>>>>> slides and 3 minutes to
>> explain
>>>>>> it) Questions for clarification (2 minutes) (More slides
>>>>>> can help when
>> the
>>>>>> 11. General Discussion and Work Program Discussion All (48
>>>>>> minutes)
>>>>>> 
>>>>>> B. R. Tina http://tinatsou.weebly.com
>>>>>> 
>>>>>> 
>>>>>> 
>>>>>> v4tov6transition mailing list [email-masked] 
>> _______________________________________________ v4tov6transition
>> mailing list [email-masked]

---

From: Jari Arkko <[email-masked]>
Date: Mon, 20 Sep 2010 19:58:05 -0700

I am going through the documents in the agenda.

Sent separately.

I think some of the text in Section 1 puts ipv6-only as the highest 
priority deployment model (and I'm saying this as a vendor of some IPv6 
only gear :-) Or am I reading your text wrong, Brian? I think ipv6-only 
is an important model and its importance grows as time goes by. But dual 
stack has not been dismissed just because we no longer have IPv4 
addresses, it is still a very much recommended model, too.

I do like the framework model. Everything we describe in terms of 
transition strategies would be good to describe under this framework.

The other thing that I wanted to say -- and this is consistent feedback 
that I get from various operators and customers -- is that I hope we are 
not developing an infinite stream of new scenarios and transition tools. 
I do recognize that one size does not fit all, but just like with IPv4, 
we need a relatively small set of tools and then the operators can 
deploy these in various combinations. Transition is 90% hard, boring 
work. We engineers, scientists, and vendors need to restrain our natural 
urge to invent new solutions to those cases where there is significant 
demand and a real problem.

Did not have time to read this.

5. IPv6 Transition Guide For A Large ISP Providing Broadband Access 
draft-yang-v4v6tran-ipv6-transition-guide

This is a very interesting document, I like reading about specific 
networks and what you see as the alternatives and pros/cons in your 
specific case. A couple of questions/comments:

Section 1: What's "the existing single transition technology" referred 
from the text?

I like the contrasting of various deployment options in Section 2.1. 
(Does Section 2.1.1 assume that dual stack == simultaneous roll-out of 
IPv6 in all routers in the network? Many networks employ a gradual 
approach to deployment, converting a small number of routers at a time 
and/or acquiring new devices for pure IPv6-only service on a 
case-by-case basis. The pros/cons may be different if you do this 
instead of a one-time rollout.)

Good stuff. A few comments:

>   According to [I-D.arkko-ipv6-transition-guidelines], native dual-
>    stack is the simplest model for transition.  However, this requires
>    the entire network to be dual-stack.  Moreover, the provisioning
>    system and other support systems must be upgraded to support IPv6.
>    Most operators will need to upgrade the network in phases along with
>    the provisioning system(s) and supporting systems.  During the
>    transition period, there will be IPv4-only islands.  In order to
>    offer dual-stack access to users over IPv4 islands, operators may
>    consider the use of tunneling technologies such as 6rd and MPLS.

I think that is actually consistent with the advice in our draft (but 
maybe we need to change something if that was not clear). On any 
specific part of the network, native and dual stack are preferred if you 
can do them, but it is indeed natural that most networks employ a 
combination of tools in different parts. My own network, for instance, 
has a combination of IPv6-only, dual-stack, and tunneled IPv6 service in 
different routers/links. I would have avoided the tunneled solution in 
one part of the network, but it was not possible at the moment.

More reviews to follow...

Jari

---

From: "Yiu L. Lee" <[email-masked]>
Date: Mon, 20 Sep 2010 23:12:35 -0400

Hi Jari,

> one part of the network, but it was not possible at the moment.
You hit the nail in the head. Our network also has multiple technologies.
Every time we tried to explain this to the management, they scratched their
heads and asked why we wanted to deploy so many technologies in the network.
To them, this is confusing and drive up the cost to manage the network. We
are working hard to balance technologies to provide service continuity and
meanwhile to speedup the IPv6 deployment. My wish is that all operators
could converse to a single technology for transitioning :-) but I have
learned that this will only stay as a wish :-( My worry is that the more the
confusion in the community, the higher the cost for the transition.

Anyway, our intention for this use case draft is to address the use cases at
least in cable industry so that MSOs could agree with similar technologies.
We hope if we could agree with the use cases and technologies, this could
help to train the engineers and drive down the overall cost (both CapEx and
OpEx).

-- Yiu

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 21 Sep 2010 16:37:02 +1200

> I am going through the documents in the agenda.

...
> addresses, it is still a very much recommended model, too.

Fair comment. As we said in the teleconf, there's no one-size fits all.
That can be tuned in the next version.

> transition strategies would be good to describe under this framework.

Ack

> demand and a real problem.

Correct. Actually, IMHO, the last thing the operators need right now
is a confusing parade of alternative new solutions. We do need to focus
on areas where the operators perceive an unsolved problem.

   Brian

---

From: Joel Jaeggli <[email-masked]>
Date: Wed, 22 Sep 2010 05:52:37 -0700

> confusion in the community, the higher the cost for the transition.

Right but the transition technology is mostly another bandaid associated
with lack of v6 deployment or ipv4 address pressure forcing shim
technologies. your/our deployed ipv4 service is going to get crapier
when you have no more public ip4 addresses to hand to costomers, the
pain can be minimized to some extent but it cannot be entirely aleviated.

Ipv6 deployment is unabiguous, my first one was in 2001 and it still is now.

> help to train the engineers and drive down the overall cost (both CapEx and

Minimzing opex is about being constructively lazy, the minimum amount of
necessary work done in order to support the use case is the low bar to
get over.