Subject: RE: Preparatory to WGLC draft-ietf-v6ops-ipsec-tunnels

From: "Durand, Alain" <[email-masked]>
Date: Thu, 9 Nov 2006 13:26:40 -0500

Fred,

The authors of draft-ietf-softwire-security-requirements
met and look at draft-ietf-v6ops-ipsec-tunnels to see if it would be
possible to add text to it to cover as well the v4 over v6 case.

Their look at two approaches, either updating the core of the text
or adding a new section at the end. Their conclusion is that
in either case it would require significant effort that is
not worth it at this point.

So, we now have no more objection to get draft-ietf-v6ops-ipsec-tunnels
to last call.

  - Alain, Softwire co-chair.

> -----Original Message-----
> From: Durand, Alain 
> Sent: Tuesday, November 07, 2006 12:24 AM
> To: Fred Baker; [email-masked]
> Cc: Lindqvist Erik Kurt; [email-masked]; 
> [email-masked]; Florent Parent; [email-masked]; Shu Yamamoto
> Subject: RE: Preparatory to WGLC draft-ietf-v6ops-ipsec-tunnels
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]] On Behalf Of Fred Baker
> > Sent: Monday, November 06, 2006 7:06 PM
> > To: [email-masked]
> > Cc: Lindqvist Erik Kurt
> > Subject: Preparatory to WGLC draft-ietf-v6ops-ipsec-tunnels
> > 
> > This draft has had something of a tortured history, and hit a bump 
> > this morning in v6ops. Next week I plan to issue a working 
> group last 
> > call on it (repeat from one about a year
> > ago) barring significant issues, and send it to the IESG. 
> > However, one issue came up that I would like a clear 
> opinion from the 
> > working group on.
> > 
> > It describes the use of IPv6 in IPv6 and IPv4 tunnels, but does not 
> > describe IPv4 in IPv6 or IPv4 tunnels. Alain Durand is of 
> the opinion 
> > that, since IPSEC is independent of the two technologies, the 
> > additional work needed to make it cover the case is 
> nominal. He also 
> > thinks that it would be useful to him operationally. However, the 
> > authors have not looked into that, and suspect that it 
> would require 
> > some think time and a number of small changes to the draft.
> > 
> > If we do the work, I think that fairness to the authors calls for 
> > Alain to contribute to the analysis and the editorial work, 
> at least 
> > in helping identify the edits required.
> > 
> > Please, I'd like an up-down decision here - drop kurt and I a note 
> > privately indicating whether you think the work is warranted or 
> > whether this draft should go forward as is.
> 
> 
>  
> Fred,
> 
> For the record, I'm not asking this change with my employer's 
> hat, but with my softwire co-chair hat.
> 
> We have a security document
> (http://www.ietf.org/internet-drafts/draft-ietf-softwire-secur
> ity-requirements-01.txt)
> in our wg that would gretly benefit from referencing 
> draft-ietf-v6ops-ipsec-tunnels both in the context of v6 over 
> v4 and v4 over v6, as our wg charter is to address both cases.
> 
> I've asked the authors of our document (Cced here) to look at 
> draft-ietf-v6ops-ipsec-tunnels and identify what would need 
> to be changed there. I would hope this analysis could be done 
> quickly to help you decide if it is worth making this last 
> minute change to your document for the benefit of the larger 
> community.
> 
>    - Alain.
>

---

From: Fred Baker <[email-masked]>
Date: Thu, 9 Nov 2006 11:10:19 -0800

OK, thanks