Subject: Use of extended prefix lengths

From: "Dunn, Jeffrey H." <[email-masked]>
Date: Thu, 5 Jun 2008 12:10:44 -0400

Colleagues,

I was discussing the possibility of using IPv6 prefix lengths greater
than 64 bits with some colleagues and wondered if anyone had any
experience with doing so.  Specifically, has anyone tried it?
Thoughts?

Best Regards, 
  
Jeffrey Dunn 
Info Systems Eng., Lead 
  
Center for Enterprise Modernization 
MITRE Corp. 
  
301-429-5377 (Office) 
301-731-8862  (FAX)

---

From: [email-masked]
Date: Thu, 5 Jun 2008 17:14:27 +0000

you mean longer than /64? 
 I have built a network out of a /96, using /120's for subnets.
 you have to turn -off- all the autoconfig crap - but it is doable.
 dhcpv6 would have been a real help then.

--bill

---

From: Mohacsi Janos <[email-masked]>
Date: Thu, 5 Jun 2008 19:26:00 +0200 (CEST)

> experience with doing so.  Specifically, has anyone tried it?

One of my colleague tried /126 with DHCPv6 address assignment and it seems 
to be mediocre success:
Linux (Dibbler) client was working almost alright - with some extension
Windows Vista failed  - not really supporting longer prefix.

for point-to-point links prefix longer than /64 was worked without any 
problem on Cisco boxes.

Best Regards,

Janos Mohacsi
Network Engineer, Research Associate, Head of Network Planning and Projects
NIIF/HUNGARNET, HUNGARY
Key 70EF9882: DEC2 C685 1ED4 C95A 145F  4300 6F64 7B00 70EF 9882

---

From: "Dunn, Jeffrey H." <[email-masked]>
Date: Thu, 5 Jun 2008 13:34:21 -0400

Bill,

Interesting.  I noted that prefixes longer than 64 are not prohibited
by the BGP, OSPF or DHCP RFCs, so I got to thinking (I know, very
dangerous).  I am checking with some folks to see if currently
available DHCPv6 server implementation will associate a prefix longer
than 64 bits with a link or link address.  I will keep the list
informed.

Best Regards,
 
Jeffrey Dunn
Info Systems Eng., Lead
MITRE Corporation.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] 
Sent: Thursday, June 05, 2008 1:14 PM
To: Dunn, Jeffrey H.
Cc: [email-masked]
Subject: Re: Use of extended prefix lengths

--bill

---

From: "Dunn, Jeffrey H." <[email-masked]>
Date: Thu, 5 Jun 2008 13:35:53 -0400

Janos,

Which server did he use?

Best Regards,
 
Jeffrey Dunn
Info Systems Eng., Lead
MITRE Corporation.

-----Original Message-----
From: Mohacsi Janos [mailto:[email-masked]] 
Sent: Thursday, June 05, 2008 1:26 PM
To: Dunn, Jeffrey H.
Cc: [email-masked]
Subject: Re: Use of extended prefix lengths

> experience with doing so.  Specifically, has anyone tried it?

One of my colleague tried /126 with DHCPv6 address assignment and it
seems 
to be mediocre success:
Linux (Dibbler) client was working almost alright - with some extension
Windows Vista failed  - not really supporting longer prefix.

Best Regards,

Janos Mohacsi
Network Engineer, Research Associate, Head of Network Planning and
Projects
NIIF/HUNGARNET, HUNGARY
Key 70EF9882: DEC2 C685 1ED4 C95A 145F  4300 6F64 7B00 70EF 9882

---

From: Chuck Anderson <[email-masked]>
Date: Thu, 5 Jun 2008 13:43:30 -0400

> experience with doing so.  Specifically, has anyone tried it?

We are using /120's for router links on Ethernet VLANs, and /128 
router loopback addresses without problems.

---

From: "Dunn, Jeffrey H." <[email-masked]>
Date: Thu, 5 Jun 2008 13:58:48 -0400

Cool.  What E-switch are you using?

Best Regards,
 
Jeffrey Dunn
Info Systems Eng., Lead
MITRE Corporation.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Chuck Anderson
Sent: Thursday, June 05, 2008 1:44 PM
To: [email-masked]
Subject: Re: Use of extended prefix lengths

---

From: Kevin Loch <[email-masked]>
Date: Thu, 05 Jun 2008 14:05:07 -0400

> for point-to-point links prefix longer than /64 was worked without any 

/112 is commonly used on router links and works fine.  I have also used
it on server subnets with various *BSD/linux/Solaris in it works there
also.

- Kevin

---

From: Mohacsi Janos <[email-masked]>
Date: Thu, 5 Jun 2008 20:28:15 +0200 (CEST)

> Which server did he use?

We tried dibbler dhcpv6 server.
  	Regards,
  		Janos Mohacsi

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Thu, 5 Jun 2008 22:50:00 +0200

> dhcpv6 would have been a real help then.

Just make sure you don't use the all-zeros address because that's the  
all-routers anycast address even though many routers don't care.  
Nightmare scenario would be that they start caring after some update.  
The top 128 addresses of a subnet are reserved anycast addresses too,  
so /120 or longer isn't ideal either. /112 is good because then the  
last four hex digits are your subnet. However, you can also often just  
use link locals, routing protocols only use link locals, anyway.

Note that DHCPv6 will only give you address assignment (if supported  
by both the client and the server) but it won't give you a subnet  
prefix length or a default router, for this you still need router  
advertisements. But you REALLY don't want to use non-/64 subnets  
unless you manually configure them, trust me.

---

From: bill fumerola <[email-masked]>
Date: Thu, 5 Jun 2008 14:28:20 -0700

> for point-to-point links prefix longer than /64 was worked without any 

for internal point-to-point links, using ospfv3 + link-local addresses
+ /128s on loopbacks has worked well for me. for point-to-point on the
edge, i've used /64s down to /120s. depending on your IGP, using global
addresses on point-to-point may have its benefits.

-- bill

---

From: Chuck Anderson <[email-masked]>
Date: Thu, 5 Jun 2008 18:05:57 -0400

> addresses on point-to-point may have its benefits.

How does traceroute work when using link-local addressing on 
point-to-point links?

---

From: bill fumerola <[email-masked]>
Date: Thu, 5 Jun 2008 16:13:27 -0700

> How does traceroute work when using link-local addressing on 

rtr1.ash>sh ipv6 route 2001:500:2F::F
B   2001:500:2F::/48 [200/0]
     via 2620:0:CCC:1::1    
rtr1.ash>sh ipv6 route 2620:0:CCC:1::1
O   2620:0:CCC:1::1/128 [110/1]
    via FE80::217:FFF:FE1C:BC1B, Tunnel3800 
rtr1.ash>sh ipv6 int tun3800
Tunnel3800 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::219:7FF:FE23:7C1B 
  Description: NYC/ASH
  No global unicast address is configured
[...]
rtr1.ash>traceroute 2001:500:2F::F

Type escape sequence to abort.
Tracing the route to f.root-servers.net (2001:500:2F::F)

  1 2620:0:CCC:0:217:FFF:FE1C:BC1B 8 msec 8 msec 8 msec
  2 2001:504:1::A502:7319:1 8 msec 8 msec 8 msec
  3 f.root-servers.net (2001:500:2F::F) 8 msec 4 msec 80 msec

and...

rtr1.nyc#sh ipv6 int br
GigabitEthernet0/0         [up/up]
    unassigned
GigabitEthernet0/0.1       [up/up]
    FE80::217:FFF:FE1C:BC1B
    2620:0:CCC:0:217:FFF:FE1C:BC1B  <-- used in traceroute
GigabitEthernet0/2         [up/up]
    FE80::217:FFF:FE1C:BC19
    2001:504:1::A503:6692:1
Loopback0                  [up/up]
    FE80::217:FFF:FE1C:BC1B
    2620:0:CCC:1::1
[....]
Tunnel3800                 [up/up]
    FE80::217:FFF:FE1C:BC1B
Tunnel3802                 [up/up]
    FE80::217:FFF:FE1C:BC1B

in this case it uses an available global address. probably the lowest
number. (on this box, 2620:0:CCC:0:: < 2620:0:CCC:1::)

rtr1.nyc#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
rtr1.nyc(config)#int tun3800
rtr1.nyc(config-if)#ipv6 unnumbered lo0
rtr1.nyc(config-if)#^Z
rtr1.nyc#

Tunnel3800                 [up/up]
    FE80::217:FFF:FE1C:BC1B
    unnumbered (Loopback0)

and now...

rtr1.ash#traceroute 2001:500:2F::F         

Type escape sequence to abort.
Tracing the route to f.root-servers.net (2001:500:2F::F)

  1 2620:0:CCC:1::1 8 msec 8 msec 8 msec
  2 2001:504:1::A502:7319:1 4 msec 8 msec 12 msec
  3 f.root-servers.net (2001:500:2F::F) 8 msec 8 msec 8 msec
rtr1.ash#

... and now it uses the loopback.

-- bill

---

From: Mohacsi Janos <[email-masked]>
Date: Fri, 6 Jun 2008 07:02:56 +0200 (CEST)

> How does traceroute work when using link-local addressing on

Very well. It will pick up the one the global IPv6 address of the box as 
a sourceaddress of ICMPv6 TTL exceeded. If you 
want make it detereministic set up unnumbered to ipv6 loopback. In case of 
cisco routers e.g.:

interface GigabitEthernet3/4
  mtu 9216
  ipv6 unnumbered Loopback0      <------
  ipv6 enable
  ipv6 ospf network point-to-point

Regards,

Janos Mohacsi

---

From: Ralph Droms <[email-masked]>
Date: Fri, 6 Jun 2008 07:03:52 -0400

The DHCP server in Cisco's CNR supports prefixes of any length (up to / 
128).

- Ralph

---

From: "Dunn, Jeffrey H." <[email-masked]>
Date: Fri, 6 Jun 2008 07:41:55 -0400

Ralph,

Many thanks for the information.  Does this include prefix delegation? 

Best Regards,
 
Jeffrey Dunn
Info Systems Eng., Lead
MITRE Corporation.

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]] 
Sent: Friday, June 06, 2008 7:04 AM
To: Dunn, Jeffrey H.
Cc: Ralph Droms; Mohacsi Janos; [email-masked]
Subject: Re: Use of extended prefix lengths

128).

- Ralph

---

From: Ralph Droms <[email-masked]>
Date: Fri, 6 Jun 2008 10:17:30 -0400

Yes...

- Ralph