Subject: Re: Load Balancing for Mobile IP

From: Fred Baker <[email-masked]>
Date: Mon, 23 Mar 2009 18:03:20 -0700

Coming back to the WG with a question from this morning. We looked at  
the Load Balancing draft and our initial reaction was to ask Mobile IP  
to look at it. Mobile IP (Marcelo) is saying that they can look at the  
issue if there is a requirement, but they cannot determine whether  
there is a requirement.

ISPs on the list - is this kind of issue a requirement for you?

On Mar 23, 2009, at 3:00 PM, marcelo bagnulo braun wrote:

> I can see that the particular solution doesn't belong to v6ops, but  
> whether the question whether problem is real or not does seem to  
> belong to v6ops, right?
> I mean, certainly mext cannot have a position on whether we need a  
> load balancing mechanism for servers. We can certianly work on  
> adapting MIP6 to support this, and whether a MIP6 solution is  
> feasible and reaosnable, but i don't think we can detemrine if this  
> work needs to be done
>
>
> Fred Baker escribió:
>> The feedback in v6ops was as I stated. They thought this discussion  
>> belonged in your working group.
>>
>> On Mar 23, 2009, at 2:49 PM, marcelo bagnulo braun wrote:
>>
>>> Fred Baker escribió:
>>>>
>>>> On Mar 23, 2009, at 2:13 PM, marcelo bagnulo braun wrote:
>>>>
>>>>> Hi Fred,
>>>>>
>>>>> quickly checked the draft, and my first thoughts are:
>>>>> - seems only to deal with mip6 and not mip4, so i guess the mip4  
>>>>> guys could be off the hook, if they want to
>>>>> - seems to fall somewhere between 6man, mext and v6ops...
>>>>>
>>>>> I think the first question is whether we need this or not. I  
>>>>> think this input should come from ops, so that would be you :-)
>>>>
>>>> The CNNIC authors are looking at it from the perspective of  
>>>> Chinese telecom requirements. I'll let them tell me I'm wrong,  
>>>> but I presume they think this is important for their part of the  
>>>> world at minimum.
>>>>
>>>
>>> so, what was the feedback in v6ops?
>>> i mean, was any other people other than the authors that thought  
>>> this was needed?
>>>
>>>
>>>
>>>
>>>>> If you guys decide we need soemthing on these lines, we can then  
>>>>> figure out if we do it in mext or in 6man, or both of them,  
>>>>> jointly.
>>>>
>>>> I think one of those makes more sense than v6ops.
>>>>
>>>>> sounds reasonable?
>>>>>
>>>>> Regards, marcelo
>>>>>
>>>>>
>>>>> Fred Baker escribió:
>>>>>> I'd like to bring
>>>>>>
>>>>>> http://tools.ietf.org/html/draft-luo-v6ops-6man-shim6-lbam
>>>>>> "Load Balancing based on IPv6 Anycast and pseudo-Mobility",  
>>>>>> Wanming Luo,
>>>>>> XiaoDong Lee, Wei Mao, Mei Wang, 3-Nov-08,
>>>>>> <draft-luo-v6ops-6man-shim6-lbam-00.txt>
>>>>>>
>>>>>> to your attention. We discussed it briefly this morning in  
>>>>>> v6ops, as it is intended as a load-sharing solution. The sense  
>>>>>> of the room was that it either belonged in Mobile IP, or that  
>>>>>> we need to work together with Mobile IP on it.
>>>>>>
>>>>>> How would you recommend proceeding?
>>>>>>
>>>>>
>>>>
>>>>
>>>
>>
>>
>

---

From: Mark Smith <[email-masked]>
Date: Tue, 24 Mar 2009 21:19:42 +1030

Hi Fred,

On Mon, 23 Mar 2009 18:03:20 -0700

> ISPs on the list - is this kind of issue a requirement for you?

Yes. It was terrible to have to enable universal MSS hacking on
10 000s of ADSL customers' connections, just to deal with broken PMTUD
on PPPoE connections, caused by some NATting load balancers which broke
end-to-end transparency of ICMP Dest Unreachable Packet Too Bigs. A
IETF specified, NATless IPv6 load balancing solution would be great.

Regards,
Mark.

---

From: "luowanming" <[email-masked]>
Date: Tue, 24 Mar 2009 22:07:21 +0800

Thanks for Mark's comments. Because the topic of my draft  may involves some aspects of IPv6, it was difficult for me to decide which WG is suitable to submit. However, I think a flexible,  higher scalability, no topological constraint load balancing mechnism is necessory because there are indeed many IPv6 deployment scenarios needing load banlancing,e.g.NAT-PT,CGN, NAT64 ,Tunnel broker, or Multihoming. Thus, if we can  specify, NATless IPv6 load balancing solution which  also is seamless compatibility with IPv6 protocols will be very beneficial for IPv6 deployment and operation. So, what is the next step for this draft? Maybe it needs some modifications according to comments? or move to mext WG? or jointly worked by v6ops and Mobile IP?

Regards,
Wanming Luo

发件人： Mark Smith 
发送时间： 2009-03-24  19:27:00 
收件人： Fred Baker 
抄送： IPv6 Operations; mext-chairs; mip4-chairs; Kurt Erik Lindqvist; RonBonica; mext-ads; draft-luo-v6ops-6man-shim6-lbam 
主题： Re: Load Balancing for Mobile IP 
 
Hi Fred,
> > Fred Baker escribi?
> >>> Fred Baker escribi?
> >>>>> Fred Baker escribi?

---

From: Fred Baker <[email-masked]>
Date: Tue, 24 Mar 2009 10:04:32 -0700

On Mar 24, 2009, at 7:07 AM, luowanming wrote:

> So, what is the next step for this draft? Maybe it needs some  
> modifications according to comments? or move to mext WG? or jointly  
> worked by v6ops and Mobile IP?

In this context, I would expect v6ops to provide a problem statement,  
and mext to provide a solution. I think Mark summarized the problem  
statement, although Marcello may want it in more detail. In my  
opinion, the logical next step for a proposed solution is discussion  
in mext.

---

From: "luowanming" <[email-masked]>
Date: Wed, 25 Mar 2009 09:24:28 +0800

Hi Fred, 

According to your opinion, do we need a new draft to provide a problem statement? If true, I want to work it together with Mark and you.

Regards,
Wanming Luo

发件人： Fred Baker 
发送时间： 2009-03-25  01:04:57 
收件人： luowanming 
抄送： Mark Smith; IPv6 Operations; mext-chairs; mip4-chairs; Kurt Erik Lindqvist; RonBonica; mext-ads; draft-luo-v6ops-6man-shim6-lbam 
主题： Re: Load Balancing for Mobile IP

---

From: Fred Baker <[email-masked]>
Date: Wed, 25 Mar 2009 08:05:13 -0700

I think the problem is well-enough described. You really need to talk  
with Marcello

On Mar 24, 2009, at 6:24 PM, luowanming wrote:

> Hi Fred,
>
> According to your opinion, do we need a new draft to provide a  
> problem statement? If true, I want to work it together with Mark and  
> you.
>
> Regards,
> Wanming Luo
>
>
> 发件人： Fred Baker
> 抄送： Mark Smith; IPv6 Operations; mext-chairs; mip4-chairs; Kurt  
> Erik Lindqvist; RonBonica; mext-ads; draft-luo-v6ops-6man-shim6-lbam