Subject: Fwd: [Fwd: I-D Action:draft-carpenter-v6ops-isp-scenarios-02.txt]

From: Fred Baker <[email-masked]>
Date: Tue, 13 Apr 2010 05:47:51 -0700

Thanks Mohamed.

Any other comments from the working group?

Begin forwarded message:

> From: <[email-masked]>
> Date: April 13, 2010 5:19:20 AM PDT
> To: Fred Baker <[email-masked]>, Brian E Carpenter <[email-masked]>
> Cc: Kurt Erik Lindqvist <[email-masked]>
> Subject: RE: [Fwd: I-D Action:draft-carpenter-v6ops-isp-scenarios-02.txt]
> 
> 
> Dear all,
> 
> Please find attached my review of this document.
> 
> I fully agree to publish it.
> 
> Cheers,
> Med
> 
> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de Fred Baker
> Envoyé : mardi 13 avril 2010 08:12
> À : Brian E Carpenter
> Cc : Kurt Erik Lindqvist; IPv6 Operations
> Objet : Re: [Fwd: I-D Action:draft-carpenter-v6ops-isp-scenarios-02.txt]
> 
> If the working group agrees, I could simply send it to the AD as informational and having been done in the context of the working group. I would like at least one  content review.
> 
> On Apr 12, 2010, at 8:17 PM, Brian E Carpenter wrote:
> 
>> Hi, v6ops and chairs,
>> 
>> We've revised this draft, as discussed in Anaheim, as a factual report
>> on the ISP survey, without adding recommendations. We believe that it's
>> valuable to publish in this form, and that it cannot be mistaken for
>> recommendations, since it doesn't make any.
>> 
>> Fred and Kurtis, how should we proceed?
>> 
>> Brian and Sheng
>> 
>> -------- Original Message --------
>> Subject: I-D Action:draft-carpenter-v6ops-isp-scenarios-02.txt
>> Date: Mon, 12 Apr 2010 19:45:01 -0700 (PDT)
>> From: [email-masked]
>> Reply-To: [email-masked]
>> To: [email-masked]
>> 
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> 
>> 	Title           : Emerging Service Provider Scenarios for IPv6 Deployment
>> 	Author(s)       : B. Carpenter, S. Jiang
>> 	Filename        : draft-carpenter-v6ops-isp-scenarios-02.txt
>> 	Pages           : 18
>> 	Date            : 2010-04-12
>> 
>> This document describes practices and plans that are emerging among
>> Internet Service Providers for the deployment of IPv6.  They are
>> based on practical experience so far, as well as current plans and
>> requirements, reported in a survey carried out in early 2010.
>> 
>> A URL for this Internet-Draft is:
>> http://www.ietf.org/internet-drafts/draft-carpenter-v6ops-isp-scenarios-02.txt
>> 
> 
> http://www.ipinc.net/IPv4.GIF
> 
> 
> 
> *********************************
> This message and any attachments (the "message") are confidential and intended solely for the addressees. 
> Any unauthorised use or dissemination is prohibited.
> Messages are susceptible to alteration. 
> France Telecom Group shall not be liable for the message if altered, changed or falsified.
> If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
> ********************************
> 
> 

http://www.ipinc.net/IPv4.GIF

---

From: Mark Smith <[email-masked]>
Date: Thu, 15 Apr 2010 06:07:22 +0930

On Tue, 13 Apr 2010 05:47:51 -0700

> Any other comments from the working group?

I had a read of it yesterday, and found it interesting as a
"current state of play".

One thing I was a bit confused about was the discussion regarding
methods of assigning customers prefixes.

It seemed to be listing 5 methods, or a least the people who filled in
the survey thought there were 5 methods:

1) manual i.e. static route towards the customer
2) RA PIO + SLAAC
3) DHCPv6-PD
4) PPPoE (/PPP)
5) RADIUS

The first 3 are valid as of providing downstream customers with
address space.

PPPoE/PPP isn't, because IPv6 PPP only negotiates 64 bit IIDs, one of
the first 3 methods above have to be used after that. For people who
answered with that, I wonder if they understand that IPv6 PPP doesn't
work like it does in IPv4.

RADIUS is one of the ways to supply the prefix information to the first
3 methods. So unless people combined RADIUS with one of the first 3
methods, I'd also wonder if they fully understand how you assign IPv6
address space to downstream customers.

Is there enough data in the survey responses to clear the above up?

It's obviously too late for this survey, however if there is one in the
future, I think it'd be interesting to ask a bit more about how the
person filling in the survey learnt about IPv6, what they view it as
(i.e. just IPv4 with bigger addresses or IPv4 with improvements in a
few areas or a new protocol that has similarities with IPv4 as well as
other protocols), does their organisation have a formal training
program etc. Those sorts of questions can help determine why e.g. in
the case above, people seem to think IPv6 PPPoE/PPP works as it does in
IPv4.

(a minor nit, PPPoE has been abbreviated to PPoE in a few places)

Regards,
Mark.

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 15 Apr 2010 10:29:44 +1200

Mark,

> Fred Baker <[email-masked]> wrote:

Yes, we will incorporate the substantive comments in the
next version. Some of the more editorial comments may be left
for the judgment of the RFC Editor.

> I had a read of it yesterday, and found it interesting as a

Thanks for that
> work like it does in IPv4.

We really can't tell that from the answers, especially for people who
were replying about plans rather than experience.
> address space to downstream customers.

Ditto.

> Is there enough data in the survey responses to clear the above up?

In a word, no, unfortunately. This is clearly an area that needs
to be well documented in operational guidance. Whether that level of
detail belongs in a draft like draft-arkko-ipv6-transition-guidelines
is something we should discuss.
> the case above, people seem to think IPv6 PPPoE/PPP works as it does in

Agreed.
> (a minor nit, PPPoE has been abbreviated to PPoE in a few places)

OK, will fix.

Thanks
   Brian + Sheng