Subject: Re: [v4tov6transition] draft-arkko-ipv6-transition-guidelines WGLC

From: Tina TSOU <[email-masked]>
Date: Thu, 02 Sep 2010 11:32:09 +0800

Hi Matsushima-san,
It is very useful sharing.
I read the slides by my guessing Japanese and Chinese characters.

Would you like to share your SAM/4rd use case in Internet Draft form for Sep 
21/22 WebEx meeting (I'm discussing with Fred whether change the date to one 
day earlier, i.e. Sep 20/21, due to the Mid Autumn Festival in some Asian 
countries)?
Especially, people may be interested at how the network devices and CPE 
needs to change to meet the SAM/4rd requirements? Is there other experience 
besides the RFC related to SAM/4rd?

Here is the original meeting scheduling, might be subject to change.

http://www.ietf.org/mail-archive/web/v4tov6transition/current/msg00074.html

There were two I-Ds posted for the v4tov6transition work.
http://tools.ietf.org/html/draft-lee-v4v6tran-problem-00
http://tools.ietf.org/html/draft-carpenter-v4v6tran-framework-00
You comments are very welcome.

I-Ds in the pipeline:
http://www.ietf.org/mail-archive/web/v4tov6transition/current/msg00129.html

B. R.
Tina
http://tinatsou.weebly.com

----- Original Message ----- 
From: "Lee, Yiu" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Thursday, September 02, 2010 11:08 AM
Subject: Re: [v4tov6transition] draft-arkko-ipv6-transition-guidelines WGLC

> Hi Satoru,
>
> I assume most people on the list don't read Japanese. If you can summarize 
> the press release to us, it will be much appreciated.
>
> Thanks,
> Yiu
>
> On Sep 1, 2010, at 11:04 PM, "[email-masked]" 
> <[email-masked]> wrote:
>
>> Hi Remi, Fred and Jari,
>>
>> FYI,
>> SPs in Japan, BBIX, Internet Multifeed, JPIX and IIJ-II unveil the 
>> intention of
>> adopting SAM/4rd as a solution for their IPv4 service over IPv6 native 
>> network.
>>
>> We then support including Remi's helpful comment for section 4.3 in the 
>> draft.
>>
>> Please take look at these joint press release.
>>
>> BBIX:
>> http://www.bbix.net/press/file/press_20100831.pdf
>>
>> Internet Multifeed:
>> http://www.mfeed.co.jp/press/2010/pdf/20100831.pdf
>>
>> JPIX:
>> http://www.jpix.ad.jp/jp/pdf/20100831_001.pdf
>>
>> IIJ-II:
>> http://www.iij.ad.jp/news/pressrelease/2010/0831.html
>>
>>
>> Since these documents are written in Japanese originally, English page 
>> does not
>> available by now. So please read these with online translation service 
>> (not sure that quality),
>> or find your friend who can read Japanese. Sorry for that inconvenience.
>>
>> --
>> Satoru Matsushima
>>
>>
>>
>>
>>> -----Original Message-----
>>> From: Rémi Després [mailto:[email-masked]]
>>> Sent: Tuesday, August 31, 2010 7:06 PM
>>> To: Fred Baker; Jari Arkko
>>> Cc: IPv6 v6ops; Kurt Erik Lindqvist; Ron Bonica;
>>> [email-masked]
>>> Subject: Re: draft-arkko-ipv6-transition-guidelines WGLC
>>>
>>> Hi Fred, hi Jari,
>>>
>>> Sorry for the late answer.
>>> 1.
>>> The main issue I see is the need for a better balance between
>>> dual stack throughout and IPv6 across IPv4 infrastructures as
>>> recommended approaches for rapid deployments.
>>> The latter approach is more recent (with RFC 5569 and RFC
>>> 5969 issued in January and August 2010 respectively) but, as
>>> it proved to be the preferred one by a number of ISPs for
>>> their first deployment, it should be documented as such.
>>> 2.
>>> Also, there appears a converging interest for 4rd, the
>>> reverse of 6rd for IPv4 connectivity across IPv6-only ISP
>>> infrastructures (draft-vautrin-softwire-4rd-00 and
>>> draft-despres-softwire-sam-01 sec. 3.2).
>>> As it is a potential alternative or complement to DS-lite,
>>> that some ISPs can consider, and that at least one does
>>> consider on a confidential basis, it should IMHO be
>>> mentioned. (Of course it shouldn't be hidden that the
>>> specification is still much less advanced than that of DS-lite).
>>>
>>> Attached is a modified version of draft-06, in PDF and and in
>>> .doc, in  which I propose an example text to cover these points.
>>>
>>> Regards,
>>> RD
>>>
>>>
>> _______________________________________________
>> v4tov6transition mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/v4tov6transition
> _______________________________________________
> v4tov6transition mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v4tov6transition
>

---

From: Rémi Després <[email-masked]>
Date: Thu, 2 Sep 2010 09:42:21 +0200

Le 2 sept. 2010 à 05:32, Tina TSOU a écrit :

> Would you like to share your SAM/4rd use case in Internet Draft form for Sep 21/22 WebEx meeting (I'm discussing with Fred whether change the date to one day earlier, i.e. Sep 20/21, due to the Mid Autumn Festival in some Asian countries)?
> Especially, people may be interested at how the network devices and CPE needs to change to meet the SAM/4rd requirements? Is there other experience besides the RFC related to SAM/4rd?

Actually, SAM/4rd isn't described in any RFC yet.
The reference is draft-despres-softwire-sam-01.
- Section 2 describes the generic Stateless Address mapping model (SAM).
- Section 3.2 focuses on IPv4 across IPv6 infrastructures (4rd).
- How to statelessly share IPv4 public addresses using port-extended addresses is covered in section 2.4 (IPv4E).

Regards,
RD

> ----- Original Message ----- From: "Lee, Yiu" <[email-masked]>
>> I assume most people on the list don't read Japanese. If you can summarize the press release to us, it will be much appreciated.
>> 
>> Thanks,
>> Yiu
>> 
>> On Sep 1, 2010, at 11:04 PM, "[email-masked]" <[email-masked]> wrote:
>> 
>>> Hi Remi, Fred and Jari,
>>> 
>>> FYI,
>>> SPs in Japan, BBIX, Internet Multifeed, JPIX and IIJ-II unveil the intention of
>>> adopting SAM/4rd as a solution for their IPv4 service over IPv6 native network.
>>> 
>>> We then support including Remi's helpful comment for section 4.3 in the draft.
>>> 
>>> Since these documents are written in Japanese originally, English page does not
>>> available by now. So please read these with online translation service (not sure that quality),

---

From: Tina TSOU <[email-masked]>
Date: Thu, 02 Sep 2010 15:54:06 +0800

B. R.
Tina
http://tinatsou.weebly.com/index.html
----- Original Message ----- 
From: "Rémi Després" <[email-masked]>
To: "Tina TSOU" <[email-masked]>
Cc: <[email-masked]>; "Lee, Yiu" 
<[email-masked]>; <[email-masked]>; 
<[email-masked]>; <[email-masked]>
Sent: Thursday, September 02, 2010 3:42 PM
Subject: Re: [v4tov6transition] draft-arkko-ipv6-transition-guidelines WGLC

Le 2 sept. 2010 à 05:32, Tina TSOU a écrit :

> Would you like to share your SAM/4rd use case in Internet Draft form for 
> Sep 21/22 WebEx meeting (I'm discussing with Fred whether change the date 
> to one day earlier, i.e. Sep 20/21, due to the Mid Autumn Festival in some 
> Asian countries)?
> needs to change to meet the SAM/4rd requirements? Is there other 
> experience besides the RFC related to SAM/4rd?

Actually, SAM/4rd isn't described in any RFC yet.
The reference is draft-despres-softwire-sam-01.
- Section 2 describes the generic Stateless Address mapping model (SAM).
- Section 3.2 focuses on IPv4 across IPv6 infrastructures (4rd).
- How to statelessly share IPv4 public addresses using port-extended 
addresses is covered in section 2.4 (IPv4E).
[Tina: That means you created both 4rd and 6rd, and you deployed 6rd, and 
let Japanese operators deploy 4rd? A la la;-) AFAICS, there are NA cable, 
broadband fixed, mobile use case I-Ds are in the pipeline. Perhaps SAM/4rd 
needs to be referenced at least in one of them.]

Regards,
RD

>> I assume most people on the list don't read Japanese. If you can 
>> summarize the press release to us, it will be much appreciated.
>>
>> Thanks,
>> Yiu
>>