Subject: [v6ops] Home network architecture work

From: Ole Troan <[email-masked]>
Date: Wed, 10 Nov 2010 10:42:13 +0800

hi,

appears to be some interest in working on the home networking problem.

as agreed in today's meeting the first step should be to produce a "home network architecture document". requirements, use-cases, problem statement, architecture...

I'd like to put together a band of volunteers (aka design team) and get started asap.

could anyone interested on working on this (as in writing text) let me know?

Jari has graciously allowed us to use the IESG breakout room (room for 12).
I've reserved the room for tomorrow (Thursday) at 10:00 - 11:30.

cheers,
Ole

---

From: Don Sturek <[email-masked]>
Date: Tue, 9 Nov 2010 18:56:09 -0800 (PST)

Hi Ole,

Don Sturek (representing Pacific Gas and Electric, a large smart meter deployer) 
will volunteer to help with the requirements including writing text.

Don

________________________________
From: Ole Troan <[email-masked]>
To: IPv6 Operations <[email-masked]>
Sent: Tue, November 9, 2010 6:42:13 PM
Subject: [v6ops] Home network architecture work

hi,

as agreed in today's meeting the first step should be to produce a "home network 
architecture document". requirements, use-cases, problem statement, 
architecture...

I'd like to put together a band of volunteers (aka design team) and get started 
asap.

cheers,
Ole
_______________________________________________
v6ops mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/v6ops

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Tue, 9 Nov 2010 21:14:23 -0600

Folks,

Thanks much to Tom Herbst for his great prezo to v6ops today.  Now I am
clear on his devices and the home network routed topology of his
devices.  Thus the problem space (or architecture) in the home for the
IPv6 CE Router is to support a multi-homed WAN and a graphed routed LAN
topology in the home. All IPv6 features of the home router have got to
work for multi-homed WAN and a graphed routed topology in the LAN.
Note, the home LAN can be multi-homed too but the graphed topology takes
care of the LAN multi-homed case.  The current Phase II bis document on
the IPv6 CE Router can take care of new network arch,
requirements/problem statement etc..  Anyway, our current design team
(for IPv6 CE Rotuer) has been considering multi-homing and a graphed
routed topology in the home LAN.  

Regards,

Hemant

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Ole Troan
Sent: Wednesday, November 10, 2010 10:42 AM
To: IPv6 Operations
Subject: [v6ops] Home network architecture work

hi,

as agreed in today's meeting the first step should be to produce a "home
network architecture document". requirements, use-cases, problem
statement, architecture...

I'd like to put together a band of volunteers (aka design team) and get
started asap.

could anyone interested on working on this (as in writing text) let me
know?

Jari has graciously allowed us to use the IESG breakout room (room for
12).
I've reserved the room for tomorrow (Thursday) at 10:00 - 11:30.

cheers,
Ole

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Tue, 9 Nov 2010 21:17:15 -0600

Don,

Sure thing.   Welcome aboard.

Hemant

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Don Sturek
Sent: Wednesday, November 10, 2010 10:56 AM
To: Ole Troan; IPv6 Operations
Subject: Re: [v6ops] Home network architecture work

Hi Ole,

Don Sturek (representing Pacific Gas and Electric, a large smart meter
deployer) will volunteer to help with the requirements including writing
text.

Don

hi,

cheers,
Ole

---

From: Tina TSOU <[email-masked]>
Date: Wed, 10 Nov 2010 11:20:36 +0800

Does it consider the use case of v6 only host and v6 only CPE?

B. R.
Tina
http://tinatsou.weebly.com

On Nov 10, 2010, at 11:17 AM, Hemant Singh (shemant) wrote:

> From: [email-masked] [mailto:[email-masked]] On  
> Behalf Of Don Sturek
> Don Sturek (representing Pacific Gas and Electric, a large smart  
> meter deployer) will volunteer to help with the requirements  
> including writing text.
>
> Don
>
>
> as agreed in today's meeting the first step should be to produce a  
> "home network architecture document". requirements, use-cases,  
> problem statement, architecture...
>

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Tue, 9 Nov 2010 21:25:38 -0600

Tina,

What do you mean by "it"?  Also, by CPE, do you mean the CPE Router?

Hemant

From: Tina TSOU [mailto:[email-masked]] 
Sent: Wednesday, November 10, 2010 11:21 AM
To: Hemant Singh (shemant)
Cc: Don Sturek; Ole Troan; IPv6 Operations
Subject: Re: [v6ops] Home network architecture work

B. R.

Tina

 

Don,

Hemant

From: [email-masked] [mailto:[email-masked]
onverted-space"> On Behalf Of Don Sturek
Sent: Wednesday, November 10, 2010 10:56 AM
To: Ole Troan; IPv6 Operations
Subject: Re: [v6ops] Home network architecture work

  <mailto:[email-masked]> 

Hi Ole,

Don <mailto:[email-masked]> 

  <mailto:[email-masked]> 

<mailto:[email-masked]> 
________________________________

From: Ole Troan < <mailto:[email-masked]> [email-masked]
<mailto:[email-masked]> >
To: [email-masked]>
Sent: Tue, November 9, 2010 6:42:13 PM
Subject: [v6ops] Home network architecture work

hi,

cheers,
Ole
_____ _________________
v6ops mailing list
[email-masked]

---

From: Ole Troan <[email-masked]>
Date: Wed, 10 Nov 2010 11:28:19 +0800

Hemant,

> routed topology in the home LAN.  

I think the suggestion that the current phase 2 document could continue down the bullet 1 path; limited scope specify the remaining issues on the CPE.

the home networking architecture would not have the limitations that the CPE requirements "series" has. in particular not restricted to being "non-innovative".

I see the two work items as independent. that is also why I want to form a new design team working on the home networking problem.

cheers,
Ole

---

From: Ole Troan <[email-masked]>
Date: Wed, 10 Nov 2010 11:30:42 +0800

Tina,

> Does it consider the use case of v6 only host and v6 only CPE?

this relates to the homegate/homenet discussion of should we make this work for both IPv4 and IPv6. I _think_ consensus is to do this work for IPv6. to the extent that it also works for IPv4, fine, but not do IPv4 only work.

cheers,
Ole

>> From: [email-masked] [mailto:v6ops-bounces@ ietf.org onverted-space"> On Behalf Of Don Sturek
>> Don Sturek (representing Pacific Gas and Electric, a large smart meter deployer) will volunteer to help with the requirements including writing text.
>> 
>> Don
>> 
>>  
>> Ole< br>_____ _________________
>> v6ops mailing list
>> [email-masked]

---

From: Tina TSOU <[email-masked]>
Date: Wed, 10 Nov 2010 11:30:49 +0800

Hemant,

B. R.
Tina

On Nov 10, 2010, at 11:25 AM, Hemant Singh (shemant) wrote:

> Tina,
>
> What do you mean by “it”?
The home network architecture document.
> Also, by CPE, do you mean the CPE Router?
The home gateway.
> From: [email-masked] [mailto:[email-masked] onverted- 
> space"> On Behalf Of Don Sturek

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Tue, 9 Nov 2010 21:31:21 -0600

Ole,

Note sure yet.  The summary I have outlined has always been a plan for
Phase III of the v6ops CE Router document. 

Hemant

-----Original Message-----
From: Ole Troan [mailto:[email-masked]] On Behalf Of Ole Troan
Sent: Wednesday, November 10, 2010 11:28 AM
To: Hemant Singh (shemant)
Cc: IPv6 Operations; [email-masked]; [email-masked]
Subject: Re: [v6ops] Home network architecture work

Hemant,

> routed topology in the home LAN.  

I think the suggestion that the current phase 2 document could continue
down the bullet 1 path; limited scope specify the remaining issues on
the CPE.

the home networking architecture would not have the limitations that the
CPE requirements "series" has. in particular not restricted to being
"non-innovative".

I see the two work items as independent. that is also why I want to form
a new design team working on the home networking problem.

cheers,
Ole

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Tue, 9 Nov 2010 21:34:18 -0600

Tina,

The answer to your original question is yes.   Note, from day one, our
work on the home gateway stayed with specifying IPv6 behavior.  

Thanks,

Hemant

Sent: Wednesday, November 10, 2010 11:31 AM

Hemant,

B. R.

Tina

 

Tina,

What do you mean by "it"?  

The home gateway.

Hemant

B. R.

Tina

 

Don,

Hemant

Hi Ole,

 

hi,

cheers,
Ole
_____ _________________
v6ops mailing list
[email-masked]

---

From: Fred Baker <[email-masked]>
Date: Wed, 10 Nov 2010 12:01:57 +0800

> this relates to the homegate/homenet discussion of should we make this work for both IPv4 and IPv6. I _think_ consensus is to do this work for IPv6. to the extent that it also works for IPv4, fine,…

I can't say I know what's happening in homenet - I'm on the list but not following it closely. That said, my personal view is that current IPv4 residential gateways, and the IPv4 side of tomorrow's dual stack residential gateway, are what they are and are unlikely to change at this point. The question *I* think is before the house is "what should a residential gateway do with IPv6 traffic".

---

From: Joel Jaeggli <[email-masked]>
Date: Wed, 10 Nov 2010 12:12:48 +0800

On 11/10/10 12:01 PM, Fred Baker wrote:
>> this relates to the homegate/homenet discussion of should we make
>> this work for both IPv4 and IPv6. I _think_ consensus is to do this
>> work for IPv6. to the extent that it also works for IPv4, fine, but
>> not do IPv4 only work.
> 
> I can't say I know what's happening in homenet - I'm on the list but
> not following it closely. That said, my personal view is that current
> IPv4 residential gateways, and the IPv4 side of tomorrow's dual stack
> residential gateway, are what they are and are unlikely to change at
> this point. The question *I* think is before the house is "what
> should a residential gateway do with IPv6 traffic". 

specific to the issues with zigbee seems like the ipv4 case isn't a big
deal there anyway.

> _______________________________________________ v6ops mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Mark Townsley <[email-masked]>
Date: Wed, 10 Nov 2010 13:51:45 +0800

> > this relates to the homegate/homenet discussion of should we make this work for both IPv4 and IPv6. I _think_ consensus is to do this work for IPv6. to the extent that it also works for IPv4, fin…
Indeed, that was what the consensus was driving towards in homegate/net
back when it was still active. However, as far as I can tell this effort
has been abandoned and the v6 portion of it is now popping up in v6ops.
> I can't say I know what's happening in homenet - I'm on the list but not following it closely. That said, my personal view is that current IPv4 residential gateways, and the IPv4 side of tomorrow's dual stack residential gateway, are what they are and are unlikely to change at this point. The question *I* think is before the house is "what should a residential gateway do with IPv6 traffic"
Focusing on v6 in v6ops makes sense to me.

- Mark

---

From: Tetsuya Murakami <[email-masked]>
Date: Wed, 10 Nov 2010 08:49:18 -0800

Hi Ole,

I (Tetsuya Murakami, IP Infusion Inc) am interested in this work. So, I would like to join the meeting tomorrow.

Thanks,
Tetsuya Murakami

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 10 Nov 2010 18:19:36 -0800 (PST)

I am in this room now (Ruby) and there is no one else :-)

Mark was here also but he left.

Behcet

----- Original Message ----
> From: Tetsuya Murakami <[email-masked]>
> To: Ole Troan <[email-masked]>
> Cc: IPv6 Operations <[email-masked]>
> Sent: Wed, November 10, 2010 10:49:18 AM
>network architecture document". requirements,  use-cases, problem statement, 
>architecture...
> > 
know?

---

From: Don Sturek <[email-masked]>
Date: Wed, 10 Nov 2010 18:26:42 -0800 (PST)

We are in Rose.....

Don

________________________________
From: Behcet Sarikaya <[email-masked]>
To: Tetsuya Murakami <[email-masked]>; Ole Troan <[email-masked]>
Cc: IPv6 Operations <[email-masked]>
Sent: Wed, November 10, 2010 6:19:36 PM
Subject: Re: [v6ops] Home network architecture work

Behcet

----- Original Message ----
> I (Tetsuya Murakami, IP Infusion Inc) am interested in this work.  So, I would 

>like to join the meeting tomorrow.
> 
> Thanks,
> Tetsuya  Murakami
> 
know?