Subject: [v6ops] draft-vandevelde-v6ops-harmful-tunnels

From: Brian E Carpenter <[email-masked]>
Date: Wed, 10 Nov 2010 15:41:26 +1300

Logging my microphone comment: documenting 6to4 and teredo operational
issues is useful, but it would be much more helpful to give explicit
advice to ISPs how to fix this. For example, tell ISPs with content-provider
customers who offer v6 service that they (the ISPs) SHOULD operate 6to4
relay(s) and advertise 2002::/16 to those customers, so as to guarantee
a good return path to a client who has found a 6to4 anycast relay somehow.

So (echoing Fred Templin), let's be constructive rather than use
negative language like 'considered harmful.'

-- 
Regards
   Brian Carpenter

---

From: "Templin, Fred L" <[email-masked]>
Date: Tue, 9 Nov 2010 18:54:31 -0800

"Considered harmful" was first popularized by Dijkstra in 1968
wrt use of the "goto" statement:

http://en.wikipedia.org/wiki/Considered_harmful

Gotos are still widely used today.

Fred
[email-masked]  

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Brian E Carpenter
> Sent: Tuesday, November 09, 2010 6:41 PM
> To: IPv6 Operations
> Subject: [v6ops] draft-vandevelde-v6ops-harmful-tunnels
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Scott Brim <[email-masked]>
Date: Wed, 10 Nov 2010 10:55:38 +0800

> Gotos are still widely used today.

I think you're proving Joel's point.

---

From: "Templin, Fred L" <[email-masked]>
Date: Tue, 9 Nov 2010 18:57:32 -0800

> From: Scott Brim [mailto:[email-masked]] 
> Sent: Tuesday, November 09, 2010 6:56 PM
> To: Templin, Fred L
> Cc: Brian E Carpenter; IPv6 Operations
> Subject: Re: [v6ops] draft-vandevelde-v6ops-harmful-tunnels
> 

Eh? Show me a linux network driver that does *not* use them
in a way that is beneficial to the code.

Fred