Subject: Re: [v6ops] IPv6 for mobile

From: <[email-masked]>
Date: Sat, 25 Dec 2010 22:36:47 +0000

Hi,

I have very closely followed IPv6 on 3GPP area only since 2003 (I say only because I know this list has readers with significantly longer experience).

For the longest time there really was no *real* business interest for IPv6 within the industry (IPv4 was enough - for the time). Due to the lack of *real* business interest we now have basebands without IPv6, handset OSes without IPv6 (or IPv6 disabled on purpose by the vendor), handsets without IPv6 for some access technologies, handsets with some amount of IPv6 but not 100%, APIs without IPv6, applications without (properly tested) IPv6, networks without IPv6, networks without all required components in place (such as billing), and so forth - a fragmented IPv6 support.

3GPP discussed the tools required for transition in length quite recently, and it was clear that the dual-stack and IPv6-only with NAT64 are the ways to go. There are some discussions alive relating to host based IPv4 on-demand and double translation schemes, but host based tunneling approaches have been clearly abandoned due complexities they bring.

The 6RD does not really help in 3GPP based cellular networks, because the root cause is not lack of technologies to offer IPv6 connectivity, but lack of business interest to do so. And when the business interest really arises the small problems like lack of baseband IPv6 support and such are sure to be promptly fixed.

So my opinion is that the lack of IPv6 here and there is best fixed by increasing the thing called demand. And I have to say that after many years of waiting the demand is really starting to be there - as we can see also on this list.

Hence I would call for some patience; the existing transition mechanism toolbox is quite good but requires implementation, which will arrive when the time is ripe. Actually, I would personally be quite surprised if there were significant players in mobile industry still choosing to totally ignore IPv6. The pipelines just have their variable lengths.

Best regards,

Teemu

---

From: Hesham Soliman <[email-masked]>
Date: Sun, 26 Dec 2010 14:51:34 +1100

Amen! I completely agree.
Hesham

On 26/12/10 9:36 AM, "[email-masked]"
<[email-masked]> wrote:

> Hi,
> 
> I have very closely followed IPv6 on 3GPP area only since 2003 (I say only
> because I know this list has readers with significantly longer experience).
> 
> For the longest time there really was no *real* business interest for IPv6
> within the industry (IPv4 was enough - for the time). Due to the lack of
> *real* business interest we now have basebands without IPv6, handset OSes
> without IPv6 (or IPv6 disabled on purpose by the vendor), handsets without
> IPv6 for some access technologies, handsets with some amount of IPv6 but not
> 100%, APIs without IPv6, applications without (properly tested) IPv6, networks
> without IPv6, networks without all required components in place (such as
> billing), and so forth - a fragmented IPv6 support.
> 
> 3GPP discussed the tools required for transition in length quite recently, and
> it was clear that the dual-stack and IPv6-only with NAT64 are the ways to go.
> There are some discussions alive relating to host based IPv4 on-demand and
> double translation schemes, but host based tunneling approaches have been
> clearly abandoned due complexities they bring.
> 
> The 6RD does not really help in 3GPP based cellular networks, because the root
> cause is not lack of technologies to offer IPv6 connectivity, but lack of
> business interest to do so. And when the business interest really arises the
> small problems like lack of baseband IPv6 support and such are sure to be
> promptly fixed.
> 
> So my opinion is that the lack of IPv6 here and there is best fixed by
> increasing the thing called demand. And I have to say that after many years of
> waiting the demand is really starting to be there - as we can see also on this
> list.
> 
> Hence I would call for some patience; the existing transition mechanism
> toolbox is quite good but requires implementation, which will arrive when the
> time is ripe. Actually, I would personally be quite surprised if there were
> significant players in mobile industry still choosing to totally ignore IPv6.
> The pipelines just have their variable lengths.
> 
> Best regards,
> 
> Teemu
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Mikael Abrahamsson <[email-masked]>
Date: Sun, 26 Dec 2010 08:06:36 +0100 (CET)

On Sat, 25 Dec 2010, [email-masked] wrote:

> The 6RD does not really help in 3GPP based cellular networks, because 
> the root cause is not lack of technologies to offer IPv6 connectivity, 
> but lack of business interest to do so. And when the business interest 
> really arises the small problems like lack of baseband IPv6 support and 
> such are sure to be promptly fixed.

6RD might be of help if this means an old device can gain DS connectivity 
by means of installing an app (I have no idea if it can be done for Apple 
iOS and Android devices) where the baseband upgrade would cost money and 
the vendor is not interested in forking out this money for devices already 
sold.

And the rest of your email just describes why short sighted market economy 
often doesn't do the right long term thing, but discussing this would be a 
political discussion so let's not get into that.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Rémi Després <[email-masked]>
Date: Mon, 27 Dec 2010 09:45:28 +0100

Le 25 déc. 2010 à 23:36, <[email-masked]> <[email-masked]> a écrit :
> ... 3GPP discussed the tools required for transition in length quite recently, and it was clear that

> the dual-stack and IPv6-only with NAT64 are the ways to go.

These two ways, however, shouldn't be believed to be on the same footing.
IMHO, people should understand that NAT64 is NOT as good as dual-stack for all applications of mobile devices.

> There are some discussions alive relating to host based IPv4 on-demand and double translation schemes, but

>  host based tunneling approaches have been clearly abandoned due complexities they bring. 

The lack of complexity of 6rd must have been either ignored or misunderstood.

> The 6RD does not really help in 3GPP based cellular networks, because the root cause is not lack of technologies to offer IPv6 connectivity,

Existence of several reasons for the slow deployment of IPv6 isn't sufficient to believe that 6rd can't accelerate it.

> So my opinion is that the lack of IPv6 here and there is best fixed by increasing the thing called demand.

Rapidly offering a *non disruptive* IPv6 service at a greatly minimized cost will increase IPv6 actual use by ordinary users (e.g. with Google).
New applications and user demand will follow.

BTW, do we know applications that can work across NAT64 without working also across cascaded NAT44s?

> ... Hence I would call for some patience; the existing transition mechanism toolbox is quite good but requires implementation, which will arrive when the time is ripe. 

My understanding of Tele2's need expressed by Mikael Abrahamsson on this thread is IPv6 connectivity:
- asap
- plug and play 
- without losing any currently available connectivity 

> Actually, I would personally be quite surprised if there were significant players in mobile industry still choosing to totally ignore IPv6.

So would I.

> The pipelines just have their variable lengths.

But if, at least for some operators, if this length can be reduced by a simple shortcut (based on a technology that has been validated on fixed networks), then why not?

Regards,
RD