Subject: [v6ops] Fwd: New Version Notification for draft-ietf-v6ops-rfc3316bis-02.txt

From: Jouni Korhonen <[email-masked]>
Date: Mon, 6 May 2013 11:16:15 +0300

Folks,

We have updated the RFC 3316bis based on the discussion/comments in the
last IETF. The I-D is getting to "about ready" state now.

- Jouni

Begin forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-ietf-v6ops-rfc3316bis-02.txt
> Date: May 6, 2013 11:13:41 AM GMT+03:00
> To: Teemu Savolainen <[email-masked]>, Jari Arkko <[email-masked]>, Jouni Korhonen <[email-masked]>, Suresh Krishnan <[email-masked]>
> 
> 
> A new version of I-D, draft-ietf-v6ops-rfc3316bis-02.txt
> has been successfully submitted by Jouni Korhonen and posted to the
> IETF repository.
> 
> Filename:	 draft-ietf-v6ops-rfc3316bis
> Revision:	 02
> Title:		 IPv6 for 3GPP Cellular Hosts
> Creation date:	 2013-05-06
> Group:		 v6ops
> Number of pages: 19
> URL:             http://www.ietf.org/internet-drafts/draft-ietf-v6ops-rfc3316bis-02.txt
> Status:          http://datatracker.ietf.org/doc/draft-ietf-v6ops-rfc3316bis
> Htmlized:        http://tools.ietf.org/html/draft-ietf-v6ops-rfc3316bis-02
> Diff:            http://www.ietf.org/rfcdiff?url2=draft-ietf-v6ops-rfc3316bis-02
> 
> Abstract:
>   As the deployment of third and fourth generation cellular networks
>   progresses, a large number of cellular hosts are being connected to
>   the Internet.  Standardization organizations are making Internet
>   Protocol version 6 (IPv6) mandatory in their specifications.
>   However, the concept of IPv6 covers many aspects and numerous
>   specifications.  In addition, the characteristics of cellular links
>   in terms of bandwidth, cost and delay put special requirements on how
>   IPv6 is used.  This document considers IPv6 for cellular hosts that
>   attach to the General Packet Radio Service (GPRS), Universal Mobile
>   Telecommunications System (UMTS), or Evolved Packet System (EPS)
>   networks (Hereafter collectively referred to as 3GPP networks).  This
>   document also lists out specific IPv6 functionality that needs to be
>   implemented in addition what is already prescribed in the IPv6 Node
>   Requirements document.  It also discusses some issues relating to the
>   use of these components when operating in these networks.  This
>   document obsoletes RFC 3316.
> 
> 
> 
> 
> The IETF Secretariat
>

---

From: Vízdal Aleš <[email-masked]>
Date: Tue, 14 May 2013 01:14:24 +0200

Hi Jouni,

Thanks for the update. Please find my review attached.

Cheers,
Ales

PS. Not being a native speaker means that my language corrections may be wrong :-)

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Jouni
> Korhonen
> Sent: Monday, May 06, 2013 10:16 AM
> To: [email-masked] Operations
> Subject: [v6ops] Fwd: New Version Notification for draft-ietf-v6ops-rfc3316bis-02.txt
> 
> 
> Folks,
> 
> We have updated the RFC 3316bis based on the discussion/comments in the last IETF.
> The I-D is getting to "about ready" state now.
> 
> - Jouni
> 
> Begin forwarded message:
> 
> > To: Teemu Savolainen <[email-masked]>, Jari Arkko
> > <[email-masked]>, Jouni Korhonen <[email-masked]>,
> > Suresh Krishnan <[email-masked]>
> >
> >
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 15 May 2013 10:33:22 +0300

Ales,

THank you for the review.. It might sound boring but I more or less agree with all your comments :)

Few specific discussion points you had in the review:

* "Would it make sense to mention that the cellular network may be sending RAs every 4 hours to save air resources as hinted in the 3GPP spec?"

I can mention the 29.061 suggested time. So implementations seem to use much longer RA intervals. I have seen intervals up to 18 hours.

* "It could be mentioned that the assigned IPv6 prefix is valid for the lifetime of a PDP context and cannot be changed without tearing down the cellular link/connection."

Hmm.. I though I had this mentioned. Maybe it was in some other text I wrote recently. Will add this note.

* Comment VA9: 

Agree with the comment. Specifically with "MiFi" use cases the same prefix may be used for days or even longer. I'll reword this towards more "privacy friendly".

* Comment VA10:

The PD is discussed in more detail in the following section. I would not implement this comment as such.

* Comment VA11:

There is the other I-D that can discuss PCOs. I would not add those here :)

* Comment VA12:

Alas 3GPP specs are still silent about RFC6106. In that sense maybe changing should to may would suffice. Indeed the split-UE use case is where RFC6106 is useful. There is a lot of weird stuff in USB stick / MiFi front.. like the one your referred to. Some of those did not support SLAAC but only DHCPv6 ;) Obviously those do not really adhere to 3GPP link model..

* Comment VA15:

IMEI.

- Jouni

On May 14, 2013, at 2:14 AM, Vízdal Aleš <[email-masked]> wrote:

> <3316bis-review.pdf>