Subject: Re: [v6ops] DHCPv6/SLAAC Make Hosts Confusing-//RE: new draft: draft-liu-bonica-v6ops-dhcpv6-slaac-problem

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 30 Oct 2013 21:39:16 +0000

I think we have to be a bit careful about "application". We certainly don't want DHCP to configure user based application information. But network configuration related to applications may be valid (although if there are other discovery techniques available, they may well be preferred).

DHCP SHOULD configure the network resources available for the client device to use (i.e., things needed to provide tnetwork connectivity and access to that network's services). It should not configure user specific services (i.e., there was some discussion about email (SMTP, POP, IMAP server) information as an example of something that would not be DHCP configured).

This is a bit tricky to clarify. And, I am certain someone will have issues with my attempt; hopefully they can do better.

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark ZZZ Smith
Sent: Wednesday, October 30, 2013 4:06 PM
To: Ted Lemon
Cc: [email-masked]; Ole Troan (otroan); Dave Thaler; [email-masked]
Subject: Re: [v6ops] DHCPv6/SLAAC Make Hosts Confusing-//RE: new draft: draft-liu-bonica-v6ops-dhcpv6-slaac-problem

----- Original Message -----
> From: Ted Lemon <[email-masked]>
> To: Mark ZZZ Smith <[email-masked]>
> Cc: Andrew Yourtchenko <[email-masked]>; Lorenzo Colitti 
> <[email-masked]>; 
> "[email-masked]" 
> <[email-masked]>; 
> "[email-masked]" <[email-masked]>; Ole Troan (otroan) 
> <[email-masked]>; Dave Thaler <[email-masked]>
> Sent: Wednesday, 30 October 2013 11:07 PM
> Subject: Re: [v6ops] DHCPv6/SLAAC Make Hosts Confusing-//RE: new 
> draft: draft-liu-bonica-v6ops-dhcpv6-slaac-problem
> 
> On Oct 30, 2013, at 4:22 AM, Mark ZZZ Smith 
> <[email-masked]>
> wrote:
> 
>>  I think DHCPv6 is really solving the application layer configuration
> problem, which is independent of and not specific to the underlying 
> links and network layer parameters.
> 
> Actually DHCPv6 is a poor solution to that problem, because 
> application configuration is not typically network-specific.  This has 
> been discussed at some length recently on the IETF mailing list.
> 

I'll have to look that up. Thanks for letting me know.

I have recently been thinking a bit more about that in the context of the DHCPv6 option transparency draft I posted, and have started to wonder if LDAP or SLP style directories would be better, with a special well known directory branch to represent network or subnet local application parameters.

Thanks,
Mark.
_______________________________________________
v6ops mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/v6ops

---

From: Ted Lemon <[email-masked]>
Date: Wed, 30 Oct 2013 22:16:17 +0000

> This is a bit tricky to clarify. And, I am certain someone will have issues with my attempt; hopefully they can do better.

One point of clarification that I found useful but was not universally applauded was the notion that if the protocol is or was in the Internet area, it's probably something you can configure with DHCP; if it's not, think carefully before using DHCP to configure it.

This lets out a _lot_ of stuff that has options in DHCPv4.   But I can't think of anything it excludes that I'd want to keep around.   Of course, Mobile IPv6 is an Internet area protocol, and it's not entirely clear to me that it's configurable via DHCP, although there exist DHCP options to configure it.