Subject: [v6ops] Revised Internet Drafts for allocation of IPv6 space for LISP EIDs

From: John Curran <[email-masked]>
Date: Wed, 23 Oct 2013 19:59:07 +0800

V6ops Folks - 

    There are two revised Internet Drafts in the Lisp working group that might 
    be worth reviewing by those running IPv6 networks.   These drafts will 
    allocate a /16 IPv6 prefix for use as LISP global Endpoint IDentifier (EID) 
    space and define the associated allocation framework.  Assignments
    from this block may appear the in the BGP routing infrastructure.

FYI,
/John

Begin forwarded message:

> From: Luigi Iannone <[email-masked]>
> Subject: [lisp] Fwd: I-D Action: draft-iannone-lisp-eid-block-mgmnt-03.txt
> Date: October 21, 2013 9:23:26 PM GMT+08:00
> To: "[email-masked] list" <[email-masked]>
> 
> Hi All,
> 
> the EID block documents have been updated as discussed during the last meeting in Orlando.
> 
> Since both documents changed a lot would be great if people can read them and send feedback
> 
> thanks
> 
> ciao
> 
> Luigi
> 
> Begin forwarded message:
> 
>> From: [email-masked]
>> Subject: I-D Action: draft-iannone-lisp-eid-block-mgmnt-03.txt
>> Date: 21 October 2013 15:14:46 GMT+02:00
>> To: [email-masked]
>> Reply-To: [email-masked]
>> 
>> 
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> 
>> 
>> 	Title           : LISP EID Block Management Guidelines
>> 	Author(s)       : Luigi Iannone
>>                          Roger Jorgensen
>>                          David Conrad
>> 	Filename        : draft-iannone-lisp-eid-block-mgmnt-03.txt
>> 	Pages           : 11
>> 	Date            : 2013-10-21
>> 
>> Abstract:
>>   This document proposes an allocation framework for the management of
>>   the LISP EID address prefix (requested in [I-D.ietf-lisp-eid-block]).
>>   The framework described relies on hierarchical distribution of the
>>   address space with sub-prefixes allocated on a temporary basis to
>>   requesting organizations.
>> 
>> 
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-iannone-lisp-eid-block-mgmnt
>> 
>> There's also a htmlized version available at:
>> http://tools.ietf.org/html/draft-iannone-lisp-eid-block-mgmnt-03
>> 
>> A diff from the previous version is available at:
>> http://www.ietf.org/rfcdiff?url2=draft-iannone-lisp-eid-block-mgmnt-03
>> 
>> 
>> Please note that it may take a couple of minutes from the time of submission
>> until the htmlized version and diff are available at tools.ietf.org.
>> 
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>> 
>> _______________________________________________
>> I-D-Announce mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/i-d-announce
>> Internet-Draft directories: http://www.ietf.org/shadow.html
>> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

Begin forwarded message:

> From: [email-masked]
> Subject: [lisp] I-D Action: draft-ietf-lisp-eid-block-06.txt
> Date: October 21, 2013 9:12:38 PM GMT+08:00
> To: [email-masked]
> Cc: [email-masked]
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Locator/ID Separation Protocol Working Group of the IETF.
> 
> 	Title           : LISP EID Block
> 	Author(s)       : Luigi Iannone
>                          Darrel Lewis
>                          David Meyer
>                          Vince Fuller
> 	Filename        : draft-ietf-lisp-eid-block-06.txt
> 	Pages           : 16
> 	Date            : 2013-10-21
> 
> Abstract:
>   This is a direction to IANA to allocate a /16 IPv6 prefix for use
>   with the Locator/ID Separation Protocol (LISP).  The prefix will be
>   used for local intra-domain routing and global endpoint
>   identification, by sites deploying LISP as EID (Endpoint IDentifier)
>   addressing space.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-lisp-eid-block
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ietf-lisp-eid-block-06
> 
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-ietf-lisp-eid-block-06
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: Brian Haberman <[email-masked]>
Date: Wed, 23 Oct 2013 11:21:15 -0400

Hi John,

>     from this block may appear the in the BGP routing infrastructure.

With no hat on... I don't think there is any "may" about their
appearance in BGP route tables.

Regards,
Brian

> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Gert Doering <[email-masked]>
Date: Wed, 23 Oct 2013 17:25:49 +0200

Hi,

> appearance in BGP route tables.

So is this "will" or "MUST NOT"?

I haven't read the IDs yet, but would be wary about any "we're not happy
with the way the RIRs hand out addresses, so we build our own system
in parallel to it, and to hell with global routing" drafts.

If that's just "we use this inside LISP, and RIR space will used on
the outside", these addresses SHOULD NOT appear in global BGP.

Gert Doering
        -- NetMaster
-- 
have you enabled IPv6 on something today...?

SpaceNet AG                        Vorstand: Sebastian v. Bomhard
Joseph-Dollinger-Bogen 14          Aufsichtsratsvors.: A. Grundner-Culemann
D-80807 Muenchen                   HRB: 136055 (AG Muenchen)
Tel: +49 (0)89/32356-444           USt-IdNr.: DE813185279

---

From: Brian Haberman <[email-masked]>
Date: Wed, 23 Oct 2013 11:29:36 -0400

Hi Gert,

> So is this "will" or "MUST NOT"?

"Will" by my interpretation and based on discussions within the LISP WG.
 To quote http://tools.ietf.org/html/draft-ietf-lisp-eid-block-06#section-7

"In order to provide connectivity between the Legacy Internet and LISP
sites, PITRs announcing large aggregates (ideally one single large
aggregate) of the IPv6 EID Block could be deployed."

Regards,
Brian

---

From: Lorenzo Colitti <[email-masked]>
Date: Thu, 24 Oct 2013 00:31:25 +0900

> aggregate) of the IPv6 EID Block could be deployed."

That sounds very much like a 6to4 relay router, which experience has shown
was an unworkable deployment model. Why is this different?

---

From: Brian Haberman <[email-masked]>
Date: Wed, 23 Oct 2013 11:36:50 -0400

Hi Lorenzo,

> was an unworkable deployment model. Why is this different?

It's not different.  But, that is the tact the LISP WG is trying to
take.  Keep in mind that the referenced draft went through IETF Last
Call and was subsequently sent back to the WG due to the concerns raised
about routing and potentially creating a parallel address registry
outside of the RIRs.

Regards,
Brian

---

From: Gert Doering <[email-masked]>
Date: Wed, 23 Oct 2013 18:02:02 +0200

Hi,

> aggregate) of the IPv6 EID Block could be deployed."

Mmmh, someone got told how 6to4 anycast not-worked and intends to bring it all
back.  Yay.

Gert Doering
        -- NetMaster

---

From: Gert Doering <[email-masked]>
Date: Wed, 23 Oct 2013 18:06:49 +0200

Hi,

On Wed, Oct 23, 2013 at 11:36:50AM -0400, Brian Haberman wrote:
> Keep in mind that the referenced draft went through IETF Last

These are the concerns I share, so I consider this pushback to be good
news.  And no, I do not have reasonable ideas how to solve this, as 
I see this area as one of the hardest points in deploying LISP in a
mixed LISP-talks-to-non-LISP model.

Thanks for the background info.

Gert Doering
        -- NetMaster

---

From: Lorenzo Colitti <[email-masked]>
Date: Thu, 24 Oct 2013 01:11:09 +0900

On Thu, Oct 24, 2013 at 12:36 AM, Brian Haberman
<[email-masked]>wrote:

> Call and was subsequently sent back to the WG due to the concerns
> raised about routing and potentially creating a parallel address registry
> outside of the RIRs.
>

Which it's still doing, right? The block-mgmnt draft is all about creating
a parallel address registry.

---

From: Brian Haberman <[email-masked]>
Date: Wed, 23 Oct 2013 12:12:18 -0400

Hi Gert,

> mixed LISP-talks-to-non-LISP model.

There is more to this than just the LISP-talking-to-non-LISP model.  The
goal is essentially to avoid a mapping lookup by having a globally
assigned blocks for EIDs.  It is an implementation optimization that
allows a LISP router to determine that a particular IPv6 address is (or
is not) reachable via LISP.

Regards,
Brian

---

From: Gert Doering <[email-masked]>
Date: Wed, 23 Oct 2013 18:14:30 +0200

Hi,

> is not) reachable via LISP.

Yeah, but having a set-aside block for LISP is actually something I could
live with.  The "it will leak to routing, create 'interesting' connectivity
issues to non-LISP and, and will fully confuse people on where to get
their IPv6 addresses from" is more what I'm worried about...

Gert Doering
        -- NetMaster

---

From: Brian Haberman <[email-masked]>
Date: Wed, 23 Oct 2013 12:14:55 -0400

Lorenzo,

> a parallel address registry.

Yes.  The creation of the block-mgmnt draft was driven by the feedback
received during the IETF Last Call that it was unclear how they would
manage an allocation.

Regards,
Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 24 Oct 2013 08:27:38 +1300

> about routing and potentially creating a parallel address registry

I think there is one difference from the 6to4 case - well, two actually.

1. A lot of operators learnt the hard way that failing to coordinate
6to4 prefix routing between operators caused very substantial problems.
(And, btw, the 6to4 RFC said that such coordination was needed.)

2. LISP has grown out of the routing community, so the need for
operational coordination is presumably understood in that community.

Nevertheless, the risk of a failure of coordination seems high.
But then, it seemed high for BGP4 itself in 1994.

   Brian

---

From: John Curran <[email-masked]>
Date: Thu, 24 Oct 2013 03:39:24 +0800

On Oct 23, 2013, at 11:36 PM, Brian Haberman <[email-masked]> wrote:
> about routing and potentially creating a parallel address registry

Minor nit in the above: I believe that drafts were sent back to the WG
_primarily_ due to lack of detail about the "experimental" nature of the 
proposed allocation, which made further consideration about the potential
implications rather difficult.  The authors have done significant edits 
as a result, and hence it's probably a good idea for everyone to reread
the drafts and come to their own conclusion.  (This is my main reason for 
bringing the matter to the attention to this list - I am not asserting 
that these are wonderful drafts or that we have a problem, only that full 
consideration should involve a slightly larger circle of folks...  :-)

Thanks!
/John

---

From: "cb.list6" <[email-masked]>
Date: Wed, 23 Oct 2013 13:00:59 -0700

> operational coordination is presumably understood in that community.

Maybe i am wrong, but i have an idea where LISP has grown out of, and
it is not the networks operators that would have to coordinate this to
work.

CB

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 24 Oct 2013 15:55:17 +1300

> it is not the networks operators that would have to coordinate this to

Agreed, routing community != network operators

I phrased it quite carefully.

   Brian

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 25 Oct 2013 10:02:35 -0400

Arguably, LISP creates a separate (overlayed) connectivity infrastructure.
It should not come as a great surprise that such an infrastructure uses 
(one way or another) an effectively separate address registry for its 
separate operation.

Having said that, leaks and how they relate to the allocation is one of 
the questions I asked the WG to clarify about this document.  It is 
currently unclear on the point, and that is not going to work for any of us.

Yours,
Joel

On 10/23/13 12:11 PM, Lorenzo Colitti wrote:
> <[email-masked] <mailto:[email-masked]>> wrote:
>
> Which it's still doing, right? The block-mgmnt draft is all about
> creating a parallel address registry.
>
>