Subject: [v6ops] Possibility of Multicast support through GRE tunnel?

From: sajjad akbar <[email-masked]>
Date: Wed, 23 Oct 2013 02:01:21 -0700 (PDT)

Dear fellows 

We need to implement multicast for hybrid network (IPv6-IPv4) in our testbed. No automatic tunneling mechanism is supporting multicast. 
can GRE tunnel support multicast streaming in a hybrid network (IPv6-IPv4)? 

Regards
Sajjad

---

From: Jeroen Massar <[email-masked]>
Date: Wed, 23 Oct 2013 11:24:17 +0200

On 2013-10-23 11:01, sajjad akbar wrote:
> 
> 
> Dear fellows 
> 
> 
> We need to implement multicast for hybrid network (IPv6-IPv4) in our
> testbed. No automatic tunneling mechanism is supporting multicast. 

As per: http://www.sixxs.net/faq/connectivity/?faq=comparison

Yes, GRE can do it, but as listed there many others do too.

The trick is that at either end of the tunnel you will have to run a MLD
proxy or a real multicast router for things to work.
(ecmh amongst many others can achieve this)

You state you have a 'hybrid network', why is that network not native?

Greets,
 Jeroen

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 23 Oct 2013 15:20:00 +0000

RFC2529 is an automatic tunneling mechanism that specifies a multicast
mapping from the IPv6 multicast space to the IPv4 space. VET is a more
recent automatic tunneling mechanism that picks up the RFC2529 mapping.

Thanks - Fred
[email-masked] 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Jeroen Massar
> Sent: Wednesday, October 23, 2013 2:24 AM
> To: sajjad akbar; [email-masked]
> Subject: Re: [v6ops] Possibility of Multicast support through GRE
> tunnel?
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops