Subject: [v6ops] Current state of v6ops drafts, updated

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 23 Oct 2013 06:44:09 +0000

I'm pulling an agenda together for IETF 88. My sources include the internet drafts directory and http://datatracker.ietf.org/wg/v6ops/, plus my mail store. I am interested in your viewpoints on this. The last paragraph of this note contains a question I'd appreciate answers to, private to [email-masked] or to the list.

One relevant point - Chris Palmer of Microsoft wants to talk about the evolution of the XBOX. When Dave Thaler asked me to speak about the evolution (devolution?) of Teredo, I put him on the agenda on the premise that this was an ongoing topic in the WG and of interest to the operators. In the case of the XBOX, that's not so obvious to me. So, please, if you're interested in such a talk, please advise, copying at least John, Chris, and myself if not the working group.

Draft status:

RFC Ed Queue:
  Oct 30  draft-ietf-v6ops-6204bis
  Nov 14  draft-ietf-v6ops-ra-guard-implementation
  Mar 18  draft-ietf-v6ops-ipv6-multihoming-without-ipv6nat
  Sep 15  draft-ietf-v6ops-rfc3316bis

Exiting WGLC; on its way to IESG:
   Oct  7  draft-ietf-v6ops-64share
   Oct 16  draft-ietf-v6ops-enterprise-incremental-ipv6

Working Group Document updated since IETF:
   Aug 14  draft-ietf-v6ops-dc-ipv6
   Aug 15  draft-ietf-v6ops-monitor-ds-ipv6
   Sep 11  draft-ietf-v6ops-mobile-device-profile
   Oct 14  draft-ietf-v6ops-nat64-experience
   Oct 21  draft-ietf-v6ops-ula-usage-recommendations
   Oct 21  draft-ietf-v6ops-balanced-ipv6-security

Individual Submission to v6ops posted/updated since IETF:
   Jul 30  draft-smith-v6ops-ce-dhcpv6-transparency
   Oct  4  draft-elkins-v6ops-ipv6-end-to-end-rt-needed
   Oct  4  draft-elkins-v6ops-ipv6-packet-sequence-needed
   Oct  4  draft-elkins-v6ops-ipv6-pdm-recommended-usage
   Oct 11  draft-byrne-v6ops-clatip
   Oct 18  draft-ma-v6ops-router-test
   Oct 21  draft-liu-bonica-v6ops-dhcpv6-slaac-problem
   Oct 21  draft-yang-v6ops-ipv6tran-select
   Oct 21  draft-sun-v6ops-openv6-address-pool-management
   Oct 21  draft-chen-v6ops-ipv6-roaming-analysis
   Oct 21  draft-moreiras-v6ops-rfc3849bis
   Oct 21  draft-petrescu-relay-route-pd-problem
   Oct 22  draft-rafiee-v6ops-iid-lifetime

My guess at an IETF 88 agenda given current data:
   Aug 14  draft-ietf-v6ops-dc-ipv6			(get discussion going)
   Aug 15  draft-ietf-v6ops-monitor-ds-ipv6		(get discussion going)
   Sep 11  draft-ietf-v6ops-mobile-device-profile	(discussion of changes resulting from IETF LC)
   Oct 14  draft-ietf-v6ops-nat64-experience		(do we have rough consensus?)
   Oct 21  draft-ietf-v6ops-ula-usage-recommendations	(get discussion going)
   Oct 21  draft-ietf-v6ops-balanced-ipv6-security	(get discussion going)
           X BOX evolution?
           Some subset of the individual submissions

In 4.5 hours, we probably have time for discussion of 9-13 drafts - my preference being closer to 9 (30 minutes/draft) than 13 (20 minutes/draft). That suggests that we could, if we chose, have the X Box discussion, and/or have time for discussion of 2-7 of the individual submissions.

There was some on-list discussion of draft-smith-v6ops-ce-dhcpv6-transparency in August, and I think I caught a vote of confidence for draft-liu-bonica-v6ops-dhcpv6-slaac-problem. I personally find draft-rafiee-v6ops-iid-lifetime interesting architecturally.

Wes George tells me that draft-yang-v6ops-ipv6tran-select has some interaction with DHC and Sunset4. I'm looking for him and the DHC chairs to tell me what to do with that - the draft may be appropriate for v6ops discussion, and may be better in one of those other working groups.

Frankly, with the draft cutoff so close to the date I need to post an agenda, it is difficult for me to follow our usual practice of monitoring mailing list discussion to vet WG interest in drafts. Therefore, I'm going to pose this question directly. I presume that every author wants to discuss their draft; some have asked for time. Would folks please advise the chairs which among the individual submissions and the X Box discussion they think merit discussion in v6ops at IETF 88?

---

From: joel jaeggli <[email-masked]>
Date: Tue, 22 Oct 2013 23:55:19 -0700

> One relevant point - Chris Palmer of Microsoft wants to talk about the evolution of the XBOX. When Dave Thaler asked me to speak about the evolution (devolution?) of Teredo, I put him on the agenda…

If it's a talk about a large scale deployment of ipv6 hosts IEPG (sunday) might be interested. my first reaction is what's the punchline for v6ops?