Subject: [v6ops] IETF 92 heads Up

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 4 Feb 2015 00:26:19 +0000

If I had to schedule the meeting today, this is what I would have to work with:

IESG:

    Oct 19  draft-ietf-v6ops-ipv6-roaming-analysis
    Jan 28  draft-ietf-v6ops-6to4-to-historic

WGLC; on its way to IESG:
    Feb  1  draft-ietf-v6ops-mobile-device-profile
    Jan 20  draft-ietf-v6ops-cidr-prefix

Working Group Document updated since IETF:

    Dec 18  draft-ietf-v6ops-siit-dc
    Jan 27  draft-ietf-v6ops-siit-dc-2xlat

Individual Submission updated since IETF:

    Dec 31  draft-sun-v6ops-xlat-multi
    Jan  8  draft-anderson-v6ops-siit-eam

Working Group Document NOT updated since IETF:

    Sep 18  draft-ietf-v6ops-design-choices
    Oct 27  draft-ietf-v6ops-dhcpv6-slaac-problem
    Oct 27  draft-ietf-v6ops-ula-usage-recommendations

Individual Submission NOT updated since IETF:

    Aug 24  draft-v6ops-pmtud-ecmp-problem
    Sep 10  draft-gont-v6ops-ipv6-ehs-in-real-world
    Sep 18  draft-elkins-v6ops-multicast-virtual-nodes
    Sep 18  draft-wang-v6ops-xlat-prefix-discovery
    Sep 25  draft-ybai-v6ops-ipv6-for-openstack
    Oct 11  draft-liu-v6ops-running-multiple-prefixes
    Oct 27  draft-chen-v6ops-nfv-ipv6
    Oct 27  draft-liu-v6ops-dhcpv6-slaac-guidance
    Oct 27  draft-osamu-v6ops-ipv4-literal-in-url
    Oct 27  draft-vyncke-v6ops-happy-eyeballs-cookie

more data at http://datatracker.ietf.org/doc/search/?sort=status&activedrafts=on&name=v6ops

Draft cutoff is 2015-03-09, and our preliminary agenda is due the same day. As usual, we are looking for discussion of posted drafts as an argument for face time, and under deadline pressure that can be difficult. If people want to file updates or new drafts, now would be an excellent time to do so.

---

From: Erik Kline <[email-masked]>
Date: Wed, 4 Feb 2015 12:12:02 +0900

>     Feb  1  draft-ietf-v6ops-mobile-device-profile

Are you implying that this would be on the agenda for discussion in
Dallas, or is it past that point now and its being past discussion is
what would appear on a slide?  :)

>     Aug 24  draft-v6ops-pmtud-ecmp-problem

I've seen this draft be usefully referred to a couple of times in the
last few months.  +1 to keeping it afloat, if not moving forward for
some reason (cc'ing Joel explicitly).

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 4 Feb 2015 03:48:03 +0000

> On Feb 3, 2015, at 7:12 PM, Erik Kline <[email-masked]> wrote:
> 

If we’re still talking about it, we should finalize it there. We do need to decide what its status is.

> some reason (cc'ing Joel explicitly).

Up to Joel. If folks tell us it should be a working group draft, it can be resubmitted as draft-ietf-v6ops-pmtud-ecmp-problem, following the naming guideline that IETF tools depend on. Or whatever.

---

From: Lorenzo Colitti <[email-masked]>
Date: Wed, 4 Feb 2015 13:04:37 +0900

On Wed, Feb 4, 2015 at 12:48 PM, Fred Baker (fred) <[email-masked]> wrote:

> Up to Joel. If folks tell us it should be a working group draft, it can be
> resubmitted as draft-ietf-v6ops-pmtud-ecmp-problem, following the naming
> guideline that IETF tools depend on. Or whatever.
>

I though we had an adoption call and there was consensus to adopt. In which
case I suppose we just need Joel to post an update. Do I remember wrong?

---

From: joel jaeggli <[email-masked]>
Date: Wed, 04 Feb 2015 10:12:08 -0600

On 2/3/15 9:48 PM, Fred Baker (fred) wrote:
>>> WGLC; on its way to IESG: Feb  1
>>> draft-ietf-v6ops-mobile-device-profile
>> 
>> Are you implying that this would be on the agenda for discussion
>> in Dallas, or is it past that point now and its being past
>> discussion is what would appear on a slide?  :)
> 
>> I've seen this draft be usefully referred to a couple of times in
>> the last few months.  +1 to keeping it afloat, if not moving
>> forward for some reason (cc'ing Joel explicitly).
> 
> Up to Joel. If folks tell us it should be a working group draft, it
> can be resubmitted as draft-ietf-v6ops-pmtud-ecmp-problem, following
> the naming guideline that IETF tools depend on. Or whatever.

I am happy to undertake a revision, or encourage my co-authors to do so.

I throw myself at the mercy of the chairs with respect to the title.

joel

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Thu, 5 Feb 2015 19:28:54 +0000

> On Feb 4, 2015, at 8:12 AM, joel jaeggli <[email-masked]> wrote:

That would be fine.

> I throw myself at the mercy of the chairs with respect to the title.

I’m working from http://www.ietf.org/id-info/guidelines.html#naming and the fact that IETF tools depend on this.

Drafts can be named one of three ways:
    draft-ietf-<wg>-*-nn.txt       A working group draft
    draft-<author>-<wg>-*-nn.txt   An individual submission to a working group
    draft-<author>-*-nn.txt        An individual submission not targeted to a specific working group

The guidelines have a number of special "authors", such as -iab-, -iaoc-, and so on.

When you file a draft as draft-ietf-v6ops-*-00.txt, the working group chairs get a question from the secretariat: "is this an authorized working group draft?" If we say "yes", it's allowed to be posted, and if we say "no" or don't say anything, it doesn't. Once the -00 is posted, it can be updated at will. The status also show up in the data tracker: if you look up https://datatracker.ietf.org/doc/search/?name=v6ops&activedrafts=on&sort=, drafts named draft-ietf-v6ops-* are listed as "WG Documents", and other documents aren't. IETF tools depend on that naming - WG status is not a separate attribute (although I would prefer that it was), it is carried in the name of the draft.

My personal tools are a little more forgiving; if I find the character string "v6ops" anywhere in the name, I consider it related to v6ops somehow. In part, that is because we sometimes get documents with names like draft-tom-dick-harry-v6ops-*, that completely screw the naming guidelines. We also sometimes get documents that are individual submissions without respect to a working group that are shopped to several working groups. I'm perfectly willing to see people drop a note to the list saying "I filed draft-myname-stuff-i-am-worried-about, and wonder what the operational folks think", or for that matter drafts from other working groups, and if folks ask, we may fit those into an agenda somewhere. But if it has the word "v6ops" in the name, I electronic ear-equivalents perk up, my bot sends a note to the working group and a separate note to the authors, and it automatically shows up in my agenda analysis.

But really. We decided to accept this as a working group draft. I'm looking for a document with a name like draft-ietf-v6ops-pmtud-ecmp-problem.