Subject: [v6ops] Discussion: IPv4 as a Service

From: Fred Baker <[email-masked]>
Date: Wed, 25 Mar 2015 18:48:51 -0500

Lee and I opened a discussion in the v6ops meeting today on a topic that I believe that the IETF, in cooperation with the *NOGs, needs to address. My slide is at https://www.ietf.org/proceedings/92/slides/slides-92-v6ops-9.pptx. Sunset4 and softwire chairs, please feel free to forward this to your mailing lists.

In short, we are starting to see the deployment of IPv6-only networks. In most cases, these are existing IPv4 networks that have become dual stack, and are somewhere in the process of shutting IPv4 down. These include Facebook, which (regardless of whether you view it as an enterprise or a content network) has been public about the fact, several mobile networks that treat IPv6-capable telephones as an IPv6-only network and use 464xlat as an operational methodology dealing with that, and some research networks, notably CERNET2, which has been running IPv6-only for ten years now. We also see green-field networks, such as Reliance JIO Infocomm Ltd; Suprita Sah presented on that topic today.

I am of the opinion, and there seemed to be agreement in the room, that the Internet community would be well served if we collected deployment experience with these technologies, and the considered advice of deploying operators. We have tried to guide the deployment of IPv6, and gathered experience and mitigations for that. Now, as IPv4 begins to fade, we need to take a leadership role in that.

I have opened a document on Google Docs, and given folks the ability to view it. That is at https://docs.google.com/document/d/1ifDEkoypW43lgZJqh2paUDcMAwoUWdz6psyEb456c3A. I have included an initial list of relevant technologies, and an initial list of the questions that we would want discussed in experience documents. I guarantee that there is an important question not asked, and while I hope otherwise, there may be some technology I have overlooked. So I invite discussion to flesh out that initial phase.

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Thu, 26 Mar 2015 20:59:57 +0000

It came to my attention last night that the link I sent yesterday is read-only. This should allow you to comment (e.g., you can change the document, but it shows up under change control; Lee, Joel, and I are editors on it).

https://docs.google.com/document/d/1ifDEkoypW43lgZJqh2paUDcMAwoUWdz6psyEb456c3A/edit?usp=sharing

I’d appreciate any comments you have on this being edited into the file or in a reply to the list or to the chairs.

> On Mar 25, 2015, at 6:48 PM, Fred Baker <[email-masked]> wrote:
>

---

From: "Mukom Akong T." <[email-masked]>
Date: Sat, 28 Mar 2015 10:15:38 -0500

Hi Fred,

> https://docs.google.com/document/d/1ifDEkoypW43lgZJqh2paUDcMAwoUWdz6psyEb456c3A/edit?usp=sharing

I added a few suggestions to the documents. Other things I didn't add but
wondered whether they were appropriate for such a document were:

- Business justification (goal): what business problem were you trying to
solve? (the boiler-plate answer might be 'deal with v4 exhaustion' but
perhaps the specific triggers might be useful?)

- Post mortem: did the deployment address the business concern you set out
to solve?

-- 

Mukom Akong T.

http://about.me/perfexcellence |  twitter: @perfexcellent
------------------------------------------------------------------------------------------------------------------------------------------
“When you work, you are the FLUTE through whose lungs the whispering of the
hours turns to MUSIC" - Kahlil Gibran
-------------------------------------------------------------------------------------------------------------------------------------------

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Mon, 30 Mar 2015 19:54:16 +0000

Over the weekend, we crowd-sourced a number of pretty good questions. I took the liberty, this morning, of reorganizing the text a bit. The "list of technologies" and "list of questions" remain, but I have added "possible (classes of) documents to be developed" and a first cut at a proposed outline, with the questions from above pulled in to make it clear what I might hope the section might comment on.

Collecting comments and thoughts. I guarantee there is something we haven’t thought of (as I was reorganizing, several points popped out, and I’m sure I’m not that smart).

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 1 Apr 2015 01:11:32 +0000

Since they might be among the early folks I would ask to write something, I asked Xing Li, Akira, and Suprita to comment specifically on the outline: “if you were to write such a document, how would this outline work for you”.

Suprita replied as follows. I have changed the proposed outline in a manner similar to her suggestion.

> On Mar 31, 2015, at 2:41 PM, suprita <[email-masked]> wrote:
> 
> I tried to first re-write the "Outlined hierarchy" used  and then make any modification to it, as per ease of answering them.
> I did not have to do many changes to the one already used by you, with minor adjustments in naming convention and placements..
> 
> Experience Gathering : Heading
> 
> General/Overview
> 	Major Motivation(s)
> 	v4 as-a-service Requirements
> 		Exactly which v4 Service Types
> Architecture and Methodology
> 	Major Design Considerations
> 	Regulatory Considerations
> 	Security Considerations
> 	Operational Considerations
> 	End-User Experience Considerations
> Observations and Experiences
> 	Effects on End-User
> 	Effects on Internal Staff
> 		Planning & Design
> 		Implementation
> 		Operations
> 	Effects on Business
> Summary: Post-mortem Report
> 	Deviations from RFC's/Drafts/Standards
> 	Worked Well
> 	Did not work well
> 
> 
> On Wed, Apr 1, 2015 at 1:56 AM, suprita <[email-masked] <mailto:[email-masked]>> wrote:
> Dear Fred,
> 
> I am yet to apply newly learnt skill from you of applying filters for the directly addressed e-mails :).
> I will sure go through the doc in detail and comment.
> 
> Thank you,
> Suprita
> 
> On Tue, Mar 31, 2015 at 2:04 AM, Fred Baker (fred) <[email-masked] <mailto:[email-masked]>> wrote:
> 
> > On Mar 30, 2015, at 12:50 PM, Fred Baker <[email-masked] <mailto:[email-masked]>> wrote:
> >
> >> https://docs.google.com/document/d/1ifDEkoypW43lgZJqh2paUDcMAwoUWdz6psyEb456c3A/edit?usp=sharing <https://docs.google.com/document/d/1ifDEkoypW43lgZJqh2paUDcMAwoUWdz6psyEb456c3A/edit?usp=sharing>
> 
> The first thing I am wondering about is whether the proposed outline “works”. Would you be willing to spend an hour thinking through the outline and wondering how you would respond to it for Reliance? What questions are missing? Would another organization work better?
> 
>