Subject: [v6ops] New Version Notification for draft-jjmb-v6ops-unique-ipv6-prefix-per-host-00.txt

From: "Brzozowski, John" <[email-masked]>
Date: Mon, 19 Oct 2015 23:45:06 +0000

v6ops,

Over the past several years there has been some planning for IPv6 support
for a large scale Wi-Fi deployment.  Turns after sharing some of these
details with many of your over the past several IETF meetings there is
interest beyond Wi-Fi for this work.  The I-D has finally been written so
please send us some feedback on the list.  Assuming we get adequate
discussion on the list we will request a slot in Yokohama to discuss this
I-D.

John & Gunter

-----Original Message-----
From: "[email-masked]" <[email-masked]>
Date: Monday, October 19, 2015 at 15:50
To: Gunter Van de Velde <[email-masked]>, John
Jason Brzozowski <[email-masked]>, Gunter Van de Velde
<[email-masked]>
Subject: New Version Notification for
draft-jjmb-v6ops-unique-ipv6-prefix-per-host-00.txt

>
>A new version of I-D, draft-jjmb-v6ops-unique-ipv6-prefix-per-host-00.txt
>has been successfully submitted by John Jason Brzozowski and posted to the
>IETF repository.
>
>Name:		draft-jjmb-v6ops-unique-ipv6-prefix-per-host
>Revision:	00
>Title:		Unique IPv6 Prefix Per Host
>Document date:	2015-10-19
>Group:		Individual Submission
>Pages:		14
>URL:            
>https://www.ietf.org/internet-drafts/draft-jjmb-v6ops-unique-ipv6-prefix-p
>er-host-00.txt
>Status:         
>https://datatracker.ietf.org/doc/draft-jjmb-v6ops-unique-ipv6-prefix-per-h
>ost/
>Htmlized:       
>https://tools.ietf.org/html/draft-jjmb-v6ops-unique-ipv6-prefix-per-host-0
>0
>
>
>Abstract:
>   In some IPv6 environments the need has arisen for hosts to be able to
>   utilise a unique IPv6 prefix even though the link or media may be
>   shared.  Typically hosts (subscribers) on a shared network, like Wi-
>   Fi or Ethernet, will acquire unique IPv6 addresses from a common IPv6
>   prefix that is allocated or assigned for use on a specific link.
>   Benefits of a unique IPv6 prefix compared to a unique IPv6 address
>   from the service provider are going from enhanced subscriber
>   management to improved isolation between subscribers.
>
>   In most deployments today IPv6 address assignment from a single IPv6
>   prefix on a shared network is done by either using IPv6 stateless
>   address auto-configuration (SLAAC) and/or stateful DHCPv6.  While
>   this is still viable and operates as designed there are some large
>   scale environments where this concept introduces significant
>   performance challenges and implications, specifically related to IPv6
>   router and neighbor discovery.  This document outlines an approach
>   utilising existing IPv6 protocols to allow hosts to be assigned a
>   unique IPv6 prefix (instead of a unique IPv6 address from a shared
>   IPv6 prefix).
>
>                  
>        
>
>
>Please note that it may take a couple of minutes from the time of
>submission
>until the htmlized version and diff are available at tools.ietf.org.
>
>The IETF Secretariat
>
>

---

From: Fernando Gont <[email-masked]>
Date: Sun, 25 Oct 2015 11:08:15 +0900

Hi, John (& Gunter),

> discussion on the list we will request a slot in Yokohama to discuss this

I went through you document, but I'd say that it wasn't that clear
what's the problem statement behind this document.

It would seem to be "we need DHCPv6-PD, but it is not widely supported".
Is that the problem statement? Or am I missing something?

Thanks!

Best regards,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: "Brzozowski, John" <[email-masked]>
Date: Mon, 26 Oct 2015 21:22:22 +0000

Fernando,

There is not a “problem” per se, most of the document orbits around a best
practice for how IPv6 can and is being deployed for a large scale Wi-Fi
service.  Based on experience deploying IPv6 elsewhere we have seen
challenges in areas pertaining to router and neighbor discovery and shared
media like Wi-Fi.  Since not enabling IPv6 is not an option an approach
was developed to ensure the same can be enabled without impacting the
quality and performance of the service.  The I-D simply documents the
approach that will be used to along with the corresponding protocols bits.

DHCPv6 PD support is referenced as future work.  The I-D does not comment
on whether or not support for the same is pervasive.

John
+1-484-962-0060

-----Original Message-----
From: Fernando Gont <[email-masked]>
Date: Sunday, October 25, 2015 at 02:08
To: John Jason Brzozowski <[email-masked]>, v6ops
<[email-masked]>
Cc: "[email-masked]"
<[email-masked]>
Subject: Re: [v6ops] New Version Notification for
draft-jjmb-v6ops-unique-ipv6-prefix-per-host-00.txt

---

From: Fernando Gont <[email-masked]>
Date: Tue, 27 Oct 2015 11:27:09 +0900

Hi, John,

On 10/27/2015 06:22 AM, Brzozowski, John wrote:
> media like Wi-Fi.

This should be stated more clearly.

For example, if this is "guidelines on how to do X", it should be
clearly stated.. Besides, the challenges you mentioned should be spelled
out. -- are they issues regarding multicast use in ND? Something else?

> Since not enabling IPv6 is not an option an approach

That's certainly fine. My point is that this was not clear to me when
reading the document.

Thanks!

Cheers,

---

From: "Brzozowski, John" <[email-masked]>
Date: Tue, 27 Oct 2015 23:36:43 +0000

Fernando,

Thanks for the feedback.  I thought we did an OK job framing the scope and
motivation of the document.  Given your feedback, Gunter and I will take
another pass and see if we can further clarify.

John
+1-484-962-0060

-----Original Message-----
From: Fernando Gont <[email-masked]>
Date: Tuesday, October 27, 2015 at 02:27
To: John Jason Brzozowski <[email-masked]>, v6ops
<[email-masked]>