Subject: [v6ops] I-D Action: draft-ietf-v6ops-reducing-ra-energy-consumption-02.txt

From: [email-masked]
Date: Thu, 01 Oct 2015 08:09:47 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the IPv6 Operations Working Group of the IETF.

        Title           : Reducing energy consumption of Router Advertisements
        Authors         : Andrew Yourtchenko
                          Lorenzo Colitti
	Filename        : draft-ietf-v6ops-reducing-ra-energy-consumption-02.txt
	Pages           : 6
	Date            : 2015-10-01

Abstract:
   Frequent Router Advertisement messages can severely impact host power
   consumption.  This document recommends operational practices to avoid
   such impact.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-v6ops-reducing-ra-energy-consumption/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-v6ops-reducing-ra-energy-consumption-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-v6ops-reducing-ra-energy-consumption-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Lorenzo Colitti <[email-masked]>
Date: Fri, 2 Oct 2015 00:13:30 +0900

On Fri, Oct 2, 2015 at 12:09 AM, <[email-masked]> wrote:

>         Filename        :
> draft-ietf-v6ops-reducing-ra-energy-consumption-02.txt
>         Pages           : 6
>         Date            : 2015-10-01
>

The changes from -02 are as follows:

   1. Added a section on RA intervals and lifetimes.
   2. Added text on RA guard in the security considerations section.

Both are in response to previous WG comments.

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Thu, 1 Oct 2015 18:39:10 +0000

Folks - I'd appreciate it if you would look at the update and comment quickly. The big new text is in section 4 and the security considerations. https://tools.ietf.org/rfcdiff?url2=draft-ietf-v6ops-reducing-ra-energy-consumption-02.txt <https://tools.ietf.org/rfcdiff?url2=draft-ietf-v6ops-reducing-ra-energy-consumption-02.txt>

My issue is that I moved too quickly. I looked at the list traffic and noted that it had come to a hiatus, and assumed that Lorenzo/Andrew had dealt with the open issues. This draft is intended to be the update that does that. However - I filed it with the IESG. If I need to snatch it back, say so now, please.

> On Oct 1, 2015, at 8:13 AM, Lorenzo Colitti <[email-masked]> wrote:
> 
> On Fri, Oct 2, 2015 at 12:09 AM, <[email-masked] <mailto:[email-masked]>> wrote:
> Added a section on RA intervals and lifetimes.
> Added text on RA guard in the security considerations section.
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: David Farmer <[email-masked]>
Date: Thu, 1 Oct 2015 15:48:21 -0500

This covers my technical issues.
 
However, as I noted with the last version for what is now 5.2 the the term "mobile devices" is used, whereas the rest of the document uses "battery-powered devices".  This is mostly editorial, but I think it would read better if consistent terminology were used throughout document.  I prefer the term "battery-powered devices", because it is more inclusive of the full range of devices that are impacted by this issue.  Today it mostly mobile devices, but this is likely to be important for the Internet of Things (IoT) as it becomes much more prevalent.

Thanks.

-- 
===============================================
David Farmer                          Email: [email-masked]
Office of Information Technology
University of Minnesota    
2218 University Ave SE         Phone: +1-612-626-0815
Minneapolis, MN 55414-3029   Cell: +1-612-812-9952
===============================================

> On Oct 1, 2015, at 13:39, Fred Baker (fred) <[email-masked]> wrote:
> 
> Folks - I'd appreciate it if you would look at the update and comment quickly. The big new text is in section 4 and the security considerations. https://tools.ietf.org/rfcdiff?url2=draft-ietf-v6ops-reducing-ra-energy-consumption-02.txt
> 

-- 
===============================================
David Farmer                          Email: [email-masked]
Office of Information Technology
University of Minnesota    
2218 University Ave SE         Phone: +1-612-626-0815
Minneapolis, MN 55414-3029   Cell: +1-612-812-9952
===============================================

---

From: Mark Smith <[email-masked]>
Date: Fri, 2 Oct 2015 09:24:25 +1000

Hi,

On 2 October 2015 at 04:39, Fred Baker (fred) <[email-masked]> wrote:
> Folks - I'd appreciate it if you would look at the update and comment
> quickly. The big new text is in section 4 and the security considerations.
> https://tools.ietf.org/rfcdiff?url2=draft-ietf-v6ops-reducing-ra-energy-consumption-02.txt
>

I'm generally ok with the next text.

I did find that the new Router Advertisement frequency section intro
read a bit as though it was a general and broad discussion of the
reasons to adjust RA timers, rather than one specific to RA interval
impacts on device power consumption.

For example, I've adjusted RA timers to reduce control plane resource
consumption on a broadband BNG/BRAS (e.g., 30K PPPoE sessions with the
default RA timers results in 50 unique RAs per second IIRC). I'd think
this reason would be out of scope for this draft.

So perhaps something like the following would make it clearer that
this section is only discussing battery power considerations when
changing RA intervals

"4. Router Advertisement frequency

There are a variety of reasons to adjust the frequency of periodic
RAs. This section discusses the power impacts for battery powered
devices when choosing an appropriate frequency for periodic RAs."

Regards,
Mark.

> My issue is that I moved too quickly. I looked at the list traffic and noted
> that it had come to a hiatus, and assumed that Lorenzo/Andrew had dealt with
> the open issues. This draft is intended to be the update that does that.
> However - I filed it with the IESG. If I need to snatch it back, say so now,
> please.
>

---

From: David Farmer <[email-masked]>
Date: Fri, 2 Oct 2015 00:57:18 -0500

> On Oct 1, 2015, at 15:48, David Farmer <[email-masked]> wrote:
> 

Reading through this again, I have a couple more editorial nits;

1. As note above "mobile devices" is used, but "battery-powered devices" and "battery-powered hosts" are also used. "Battery-powered hosts" seems to be the most commonly used, so I suggest s/mobile devices/battery-powered hosts/ and s/battery-powered devices/battery-powered hosts/

2. There is a reference to RFC6104 in the security considerations section, but no Informational Reference is detailed in section 9.

Thanks