Subject: [v6ops] IPv6-only draft

From: Fred Baker <[email-masked]>
Date: Tue, 16 Jul 2019 17:27:23 -0700

The author is asking for time on the agenda at IETF 105; I told him that if there was time at the end of the meeting, it could be part of "AOB". I don't see any discussion on the draft since November 2017.

FYI, draft-ietf-6man-ipv6only-flag is a different topic.

https://tools.ietf.org/html/draft-palet-v6ops-ipv6-only
https://mailarchive.ietf.org/arch/search/?qdr=a&q=%22draft-palet-v6ops-ipv6-only%22

Your comments appreciated.

--------------------------------------------------------------------------------
The fact that there is a highway to hell and a stairway to heaven is an interesting comment on projected traffic volume...

---

From: "Mudric, Dusan (Dusan)" <[email-masked]>
Date: Fri, 19 Jul 2019 19:05:18 +0000

"3.  Definition of IPv6-only

   Consequently, considering the context described in the section above,
   if we want to be precise and avoid confusing others, we can not use	
   the terminology "IPv6-only" in a generic way, and we need to define
   what part of the network we are referring to.

   From that perspective, we define the "IPv6-only" status in a given
   part(s) of a network, depending on if there is actual native
   forwarding of IPv4, so IPv4 is not configured neither managed."

The document defines IPv6-only not only for the network parts but also for a host/router.

"7.  IPv6-only WAN/access

   IPv6-only WAN or access can be used only if the WAN or access network
   isn't actually natively forwarding IPv4."

Should use affirmative kind of definitions for IPv6-only, not only here but also in other sections. Instead of "isn't actually natively forwarding IPv4" should define what it IS forwarding, like "is natively forwarding IPv6".

"10.  Transitional IPv6 host/router

   Transitional IPv6 host/router is a dual-stack host/router with
   IPv6-only WAN where IPv4 service support is provided by means of
   transition mechanism, IPv4aaS (IPv4-as-a-service)."

Dusan

Why is it important to mention WAN address family? Why WAN must be IPv6-only?

> -----Original Message-----
> From: v6ops <[email-masked]> On Behalf Of Fred Baker
> Sent: Tuesday, July 16, 2019 8:27 PM
> To: IPv6 Operations <[email-masked]>
> Subject: [v6ops] IPv6-only draft
> 
> The author is asking for time on the agenda at IETF 105; I told him that if there
> was time at the end of the meeting, it could be part of "AOB". I don't see any
> discussion on the draft since November 2017.
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__tools.ietf.org_html_draft-2Dpalet-2Dv6ops-2Dipv6-
> 2Donly&d=DwICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrh
> IoUWB8YLZU23029sMQGQ2kY&m=1nAt78nefTz-p_aiWCrcg5YAes1Z-
> E1BJms0WuHLM2M&s=UNkIjLs2G5OnvxDyoSyysQPWYTYrk9wTfadmnnr57kg
> &e=
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__mailarchive.ietf.org_arch_search_-3Fqdr-3Da-26q-3D-2522draft-
> 2Dpalet-2Dv6ops-2Dipv6-2Donly-
> 2522&d=DwICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIo
> UWB8YLZU23029sMQGQ2kY&m=1nAt78nefTz-p_aiWCrcg5YAes1Z-
> E1BJms0WuHLM2M&s=E1m_qHn7RsRktmhF07Nf9eanzgGmtNP7lQ29Kyr5su
> E&e=
> 
> The fact that there is a highway to hell and a stairway to heaven is an
> interesting comment on projected traffic volume...
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_v6ops&d=DwICAg&c=BFpWQw8bsuKpl
> 1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=1nAt
> 78nefTz-p_aiWCrcg5YAes1Z-E1BJms0WuHLM2M&s=595l-
> RsCyu_0mPOHtZ0uecureSaBYL3jaFjC9O1xAwY&e=

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sat, 20 Jul 2019 16:54:03 +0200

Hi Dusan,

El 20/7/19 7:35, "v6ops en nombre de Mudric, Dusan (Dusan)" <[email-masked] en nombre de [email-masked]> escribió:

    

-> I see this document as to have view "end-to-end". So, from host A (source) to host B (destination), is it IPv6-only? Under that perspective, the hosts, routers, involve in that end-to-end communication, are also part of the network. If this is not clear, I could expand the text on this section to clarify that. Do you have any suggested wording?
    
    "7.  IPv6-only WAN/access

-> I think it is clearer with the negative form, unless this is incorrect in English? I'm not native speaker. If I use affirmative it gets more complex:
"isn't actually natively forwarding IPv4"
vs
"is actually forwarding natively IPv6 and not natively IPv4"

-> not sure what is the input here?
    
    Dusan

-> Because the full reason or "starting-point" of the document is the IPv6-only terminology clarification.

    _______________________________________________
    v6ops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/v6ops

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: "Mudric, Dusan (Dusan)" <[email-masked]>
Date: Mon, 22 Jul 2019 13:45:07 +0000

> From: JORDI PALET MARTINEZ <[email-masked]>
> Sent: Saturday, July 20, 2019 10:54 AM
> To: Mudric, Dusan (Dusan) <[email-masked]>; IPv6 Operations
> <[email-masked]>
> Subject: Re: [v6ops] IPv6-only draft
> 
> Hi Dusan,
> 
> 
> El 20/7/19 7:35, "v6ops en nombre de Mudric, Dusan (Dusan)" <v6ops-
> [email-masked] en nombre de [email-masked]> escribió:
> 
> 
> 
> -> I see this document as to have view "end-to-end". So, from host A
> (source) to host B (destination), is it IPv6-only? Under that perspective, the
> hosts, routers, involve in that end-to-end communication, are also part of
> the network. If this is not clear, I could expand the text on this section to
> clarify that. Do you have any suggested wording?
[Dusan] Please revise this suggestion:
        From that perspective, we define the "IPv6-only" service as a usage of 
        IPv6 address family throughout the end-to-end paths between the applications.
        Both  the applications and the underlined network transport use only IPv6 infrastructure.

>     Should use affirmative kind of definitions for IPv6-only, not only here but
> also in other sections. Instead of "isn't actually natively forwarding IPv4"
> should define what it IS forwarding, like "is natively forwarding IPv6".
> 
> -> I think it is clearer with the negative form, unless this is incorrect in
> English? I'm not native speaker. If I use affirmative it gets more complex:
[Dusan] Saying what it is not, opens a brother space for what it is. If it is not IPv4, it might be IPv6 or IPv10.

> only terminology clarification.
[Dusan] Then there should be two definitions, one for hosts/routers and another for WAN. Hosts and routers can run applications that are not related to transport/forwarding. These applications should use IPv6-only address family and APIs that provide IPv6-only functionality. Routers should route IPv6-only packets.

> 3A__www.ietf.org_mailman_listinfo_v6ops&d=DwIFaQ&c=BFpWQw8bsuKpl
> 1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=nVi1
> kxCxFdlB1F2zpz7Bo6AOkAWuN4dXAGVdaQvc8dU&s=Ra0Bi_7Bb4Bl_HWen
> W1n1hXv-oPjwvj2phNsvoLVwB0&e=
> 
> 
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=http-
> 3A__www.theipv6company.com&d=DwIFaQ&c=BFpWQw8bsuKpl1SgiZH64Q
> &r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=nVi1kxCxFdlB1
> F2zpz7Bo6AOkAWuN4dXAGVdaQvc8dU&s=U7_rLtGQU3ODP6ZztvObrRvAiIS
> aqUJvwbzec5hmzho&e=
> The IPv6 Company
> 
> This electronic message contains information which may be privileged or
> confidential. The information is intended to be for the exclusive use of the
> individual(s) named above and further non-explicilty authorized disclosure,
> copying, distribution or use of the contents of this information, even if
> partially, including attached files, is strictly prohibited and will be considered a
> criminal offense. If you are not the intended recipient be aware that any
> disclosure, copying, distribution or use of the contents of this information,
> even if partially, including attached files, is strictly prohibited, will be
> considered a criminal offense, so you must reply to the original sender to
> inform about this communication and delete it.
> 
>