Subject: Re: [v6ops] Roman Danyliw's No Objection on draft-ietf-v6ops-nat64-deployment-07: (with COMMENT)

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 12 Jul 2019 11:30:54 +0200

Thanks a lot, done already in v08.

Regards,
Jordi
@jordipalet

El 12/7/19 3:37, "v6ops en nombre de Roman Danyliw" <[email-masked] en nombre de [email-masked]> escribió:

    Hi!
    
    > -----Original Message-----
    > From: Jordi Palet Martínez [mailto:[email-masked]]
    > Sent: Thursday, July 11, 2019 3:27 AM
    > To: [email-masked]; Jordi Palet Martínez
    > <jordi.palet=[email-masked]>; Roman Danyliw
    > <[email-masked]>; The IESG <[email-masked]>
    > Cc: [email-masked]; [email-masked]; v6ops-
    > [email-masked]
    > Subject: Re: Roman Danyliw's No Objection on draft-ietf-v6ops-nat64-
    > deployment-07: (with COMMENT)
    > 
    > Hi Med,
    > 
    > Thanks a lot! that's a very good "middle point" reference. It is only about US,
    > I will try to see if there is a similar one that shows also other regions.
    > 
    > Regards,
    > Jordi
    > @jordipalet
    > 
    > 
    > El 11/7/19 9:05, "[email-masked]"
    > <[email-masked]> escribió:
    > 
    >     Hi Jordi, all,
    > 
    >     One comment below.
    > 
    >     Cheers,
    >     Med
    > 
    >     > -----Message d'origine-----
    >     > De : v6ops [mailto:[email-masked]] De la part de Jordi Palet
    >     > Martínez
    >     > Envoyé : jeudi 11 juillet 2019 08:41
    >     > À : Roman Danyliw; The IESG
    >     > Cc : [email-masked]; [email-masked]; v6ops-
    >     > [email-masked]
    >     > Objet : Re: [v6ops] Roman Danyliw's No Objection on draft-ietf-v6ops-
    >     > nat64-deployment-07: (with COMMENT)
    >     >
    >     > Hi Roman,
    >     >
    >     > Thanks a lot for your inputs.
    >     >
    >     > See below, in-line.
    >     >
    >     > Regards,
    >     > Jordi
    >     > @jordipalet
    >     >
    >     >
    >     > El 11/7/19 2:44, "Roman Danyliw via Datatracker" <[email-masked]>
    >     > escribió:
    >     >
    >     >     Roman Danyliw has entered the following ballot position for
    >     >     draft-ietf-v6ops-nat64-deployment-07: No Objection
    >     >
    >     >     When responding, please keep the subject line intact and reply to all
    >     >     email addresses included in the To and CC lines. (Feel free to cut
    >     > this
    >     >     introductory paragraph, however.)
    >     >
    >     >
    >     >     Please refer to https://www.ietf.org/iesg/statement/discuss-
    >     > criteria.html
    >     >     for more information about IESG DISCUSS and COMMENT positions.
    >     >
    >     >
    >     >     The document, along with other ballot positions, can be found here:
    >     >     https://datatracker.ietf.org/doc/draft-ietf-v6ops-nat64-deployment/
    >     >
    >     >
    >     >
    >     >     ----------------------------------------------------------------------
    >     >     COMMENT:
    >     >     ----------------------------------------------------------------------
    >     >
    >     >     (1) Section 5.  Is there an informative reference that can be made
    >     > about the
    >     >     successful deployment on cellular networks?
    >     >
    >     > Do you mean citing specific operators? I can name several in almost
    > every
    >     > continent, but I'm not convinced this is correct in an IETF document ...
    >     >
    
    I'm flexible.  The text asserts this is used widely.  I was wondering if any informative reference could point to that.
    
    >     [Med] No need to be exhaustive here, I suggest to add one single pointer:
    > https://www.worldipv6launch.org/major-mobile-us-networks-pass-50-ipv6-
    > threshold/. Having an informative reference is helpful for this kind of
    > statements (because otherwise, this may be considered as speculative).
    >
    > 
    >     >     (2) Section 7.  Consider adding an explicit statement such as the
    >     > following
    >     >     after the intro sentence that “no new security considerations are
    >     > added”:
    >     >
    >     >     As noted in the relevant sections above, the NAT64 and DNS64
    >     > technologies can
    >     >     impact the efficacy or functionality of key security (i.e., DNSSEC and
    >     > VPNs)
    >     >     and privacy preserving (i.e., DNS-over-TLS and DNS-over-HTTP)
    >     > technologies.
    >     >
    >     > -> I will need to reword it. This is right in the reference to DNSSEC.
    >     > However VPNs and DNS privacy, the point is on the other way around
    > (those
    >     > technologies can avoid the DNS64 performing correctly, and thus, break
    >     > NAT64).
    
    Right.  I botched what-breaks-what so please do reword it.  
    
    >     >     (3) Editorial Nits
    >     >
    >     >     ** Section 1.  Editorial. s/today unrealistic/unrealistic today/
    >     >
    >     >     ** Section 5.  Typo.  s/learn he/learn the/
    >     >
    >     >     ** Section 5.  Editorial.  “Hundreds of millions of users” mentioned
    >     > twice.
    >     >
    >     >     OLD:
    >     >     NAT64/464XLAT has demonstrated to be a valid choice in several
    >     > scenarios
    >     >     (IPv6-IPv4 and IPv4-IPv6-IPv4), with hundreds of millions of users,
    >     > being the
    >     >     predominant mechanism in the majority of the cellular networks
    > (which
    >     > account
    >     >     for hundreds of millions of users).
    >     >
    >     >     NEW:
    >     >     NAT64/464XLAT has demonstrated to be a valid choice in several
    >     > scenarios
    >     >     (IPv6-IPv4 and IPv4-IPv6-IPv4) in cellular networks which account for
    >     > hundreds
    >     >     of millions of users.
    >     >
    >     > Noted and corrected all those nits in my internal version. I will wait a
    >     > couple of days before publishing it, in case there are any further inputs.
    
    Thanks for fixing these.
    
    Thanks,
    Roman
    
    >     >
    > 
    > 
    > 
    > 
    > **********************************************
    > IPv4 is over
    > Are you ready for the new Internet ?
    > http://www.theipv6company.com
    > The IPv6 Company
    > 
    > This electronic message contains information which may be privileged or
    > confidential. The information is intended to be for the exclusive use of the
    > individual(s) named above and further non-explicilty authorized disclosure,
    > copying, distribution or use of the contents of this information, even if
    > partially, including attached files, is strictly prohibited and will be
    > considered a criminal offense. If you are not the intended recipient be aware
    > that any disclosure, copying, distribution or use of the contents of this
    > information, even if partially, including attached files, is strictly prohibited,
    > will be considered a criminal offense, so you must reply to the original
    > sender to inform about this communication and delete it.
    > 
    > 
    
    _______________________________________________
    v6ops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/v6ops

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Roman Danyliw <[email-masked]>
Date: Sun, 21 Jul 2019 15:07:14 +0000

Hi!

Thanks for the updates in -08 to address  my comments.

Roman

> From: JORDI PALET MARTINEZ [mailto:[email-masked]]
> Sent: Friday, July 12, 2019 5:31 AM
> To: Roman Danyliw <[email-masked]>; Jordi Palet Martínez
> <[email-masked]>; [email-masked];
> Jordi Palet Martínez <jordi.palet=[email-masked]>;
> The IESG <[email-masked]>
> Subject: Re: [v6ops] Roman Danyliw's No Objection on draft-ietf-v6ops-
> El 12/7/19 3:37, "v6ops en nombre de Roman Danyliw" <v6ops-
> [email-masked] en nombre de [email-masked]> escribió:
> 
>     Hi!
> 
>     I'm flexible.  The text asserts this is used widely.  I was wondering if any
> informative reference could point to that.
>