Subject: [v6ops] IETF Working Group Agenda Analysis

From: Fred Baker <[email-masked]>
Date: Mon, 14 Oct 2019 15:04:13 -0700

Apologies for the HTML Email. Some folks complain about them. This is a file I put together daily showing the status of v6ops documents.This document describes the drafts associated with this group. It describes their current state as seen by the RFC Editor, IESG/AD, and the working or research group. For working group drafts and individual submissions, it also indicates whether the draft has been updated since the previous IETF meeting. Drafts that are new or have been updated are "current"; other drafts are "old".

At IETF 105, Jen discussed draft-linkova-v6ops-nd-cache-init, and there was a lot of support for taking it as a working group draft. Bob Hinden, 6man chair, commented that he would prefer that v6ops discuss operational issues, but protocol issues be discussed in 6man. Hence, Ron and I are looking for a draft-ietf-v6ops-nd-cache-init that addresses the operational issues raised in this draft, and Bob and Ole are looking for the protocol issues in a 6man draft. Those balls are in Jen's court, but I suspect she would appreciate any help folks want to offer.

A point I'm thinking about for IETF 106 is that we don't see a lot of email support for the individual submissions below. If you are hoping for one of them to go somewhere, email to the list would be in order. We're also interested in new drafts on IPv6 networking. If you're seeking inspiration, there have been a couple of longish threads on nanog@ recently. As stated in our charter, we would hope they address operational issues that you see in your network(s), and propose solutions. Such drafts have to be posted before November 4, as that's the repository cut-off, and ideally long enough before that to allow for mailing list discussion.
> On each draft below, there are three or four links:
> 
> the relevant datatracker link,
> a pointer to the HTML version of the draft in the tools directory,
> a pointer to the email archived on IETF mailing lists related to the draft, and
> a pointer to RFCDIFF against the previous version, if there was one.
> RFC Editor: RFC-EDITOR
> 
> 2019-09-09	draft-ietf-v6ops-nat64-deployment (tracker) <https://datatracker.ietf.org/doc/draft-ietf-v6ops-nat64-deployment> (HTML) <https://tools.ietf.org/html/draft-ietf-v6ops-nat64-deployment> (thread) <https://mailarchive.ietf.org/arch/search/?qdr=a&q=%22draft-ietf-v6ops-nat64-deployment%22> (diffs) <https://tools.ietf.org/rfcdiff?url2=draft-ietf-v6ops-nat64-deployment-08.txt>
> WG: Candidate for WG Adoption
> 
> 2019-07-25	draft-linkova-v6ops-nd-cache-init (tracker) <https://datatracker.ietf.org/doc/draft-linkova-v6ops-nd-cache-init> (HTML) <https://tools.ietf.org/html/draft-linkova-v6ops-nd-cache-init> (thread) <https://mailarchive.ietf.org/arch/search/?qdr=a&q=%22draft-linkova-v6ops-nd-cache-init%22> (diffs) <https://tools.ietf.org/rfcdiff?url2=draft-linkova-v6ops-nd-cache-init-01.txt>
> Individual Submission: Unupdated
> 
> 2019-07-08	draft-palet-v6ops-464xlat-opt-cdn-caches (tracker) <https://datatracker.ietf.org/doc/draft-palet-v6ops-464xlat-opt-cdn-caches> (HTML) <https://tools.ietf.org/html/draft-palet-v6ops-464xlat-opt-cdn-caches> (thread) <https://mailarchive.ietf.org/arch/search/?qdr=a&q=%22draft-palet-v6ops-464xlat-opt-cdn-caches%22> (diffs) <https://tools.ietf.org/rfcdiff?url2=draft-palet-v6ops-464xlat-opt-cdn-caches-03.txt>
> 2019-07-06	draft-gont-v6ops-slaac-renum (tracker) <https://datatracker.ietf.org/doc/draft-gont-v6ops-slaac-renum> (HTML) <https://tools.ietf.org/html/draft-gont-v6ops-slaac-renum> (thread) <https://mailarchive.ietf.org/arch/search/?qdr=a&q=%22draft-gont-v6ops-slaac-renum%22>
> 2019-07-06	draft-lmhp-v6ops-transition-comparison (tracker) <https://datatracker.ietf.org/doc/draft-lmhp-v6ops-transition-comparison> (HTML) <https://tools.ietf.org/html/draft-lmhp-v6ops-transition-comparison> (thread) <https://mailarchive.ietf.org/arch/search/?qdr=a&q=%22draft-lmhp-v6ops-transition-comparison%22> (diffs) <https://tools.ietf.org/rfcdiff?url2=draft-lmhp-v6ops-transition-comparison-03.txt>
> 2019-07-04	draft-palet-v6ops-p2p-links (tracker) <https://datatracker.ietf.org/doc/draft-palet-v6ops-p2p-links> (HTML) <https://tools.ietf.org/html/draft-palet-v6ops-p2p-links> (thread) <https://mailarchive.ietf.org/arch/search/?qdr=a&q=%22draft-palet-v6ops-p2p-links%22> (diffs) <https://tools.ietf.org/rfcdiff?url2=draft-palet-v6ops-p2p-links-03.txt>
> 2019-07-03	draft-palet-v6ops-ipv6-only (tracker) <https://datatracker.ietf.org/doc/draft-palet-v6ops-ipv6-only> (HTML) <https://tools.ietf.org/html/draft-palet-v6ops-ipv6-only> (thread) <https://mailarchive.ietf.org/arch/search/?qdr=a&q=%22draft-palet-v6ops-ipv6-only%22> (diffs) <https://tools.ietf.org/rfcdiff?url2=draft-palet-v6ops-ipv6-only-04.txt>
> 2019-06-24	draft-templin-v6ops-pdhost (tracker) <https://datatracker.ietf.org/doc/draft-templin-v6ops-pdhost> (HTML) <https://tools.ietf.org/html/draft-templin-v6ops-pdhost> (thread) <https://mailarchive.ietf.org/arch/search/?qdr=a&q=%22draft-templin-v6ops-pdhost%22> (diffs) <https://tools.ietf.org/rfcdiff?url2=draft-templin-v6ops-pdhost-24.txt>
> Individual Submission: Updated
> 
> 2019-09-18	draft-shytyi-v6ops-danir (tracker) <https://datatracker.ietf.org/doc/draft-shytyi-v6ops-danir> (HTML) <https://tools.ietf.org/html/draft-shytyi-v6ops-danir> (thread) <https://mailarchive.ietf.org/arch/search/?qdr=a&q=%22draft-shytyi-v6ops-danir%22> (diffs) <https://tools.ietf.org/rfcdiff?url2=draft-shytyi-v6ops-danir-04.txt>
> The charter for this group is at https://datatracker.ietf.org/group/v6ops/about/ <https://datatracker.ietf.org/group/v6ops/about/>Mon Oct 14 14:00:32 2019 <https://datatracker.ietf.org/group/v6ops/about/>

---

From: Jen Linkova <[email-masked]>
Date: Tue, 15 Oct 2019 19:12:13 +1100

> At IETF 105, Jen discussed draft-linkova-v6ops-nd-cache-init, and there was a lot of support for taking it as a working group draft. Bob Hinden, 6man chair, commented that he would prefer that v6op…

Almost done with the new version, sorry about the delay, will submit
before the deadline most definitely!

-- 
SY, Jen Linkova aka Furry

---

From: Gábor LENCSE <[email-masked]>
Date: Tue, 15 Oct 2019 21:06:39 +0200

Dear Fred,

>> 2019-07-06	draft-lmhp-v6ops-transition-comparison (tracker) <https://datatracker.ietf.org/doc/draft-lmhp-v6ops-transition-comparison> (HTML) <https://tools.ietf.org/html/draft-lmhp-v6ops-transitio…

Unfortunately I cannot promise a significant update until the cut date 
of IETF 106. However, I do not want to abandon it at all, and I plan to 
add a section about the performance analysis of the 5 IPv4aaS 
technologies according to the methodology described in RFC 8219.

Although our results are not visible yet, several people are working on 
this topic. When I was in Japan, I did SIIT (also called stateless 
NAT64) performance measurements, by which I tested the feasibility of 
the benchmarking methodology described in RFC 8219. Unfortunately, the 
DPDK based measurement program written by my PhD student proved to be 
completely unusable, and though I could do some quick fix and I could 
use it in a limited way, I decided to completely re-implement it. Now, I 
am very close to finish it and release siitperf as a free software.

Since September, I have an MSc student, who is working on an RFC 8219 
compliant DS-Lite Tester. He has experience in DPDK, and I hope that he 
can do it in one semester. (Perhaps, he will extend his tester for the 
other technologies in the next semester, but it is his decision, if he 
is willing to do so.)

I also have two new PhD students: one of them focuses on the comparison 
of the 5 IPv4aaS technologies in several aspects, and the other one 
deals with the security issues of IPv6 transition technologies.

So even slowly, but we are progressing. I plan to include some of our 
results into our draft before IETF 107.

Best regards,

Gábor

---

From: Fred Baker <[email-masked]>
Date: Tue, 15 Oct 2019 22:45:01 -0700

Looking forward to the update and the results.

> On Oct 15, 2019, at 12:06 PM, Gábor LENCSE <[email-masked]> wrote:
> 
> Dear Fred,
> 
> Unfortunately I cannot promise a significant update until the cut date of IETF 106. However, I do not want to abandon it at all, and I plan to add a section about the performance analysis of the 5 IPv4aaS technologies according to the methodology described in RFC 8219.
> 
> Although our results are not visible yet, several people are working on this topic. When I was in Japan, I did SIIT (also called stateless NAT64) performance measurements, by which I tested the feasibility of the benchmarking methodology described in RFC 8219. Unfortunately, the DPDK based measurement program written by my PhD student proved to be completely unusable, and though I could do some quick fix and I could use it in a limited way, I decided to completely re-implement it. Now, I am very close to finish it and release siitperf as a free software.
> 
> Since September, I have an MSc student, who is working on an RFC 8219 compliant DS-Lite Tester. He has experience in DPDK, and I hope that he can do it in one semester. (Perhaps, he will extend his tester for the other technologies in the next semester, but it is his decision, if he is willing to do so.)
> 
> I also have two new PhD students: one of them focuses on the comparison of the 5 IPv4aaS technologies in several aspects, and the other one deals with the security issues of IPv6 transition technologies.
> 
> So even slowly, but we are progressing. I plan to include some of our results into our draft before IETF 107.
> 
> Best regards,
> 
> Gábor
> 
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Fred Baker <[email-masked]>
Date: Tue, 15 Oct 2019 23:10:15 -0700

Let me ask a question. Each time we meet, about a month before the repository cut-off, I say "it's a month before the cut-off" - Speak!. I barely hear crickets. When I sent this (which I share with Ron every other week and we discuss), I got several replies.

Question for this list: is this a useful formulation of the datatracker data and call to working group action? Would you like to see it a few weeks before each meeting? It's what Ron and I use, in addition to the datatracker itself, in figuring out our agenda. When I comment on mailing list behavior, these are the links I'm following. As I did in this email, I can also list action items I'm expecting - such as "hint, you know who you are" - we had several people agree at IETF 105 to review drafts and comment to the list...

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 17 Oct 2019 15:06:01 +0200

Le 16/10/2019 à 08:10, Fred Baker a écrit :
> Let me ask a question. Each time we meet, about a month before the 
> repository cut-off, I say "it's a month before the cut-off" - Speak!. 
> I barely hear crickets. When I sent this (which I share with Ron every 
> other week and we discuss), I got several replies.

On my side, I must say that I do find useful the list you post about the 
relevant Internet Drafts.

About the low noise crickets make:

I think this aspect of too low traffic when requested is due to a little 
bit of compulsive posting by many posters.  I myself am doing it so.  
Whenever in my schedule there is a result I think it deserves noting in 
v6ops I just post it: be it before a meeting, during or right after a 
meeting.   This sometimes works, other times not at all.

>
> Question for this list: is this a useful formulation of the 
> datatracker data and call to working group action? Would you like to 
> see it a few weeks before each meeting? It's what Ron and I use, in 
> addition to the datatracker itself, in figuring out our agenda. When I 
> comment on mailing list behavior, these are the links I'm following. 
> As I did in this email, I can also list action items I'm expecting - 
> such as "hint, you know who you are" - we had several people agree at 
> IETF 105 to review drafts and comment to the list...

I will not come to this meeting.  A co-author will, and we are 
interested in getting a slot, nad interested in getting discussion results.

We do have a sort of long term time plan for our draft.  We would like 
to match our time plan to the v6ops WG time plan.  We tried to talk 
about our draft whenever talk about drafts was requested.  That is the 
best we can do at this time.

But if there was a WG Milestones in a Charter, then we could adapt to 
these milestones too.

Alex

> > Apologies for the HTML Email. Some folks complain about them. This 
> is a file I put together daily showing the status of v6ops 
> documents.This document describes the drafts associated with this 
> group. It describes their current state as seen by the RFC Editor, 
> IESG/AD, and the working or research group. For working group drafts 
> and individual submissions, it also indicates whether the draft has 
> been updated since the previous IETF meeting. Drafts that are new or 
> have been updated are "current"; other drafts are "old".
> >
> > At IETF 105, Jen discussed draft-linkova-v6ops-nd-cache-init, and 
> there was a lot of support for taking it as a working group draft. Bob 
> Hinden, 6man chair, commented that he would prefer that v6ops discuss 
> operational issues, but protocol issues be discussed in 6man. Hence, 
> Ron and I are looking for a draft-ietf-v6ops-nd-cache-init that 
> addresses the operational issues raised in this draft, and Bob and Ole 
> are looking for the protocol issues in a 6man draft. Those balls are 
> in Jen's court, but I suspect she would appreciate any help folks want 
> to offer.
> >
> > A point I'm thinking about for IETF 106 is that we don't see a lot 
> of email support for the individual submissions below. If you are 
> hoping for one of them to go somewhere, email to the list would be in 
> order. We're also interested in new drafts on IPv6 networking. If 
> you're seeking inspiration, there have been a couple of longish 
> threads on nanog@ recently. As stated in our charter, we would hope 
> they address operational issues that you see in your network(s), and 
> propose solutions. Such drafts have to be posted before November 4, as 
> that's the repository cut-off, and ideally long enough before that to 
> allow for mailing list discussion.
>