Subject: Re: [v6ops] SLAAC renum: Problem Statement & Operational workarounds

From: Fernando Gont <[email-masked]>
Date: Fri, 1 Nov 2019 01:21:57 -0300

On 30/10/19 11:07, Ole Troan wrote:
> Ted,
> 
>>> We check both, the handling of the IA_PD and the error message.
>>
>> And to be clear, you mean that if the CPE asks for a prefix delegation and doesn’t get the prefix it previously had, it deprecates it as described in L-14?  When this deprecation happens, what ways are being tested for it to happen?
>>
>> E.g., is it the case that the client sends an IA PD containing an IA Prefix option, is the server returning the IA Prefix option containing the same prefix, with a status code encapsulated in it?   What status code?   Or is it returning an IA Prefix option with a different prefix?   Or is it doing both?
> 
> You are thinking about this wrong.
> The simple implementation of uRPF/BCP38 is: on LAN ingress to do a lookup in the FIB of the SA, if the resulting adjacency/interface matches the ingress interface allow packet otherwise drop packet and send ICMP message. This behaviour is required regardless of renumbering or not.
> The ISP is required to do this on their ingress interfaces too.

You mean required as in "MUST"? If so, where?

-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Fred Baker <[email-masked]>
Date: Fri, 1 Nov 2019 10:21:53 -0400

> On Oct 30, 2019, at 10:07 AM, Ole Troan <[email-masked]> wrote:
> 
> Ted,
> 
> The simple implementation of uRPF/BCP38 is: on LAN ingress to do a lookup in the FIB of the SA,

On a customer-facing interface (e.g., someone you don't exchange BGP with and is therefore the only source of the prefix), yes. In an ISP, you want to be looking at the RIB, not the FIB; any BGP neighbor that is advertising a prefix to you might send you a packet with a source address in that prefix.

> if the resulting adjacency/interface matches the ingress interface allow packet otherwise drop packet and send ICMP message. This behaviour is required regardless of renumbering or not.
> Cheers,
> Ole
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops