Subject: [v6ops] Call for Discussion draft-palet-v6ops-ipv6-only

From: Ron Bonica <[email-masked]>
Date: Mon, 8 Jun 2020 16:51:06 +0000

Folks,

Each week between now and IETF week, we will review and discuss one draft with an eye towards progressing it.

This week, please review and comment on draft-palet-v6ops-ipv6-only.

Please submit comments by June 22, 2020.

                                  Fred and Ron

Juniper Business Use Only

---

From: Philip Homburg <[email-masked]>
Date: Tue, 09 Jun 2020 11:51:38 +0200

>This week, please review and comment on draft-palet-v6ops-ipv6-only.

I think this is a well thought-out set of definitions.

---

From: Mikael Abrahamsson <[email-masked]>
Date: Tue, 9 Jun 2020 14:55:28 +0200 (CEST)

> This week, please review and comment on draft-palet-v6ops-ipv6-only.

I think it would be good if we could come up with some terms that cause 
less confusion when discussing different solutions. So this draft has an 
embryo for that, but I think it would be good if there were some examples.

So let's say I want to describe a mobile access with IPv6 only WAN that 
supports 464xlat? What is that then? "dual stack LAN with transitional 
464xlat-enabled router with IPv6 only WAN and NAT64 function in the 
network"?

That's still long and cumbersome...?

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 09 Jun 2020 15:55:31 +0200

Hi Mikael,

In my opinion, your example, has several parts.

If we want to talk about "all", should be sufficient to say "this is a 464XLAT" case. I think this is out of the scope of the document, because 464XLAT itself is very well self-contained/described.

The point is if you want to talk about the WAN link itself. In your example case it is clearly an IPv6-only WAN.

If you want to talk about the UE, actually "today OSs" are native dual-stack, however, in this network it is being used as a transitional IPv6 host/router.

The full point of the document is that if we talk about an specific transition mechanism, everything is very clear (unless the network is doing a "special" deployment different from the standard), however, in many occasions it is very relevant to make sure if the WAN links (for example) are *natively* transporting IPv6-only.

That said, I'm of course happy to add a few examples. Not sure if that should be an annex or in the main text already.

Regards,
Jordi
@jordipalet

El 9/6/20 14:56, "v6ops en nombre de Mikael Abrahamsson" <[email-masked] en nombre de swmike=[email-masked]> escribió:

    _______________________________________________
    v6ops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/v6ops

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Wed, 10 Jun 2020 08:49:03 +0000

Hi,

I have reviewed this draft. It is always good to clarify some confusing terminology.

Some comments:

1.      Shall we put Access together with LAN instead of with WAN?

2.      Do we want to include IPv6-only Data Center?

3.      A typo on Page 3?: “Also if customer devices in a LAN are IPv6-only (A typo? -> IPv4-only), they will not be able to access IPv6-only services, so this means that IPv6-only services can't be deployed unless it is done in such way that some transition mechanism …”

4.      Do we want to provide a reference [RFC8585] for "IPv4-as-a-service"?

I would also agree that an example(s) or illustrative diagram(s) might be helpful, and I gave an attempt. This would be a typical diagram for users to access to data center.

I tried to include all the terms defined in this draft, and also IPv6-only Data Center. I put LAN and Access together as well.

Best regards,

Shuping

-----Original Message-----
From: v6ops [mailto:[email-masked]] On Behalf Of JORDI PALET MARTINEZ
Sent: Tuesday, June 9, 2020 9:56 PM
To: [email-masked]
Subject: Re: [v6ops] Call for Discussion draft-palet-v6ops-ipv6-only

Hi Mikael,

Regards,

Jordi

@jordipalet

El 9/6/20 14:56, "v6ops en nombre de Mikael Abrahamsson" <[email-masked] en nombre de swmike=[email-masked]<mailto:[email-masked]%20en%20nombre%20de%20swmike=[email-masked]>> escribió:

    network"?

    --

    Mikael Abrahamsson    email: [email-masked]<mailto:[email-masked]>

    v6ops mailing list

    [email-masked]<mailto:[email-masked]>

IPv4 is over

The IPv6 Company

v6ops mailing list

[email-masked]<mailto:[email-masked]>

---

From: Richard Patterson <[email-masked]>
Date: Wed, 10 Jun 2020 10:49:38 +0100

On comment 1, from a CPE router perspective it's the WAN interface that's
facing the Access Node, i.e., an OLT or DSLAM.
With that in-mind I think the existing wording for this point is correct.
Perhaps "access network" can become "Access Network"?

On Wed, 10 Jun 2020 at 09:50, Pengshuping (Peng Shuping) <
[email-masked]> wrote:

> 3.      A typo on Page 3?: “Also if customer devices in a LAN are
> IPv6-only (A typo? -> IPv4-only), they will not be able to access IPv6-only
> services, so this means that IPv6-only services can't be deployed unless it
> is done in such way that some transition mechanism …”
>
> I would also agree that an example(s) or illustrative diagram(s) might be
> helpful, and I gave an attempt. This would be a typical diagram for users
> to access to data center.
>
> I tried to include all the terms defined in this draft, and also IPv6-only
> Data Center. I put LAN and Access together as well.
>
>
>
> Best regards,
>
> Shuping
>
>
>
>
>
>
>
> If we want to talk about "all", should be sufficient to say "this is a
> 464XLAT" case. I think this is out of the scope of the document, because
> 464XLAT itself is very well self-contained/described.
>
>
>
> The point is if you want to talk about the WAN link itself. In your
> example case it is clearly an IPv6-only WAN.
>
>
>
> If you want to talk about the UE, actually "today OSs" are native
> dual-stack, however, in this network it is being used as a transitional
> IPv6 host/router.
>
>
>
> The full point of the document is that if we talk about an specific
> transition mechanism, everything is very clear (unless the network is doing
> a "special" deployment different from the standard), however, in many
> occasions it is very relevant to make sure if the WAN links (for example)
> are *natively* transporting IPv6-only.
>
>
>
> That said, I'm of course happy to add a few examples. Not sure if that
> should be an annex or in the main text already.
>
>
>
> Regards,
>
> Jordi
>
> @jordipalet
>
>
>
>
>
> El 9/6/20 14:56, "v6ops en nombre de Mikael Abrahamsson" <[email-masked]
> en nombre de swmike=[email-masked]
> <[email-masked]%20en%20nombre%20de%20swmike=[email-masked]>>
> escribió:
>
>
>
>     > Each week between now and IETF week, we will review and discuss one
> draft with an eye towards progressing it.
>
>     >
>
>     >
>
>     >
>
> This electronic message contains information which may be privileged or
> confidential. The information is intended to be for the exclusive use of
> the individual(s) named above and further non-explicilty authorized
> disclosure, copying, distribution or use of the contents of this
> information, even if partially, including attached files, is strictly
> prohibited and will be considered a criminal offense. If you are not the
> intended recipient be aware that any disclosure, copying, distribution or
> use of the contents of this information, even if partially, including
> attached files, is strictly prohibited, will be considered a criminal
> offense, so you must reply to the original sender to inform about this
> communication and delete it.
>
>
>
>
>
>
>