Subject: [v6ops] Fwd: IETF 108 planning

From: Fred Baker <[email-masked]>
Date: Wed, 3 Jun 2020 09:57:58 -0700

Passing along an exchange I had with Ron. TL;DR: we plan to have an “interim” session online sometime in July in lieu of a formal meeting managed as part of IETF 108. If we want to meet as part of IETF 108, I have until June 12 to request a slot, but as of now I don’t plan to do so.

Your opinions welcome.

Sent from my iPad

Begin forwarded message:

> From: Ron Bonica <[email-masked]>
> Date: June 3, 2020 at 8:17:07 AM PDT
> To: Fred Baker <[email-masked]>
> Cc: Warren Kumari <[email-masked]>
> Subject: RE:  IETF 108 planning
> 
> 
> Fred,
>  
> I agree. V6OPS has done a very good job of shifting its work from in person meetings to the mailing list. So, we really don’t need to meet at IETF 108.
>  
> We are progressing the drafts that we have on our plate nicely and we don’t have any new drafts.
>  
>                                                         Ron
>  
>  
>  
> Juniper Business Use Only
> From: Fred Baker <[email-masked]> 
> Sent: Tuesday, June 2, 2020 5:53 PM
> To: Ron Bonica <[email-masked]>
> Cc: Warren Kumari <[email-masked]>
> Subject: Fwd: IETF 108 planning
>  
> FYI, per https://datatracker.ietf.org/meeting/108/important-dates/, 6/12 is the last day to request a working group meeting within the IETF 108 schedule. I am not currently planning to do that, as we have no new drafts to discuss. Folks have until 7/8 to file them, of course, but If they do they by definition have to be deferred to IETF 109 - I can't schedule a meeting to discuss them. At most, we can invite email discussion.
>  
> You saw this email two months ago, and the one response, from Brian Carpenter, who asked that the speakers file drafts.
>  
> When would be a good time for a phone call?
>  
> 
> Begin forwarded message:
>  
> From: Fred Baker <[email-masked]>
> Subject: IETF 108 planning
> Date: April 18, 2020 at 12:25:29 PM PDT
> To: IPv6 Operations <[email-masked]>
>  
> Ron and I are starting the planning for IETF 108. Alissa has told the working group chairs that there is a distinct chance that it will be entirely virtual. Whatever the rest of the IETF does, I expect there will be some of us that are not permitted to travel there - at least one speaker has told me that. And I’m scratching my head on the agenda.
>  
> Each meeting, I say about 30 days before the repository closes that “if someone has a draft they want to file, now would be the perfect time to do so.” Consider that said. We are in the process of working group last calls on five drafts, which I expect to result in updated drafts placed in Warren’s in-basket. Those are each named “draft-Ietf-v6ops-*” or “draft-Ietf-dhc-*”. 
>  
> My understanding is that, with one possible exception, the working group doesn’t find our other posted individual submissions (draft-name-v6ops-*) operationally interesting. So I’m looking for one, perhaps both, of two things: new drafts that the working group, when asked, says “this is important; we need to discuss this”, or statements by other than an author/editor that the individual submissions are operationally interesting. In each case, as always, I’m looking for supportive list discussion; that can include the authors/editors, of course, but most interesting are folks that have no vested interest saying “I would like to implement this in my network.”
>  
> So, I’m looking for drafts to discuss.
>  
> We also, for the past several years, been giving operators an opportunity to talk about IPv6 (and especially IPv6-only) deployment in their networks. If you look in the proceedings starting with about IETF 98, we have had one per meeting with the exception of IETF 107. What I am looking for there is
>  
>    - letting operators talk with each other
>    - is there work that we, the IETF, need to be doing and haven’t done?
>  
> Right now, I have three folks that have asked me for air time:
>  
>       Ben Kyemba, RENU (IPv6 deployment in RENU, NREN in Uganda)
>       Jen Linkova, Google, (the process of turning off IPv4)
>       Chifei Xie, China Telecom (Chinese IPv6 usage statistics, which differ from Google, Akamai, and APNIC numbers)
>  
> A topic I would like to see discussed (but I’m missing some important details) would be an IPv6-capable network security survey tool. One issue enterprises raise with IPv6 is that appliances and tools they use for IPv4 security are not available (or not well known) as applying the same tests to IPv6 and thereby testing a network’s IPv6 security In a comparable way. If someone has one they would recommend, especially if they have experience using it, I’d like to add a talk on that topic to the above four.
>  
> So, to put hands and feet on this, I’m thinking of scheduling a two hour virtual interim and asking those three or four speakers to participate in it. If we have new draft(s) with working group support, I’ll include those as well, of course, but that would be in a separate meeting.
>  
> So, I have a couple of questions, besides “please post drafts”.
>  
> 1) do you find the speakers listed above interesting?
> 2) would you rather meet f2f in Madrid during the scheduled IETF week?
>      “ “ “ meet virtually during the scheduled IETF week
>      “ “ “ would you rather have one or two virtual interims?
> 3) if you’re interested in a virtual interim, when would you like to do it? Fill in the doodle poll: https://doodle.com/poll/4fw2d6d56fyi2tw4

---

From: Fernando Gont <[email-masked]>
Date: Thu, 4 Jun 2020 01:31:29 -0300

Hello, Fred,

FWIW, I agree with your (and Ron's) assessment. Even more, if there's a 
need for a virtual meeting, I guess the option of interim meetings is 
always on the table?

(Actually, I'd say that I'm curious about the need to have a virtual 
IETF 108 -- spreading any virtual interim meetings over time and as 
needed would seem like a much better option to me).

Thanks,
Fernando

On 3/6/20 13:57, Fred Baker wrote:
> Passing along an exchange I had with Ron. TL;DR: we plan to have an 
> “interim” session online sometime in July in lieu of a formal meeting 
> managed as part of IETF 108. If we want to meet as part of IETF 108, I 
> have until June 12 to request a slot, but as of now I don’t plan to do so.
> 
> Your opinions welcome.
> 
> Sent from my iPad
> 
> Begin forwarded message:
> 
>> *From:* Ron Bonica <[email-masked]>
>> *Date:* June 3, 2020 at 8:17:07 AM PDT
>> *To:* Fred Baker <[email-masked]>
>> *Cc:* Warren Kumari <[email-masked]>
>> *Subject:* *RE:  IETF 108 planning*
>>
>> 
>>
>> Fred,
>>
>> I agree. V6OPS has done a very good job of shifting its work from in 
>> person meetings to the mailing list. So, we really don’t need to meet 
>> at IETF 108.
>>
>> *From:* Fred Baker <[email-masked]>
>> *Sent:* Tuesday, June 2, 2020 5:53 PM
>> *To:* Ron Bonica <[email-masked]>
>> *Cc:* Warren Kumari <[email-masked]>
>> *Subject:* Fwd: IETF 108 planning
>>
>> FYI, per https://datatracker.ietf.org/meeting/108/important-dates/, 
>> 6/12 is the last day to request a working group meeting within the 
>> IETF 108 schedule. I am not currently planning to do that, as we have 
>> no new drafts to discuss. Folks have until 7/8 to file them, of 
>> course, but If they do they by definition have to be deferred to IETF 
>> 109 - I can't schedule a meeting to discuss them. At most, we can 
>> invite email discussion.
>>
>> You saw this email two months ago, and the one response, from Brian 
>> Carpenter, who asked that the speakers file drafts.
>>
>>     *From: *Fred Baker <[email-masked]
>>     <mailto:[email-masked]>>
>>
>>     *Subject: IETF 108 planning*
>>
>>     *Date: *April 18, 2020 at 12:25:29 PM PDT
>>
>>     *To: *IPv6 Operations <[email-masked] <mailto:[email-masked]>>
>>
>>     Ron and I are starting the planning for IETF 108. Alissa has told
>>     the working group chairs that there is a distinct chance that it
>>     will be entirely virtual. Whatever the rest of the IETF does, I
>>     expect there will be some of us that are not permitted to travel
>>     there - at least one speaker has told me that. And I’m scratching
>>     my head on the agenda.
>>
>>     Each meeting, I say about 30 days before the repository closes
>>     that “if someone has a draft they want to file, now would be the
>>     perfect time to do so.” Consider that said. We are in the process
>>     of working group last calls on five drafts, which I expect to
>>     result in updated drafts placed in Warren’s in-basket. Those are
>>     each named “draft-Ietf-v6ops-*” or “draft-Ietf-dhc-*”.
>>
>>     My understanding is that, with one possible exception, the working
>>     group doesn’t find our other posted individual submissions
>>     (draft-name-v6ops-*) operationally interesting. So I’m looking for
>>     one, perhaps both, of two things: new drafts that the working
>>     group, when asked, says “this is important; we need to discuss
>>     this”, or statements by other than an author/editor that the
>>     individual submissions are operationally interesting. In each
>>     case, as always, I’m looking for supportive list discussion; that
>>     can include the authors/editors, of course, but most interesting
>>     are folks that have no vested interest saying “I would like to
>>     implement this in my network.”
>>
>>     We also, for the past several years, been giving operators an
>>     opportunity to talk about IPv6 (and especially IPv6-only)
>>     deployment in their networks. If you look in the proceedings
>>     starting with about IETF 98, we have had one per meeting with the
>>     exception of IETF 107. What I am looking for there is
>>
>>           Chifei Xie, China Telecom (Chinese IPv6 usage statistics,
>>     which differ from Google, Akamai, and APNIC numbers)
>>
>>     A topic I would like to see discussed (but I’m missing some
>>     important details) would be an IPv6-capable network security
>>     survey tool. One issue enterprises raise with IPv6 is that
>>     appliances and tools they use for IPv4 security are not available
>>     (or not well known) as applying the same tests to IPv6 and thereby
>>     testing a network’s IPv6 security In a comparable way. If someone
>>     has one they would recommend, especially if they have experience
>>     using it, I’d like to add a talk on that topic to the above four.
>>
>>     So, to put hands and feet on this, I’m thinking of scheduling a
>>     two hour virtual interim and asking those three or four speakers
>>     to participate in it. If we have new draft(s) with working group
>>     support, I’ll include those as well, of course, but that would be
>>     in a separate meeting.
>>
>>     3) if you’re interested in a virtual interim, when would you like
>>     to do it? Fill in the doodle poll:
>>     https://doodle.com/poll/4fw2d6d56fyi2tw4
>>
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
> 

-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 4 Jun 2020 09:13:48 +0200

> needed would seem like a much better option to me).

100% !!!

I think this is not just for you ... it works ways better for everyone.

Well except LLC perhaps.

That actually puts back on the table the need for regular IETF venue
meetings all together and that is why many people are even afraid that
periodic interims regardless if online or physical could dismiss the need
for global gatherings.

Best,
R.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 4 Jun 2020 07:54:05 +0000

Well, my groups (6TiSCH, LPWAN) have been practicing regular interims (like bi-weekly) for years and that was really productive.
That never replaced the need for the face to face IETF meetings, though. Those forms of interaction have shown to be really complementary for us.

The virtual IETF is yet another thing. At IETF 107 neither f the above groups met, and we had interims instead. That allowed us to adjust the time of the meeting to the audience as opposed to get something packed with other meetings, and in the middle of the night for a majority (those groups have a majority of EU-based population). We were really happy with that.

This time we plan to ask for a short meeting, in the hope that we can make explicit status and possibly steer decisions - to be confirmed on the list, of course. What I’m trying to say is that after 6+ month without a formal meeting we are missing the official aspect of the IETF meetings and the expectation that more people show up and influence than the more limited core that attend regular interims.

Not sure the virtual IETF will achieve that as the F2F does. Then there’s the fees.

Take care,

Pascal

From: v6ops <[email-masked]> On Behalf Of Robert Raszuk
Sent: jeudi 4 juin 2020 09:14
To: Fernando Gont <[email-masked]>
Cc: IPv6 Operations <[email-masked]>
Subject: Re: [v6ops] Fwd: IETF 108 planning

100% !!!

Well except LLC perhaps.

That actually puts back on the table the need for regular IETF venue meetings all together and that is why many people are even afraid that periodic interims regardless if online or physical could dismiss the need for global gatherings.

Best,
R.

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 4 Jun 2020 20:08:19 +1200

Robert,

On 04-Jun-20 19:13, Robert Raszuk wrote:
> That actually puts back on the table the need for regular IETF venue meetings all together

Please don't overlook the fact that many people are deadline-driven and the 4-monthly I-D cutoff dates are our main deadlines. Taking that away would damage progress. Also, we need a vehicle for BOFs and other mechanisms like HotRFC, and reporting mechanisms to the community. And whether on-line code sprints and hacakathons really work remains to be seen.

I'm not saying these things can't be done on line, but we need to make sure we find out all the unwritten and community-building functions of the meetings and replace them too.

A fine topic for the SHMO WG if created.

   Brian

> and that is why many people are even afraid that periodic interims regardless if online or physical could dismiss the need for global gatherings. 
> 
> Best,
> R.
> 
> 
> 
> 
>  
>

---

From: Tim Chown <[email-masked]>
Date: Thu, 4 Jun 2020 13:18:48 +0100

> On 4 Jun 2020, at 09:08, Brian E Carpenter <[email-masked]> wrote:
> 

Well, an interim is $230 (or was it $320?) cheaper for attendees than planning for a session at the main event.  Makes it cheaper and more accessible to attend, and avoids people missing the session due to clashes with other WGs.  No reason we couldn’t have interim meeting cutoffs, if deadlines are deemed useful?

Tim

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 4 Jun 2020 14:24:24 +0200

>
>  No reason we couldn’t have interim meeting cutoffs, if deadlines are
> deemed useful?
>
> Tim

Spot on ! Besides if cutoffs are distributed in time (say per WG or per
Area) it gives much more time for folks interested in BGP or IPv6 to also
catch-up with Quic or HTML progress.

R.

---

From: Tim Chown <[email-masked]>
Date: Thu, 4 Jun 2020 13:35:52 +0100

> On 4 Jun 2020, at 13:24, Robert Raszuk <[email-masked]> wrote:
> 
>  No reason we couldn’t have interim meeting cutoffs, if deadlines are deemed useful?
> 
> Tim
> 
> Spot on ! Besides if cutoffs are distributed in time (say per WG or per Area) it gives much more time for folks interested in BGP or IPv6 to also catch-up with Quic or HTML progress.

Actually, this is a really good point; as it is you see maybe 300-500 (?) drafts appear in 24 hours.  No way you can read everything you might like to. Stagger them and it becomes possible.

Tim

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 4 Jun 2020 14:41:25 +0200

Le 04/06/2020 à 09:54, Pascal Thubert (pthubert) a écrit :
> Well, my groups (6TiSCH, LPWAN) have been practicing regular interims
>  (like bi-weekly) for years and that was really productive.
> 
> That never replaced the need for the face to face IETF meetings,
> though. Those forms of interaction have shown to be really
> complementary for us.
> 
> The virtual IETF is yet another thing. At IETF 107 neither f the
> above groups met, and we had interims instead. That allowed us to
> adjust the time of the meeting to the audience as opposed to get
> something packed with other meetings, and in the middle of the night
> for a majority (those groups have a majority of EU-based population).
> We were really happy with that.
> 
> This time we plan to ask for a short meeting, in the hope that we can
>  make explicit status and possibly steer decisions - to be confirmed
> on the list, of course. What I’m trying to say is that after 6+ month
>  without a formal meeting we are missing the official aspect of the
> IETF meetings and the expectation that more people show up and
> influence than the more limited core that attend regular interims.
> 

For the fees aspect: interests of individuals were polled and a majority
expressed there should be no fees for the IETF virtual meetings.  I hope
that is taken into account.

I do agree, though, that doing a great experience telco with many
participants might incur costs.  Webex is still for free, I think, but
not sure for how long.  If it comes back paying, the cost might still be
low, compared to a typical individual meeting fee of roughly a few
hundred dollars.

Alex

> 
> Take care,
> 
> Pascal
> 
> *From:* v6ops <[email-masked]> *On Behalf Of *Robert Raszuk 
> *Sent:* jeudi 4 juin 2020 09:14 *To:* Fernando Gont
> <[email-masked]> *Cc:* IPv6 Operations <[email-masked]> 
> *Subject:* Re: [v6ops] Fwd: IETF 108 planning
> 
>  meetings all together and that is why many people are even afraid
> that periodic interims regardless if online or physical could dismiss
> the need for global gatherings.
> 
> Best,
> 
> R.
> 
> 
> _______________________________________________ v6ops mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Ted Lemon <[email-masked]>
Date: Thu, 4 Jun 2020 08:42:02 -0400

> Actually, this is a really good point; as it is you see maybe 300-500 (?) drafts appear in 24 hours.  No way you can read everything you might like to. Stagger them and it becomes possible.

Ideally, then, we’d just say “let’s have a new version of Document X at date Y prior to interim Y,” rather than leaving it open. Then authors could schedule the work on documents more based on their actual work schedule rather than an arbitrary deadline. I say this based on the personal experience of having had deadlines come at really inconvenient times so far this year, although IETF 108 looks like it might not be too bad. But in general, a steady state model of document deadlines would work a lot better for me, and it sounds like I’m not alone in that.