Subject: [v6ops] v6ops - Update to a Meeting Session Request for IETF 111

From: IETF Meeting Session Request Tool <[email-masked]>
Date: Thu, 20 May 2021 00:25:51 -0700

An update to a meeting session request has just been submitted by Fred Baker, a Chair of the v6ops working group.

---------------------------------------------------------
Working Group Name: IPv6 Operations
Area Name: Operations and Management Area
Session Requester: Fred Baker

Number of Sessions: 1
Length of Session(s):  1 Hour
Number of Attendees: 100
Conflicts to Avoid: 
 Chair Conflict: spring lsr 6man intarea idr bess tsvwg

 Key Participant Conflict: rtgwg panrg grow

People who must be present:
  Fred Baker
  Ron Bonica
  Warren &quot;Ace&quot; Kumari

Resources Requested:

Special Requests:
  
---------------------------------------------------------

---

From: Fred Baker <[email-masked]>
Date: Thu, 20 May 2021 18:29:20 -0700

Following up on the document list. See attached. This data is data tracker data that is reorganized into a format that I find more useful - each document has several statuses (has it been posted? What does the Working Group, IESG, or RFC Editor think of it?), and I try to sort that out into a "most relevant" status". Also, since "has it been updated since the most recent IETF meeting" is a factor in v6ops, you'll find that considered.

At this point, I have four questions for the working group:
   For draft-ietf-v6ops-transition-comparison, any comments on progress/status? (The authors would like to wait until October 30 before making a decision, pending other tests)
   For draft-ietf-v6ops-ipv6-deployment, any comments on progress/status? (On April 7, Guiseppe sent a note to the list asking for more comments)
   For draft-horley-v6ops-expand-doc, What is the working group;'s opinion? The chairs think it is in a state conducive to adoption.
   For draft-vasilenko-v6ops-ipv6-oversized-analysis, where do we go? At this moment, I'm thinking it could be presented at discussed at IETF 111.

Per https://datatracker.ietf.org/meeting/111/important-dates/, we are on the clock for IETF 111. Register...

> On May 20, 2021, at 12:25 AM, IETF Meeting Session Request Tool <[email-masked]> wrote:
> 
> 
>

---

From: Giuseppe Fioccola <[email-masked]>
Date: Mon, 24 May 2021 09:40:57 +0000

Dear Fred, All,
Regarding draft-ietf-v6ops-ipv6-deployment, we are thoroughly reviewing it to address the high number of comments. Meanwhile we also received additional inputs offline, in particular from Jordi Palet and he will also join as new coauthor.
We have almost finished and I think we can publish the new version soon.

Regards,

Giuseppe

From: v6ops [mailto:[email-masked]] On Behalf Of Fred Baker
Sent: Friday, May 21, 2021 3:29 AM
To: IPv6 Operations <[email-masked]>
Subject: Re: [v6ops] v6ops - Update to a Meeting Session Request for IETF 111

> On May 20, 2021, at 12:25 AM, IETF Meeting Session Request Tool <[email-masked]<mailto:[email-masked]>> wrote:
>
>
>

---

From: Gábor LENCSE <[email-masked]>
Date: Wed, 26 May 2021 17:00:02 +0200

Dear IPv6 Operations WG Members,

I would like to give an explanation of the following:

>     For draft-ietf-v6ops-transition-comparison, any comments on progress/status? (The authors would like to wait until October 30 before making a decision, pending other tests)

The most important reason to delay the WGLC of our draft is the 
following text on page 15:

    Stateful technologies, 464XLAT and DS-Lite (and also NAT444) can
    therefore be much more efficient in terms of port allocation and thus
    public IP address saving.  The price is the stateful operation in the
    service provider network, which allegedly does not scale up well.  It
    should be noticed that in many cases, all those factors may depend on
    how it is actually implemented.

    XXX MEASUREMENTS ARE PLANNED TO TEST IF THE ABOVE IS TRUE.  XXX

Of course, this issue should be resolved before the WGLC. To that end, I 
have already submitted the "00" version of a draft about the 
benchmarking methodology for stateful NAT64 gateways: 
https://datatracker.ietf.org/doc/html/draft-lencse-bmwg-benchmarking-stateful
First, I would like to receive comments about the methodology on the 
BMWG mailing list. -- Your comments are also welcome, if you have time 
to review it!!!
When the method seems to be good enough, I update the "sateful" branch 
of my DPDK-based tester called "siitperf": 
https://github.com/lencsegabor/siitperf/tree/stateful
Then I plan to discuss the most important parameters of the scale up 
tests and then check how stateful NAT64 scales up.

I plan to come back to you before starting the test to confirm with you, 
if you find the planned tests reasonable.

As for Section 5 of draft-ietf-v6ops-transition-comparison about 
Performance Comparison, I planned to perform benchmarking measurements 
of all 5 IPv4aaS technologies, but even the RFC 8219 compliant Testers 
and not implemented yet for the other 4 technologies except 464XLAT. I 
estimated that it would take 2-3 more years to perform the performance 
comparison. The session chairs recommended not to wait for such a long 
time with the publication of this draft. Thus, this section will either 
be removed or left as a stub and a pointer is going to be added, which 
points to a separate draft, in which one can later find the results of 
the performance analysis.

However, if you have any comments regarding our draft, they are always 
welcome! Issues resolved now, will not need to be handled later. :-)

Best regards,

Gábor