Subject: [v6ops] I-D Action: draft-ietf-v6ops-hbh-00.txt

From: [email-masked]
Date: Mon, 11 Oct 2021 09:43:42 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IPv6 Operations WG of the IETF.

        Title           : Operational Issues with Processing of the Hop-by-Hop Options Header
        Authors         : Shuping Peng
                          Zhenbin Li
                          Chongfeng Xie
                          Zhuangzhuang Qin
                          Gyan Mishra
	Filename        : draft-ietf-v6ops-hbh-00.txt
	Pages           : 14
	Date            : 2021-10-09

Abstract:
   This document describes the processing of the Hop-by-Hop Options
   Header (HBH) in today's routers in the aspects of standards
   specification, common implementations, and default operations.  This
   document outlines the reasons why the Hop-by-Hop Options Header is
   rarely utilized in current networks.  In addition, this document
   describes how the HBH could be used as a powerful mechanism allowing
   deployment and operations of new services requiring a more optimized
   way to leverage network resources of an infrastructure.  The Hop-by-
   Hop Options Header is taken into consideration by several network
   operators as a valuable container for carrying the information
   facilitating the introduction of new services.  The purpose of this
   draft is to document the reasons why the HBH is rarely used within
   networks and to define a proper list of requirements aiming to allow
   a better leverage of the HBH capability.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-v6ops-hbh/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-v6ops-hbh-00

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Nick Hilliard <[email-masked]>
Date: Mon, 11 Oct 2021 21:54:43 +0100

> 	Filename        : draft-ietf-v6ops-hbh-00.txt

I'm struggling with this ID.

Section 1: there is nothing in this section which isn't already said in 
rfc9098.

Section 2 is an overly-detailed explanation of router control plane / 
forwarding plane interaction, but then changes to a general discussion 
about HBH, most of which is repetition of other ietf documents.

Section 3 is a restatement of some material from rfc8200.

Sections 4 and 5 are a restatement of chunks of rfc9098.

Section 6 is a statement of aspirations about potential use of HBH.

Section 7 is mostly a repetition of draft-hinden-6man-hbh-processing. 
It states a list of aspirations for HBH processing that, if anything, 
belong to a standards track document, but they're difficult to mandate 
in a standards document for reasons which have already been discussed at 
some length in the draft-hinden-6man-hbh-processing discussion.

Section 8 talks about a new HBH header scheme, but doesn't indicate 
anywhere what this means or what the assumed old HBH scheme is.

The problem is, material which has been restated from other IETF 
documents needs to be removed (e.g. sections 1, 3, 4, and 5).

Once this is done, there's not much left in this draft, and what's left 
is either not relevant to the core of the document (detailed discussion 
of forwarding hardware mechanisms) or else has been restated in other 
drafts, e.g. draft-hinden-6man-hbh-processing, or else doesn't fit 
together in this document (section 2, 8).

Ideally people want general EHs (i.e. not just HBHs) to work a bit 
better - we all agree on that.  If this is the case, then 
draft-hinden-6man-hbh-processing provides a much better-thought-through 
path than draft-ietf-v6ops-hbh.

Sorry if this review comes across as harsh, but there's been a good deal 
of discussion about several other documents on the v6ops mailing list 
recently, and it's just difficult to see what this document brings that 
is new.

Nick

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Tue, 12 Oct 2021 00:48:33 +0000

Hi all, 

The new version of this draft has been uploaded. Many thanks for all the comments and suggestions we received! 

The main changes we have made are the followings,

1.	The title is changed to avoid the misleading towards a solution draft. 
2.	The purpose of this draft is further clarified in both the abstract and the introduction sections. 
3.	The scope of this draft is also clarified in section 2. 
4.	Necessary reference is added.
5.	Directly quote the specifications in the existing RFCs wherever are suitable. 
6.	Requirements in Section 7 are updated according to the received comments but still need more work which will be conducted in the later versions. 
7.	Section 8 is significantly changed instead of being completely deleted since we believe the migration is also very important to consider. 
8.	New sections on other network scenarios are still not yet added. We will work on them in the later versions. 

More work are still needed, and we will continue to working on this draft and keep improving it. Your comments and suggestions are always welcomed. 

Thank you! 

Best regards, 
Shuping

> -----Original Message-----
> From: v6ops [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Tuesday, October 12, 2021 12:44 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [v6ops] I-D Action: draft-ietf-v6ops-hbh-00.txt
> 
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Tue, 12 Oct 2021 01:01:46 +0000

Hi Nick, 

Thank you for your review and comments! 

People from the two working groups (6man and v6ops) have given extensive reviews on this draft and provided their comments in the mailing list. Some of your comments are already covered and discussed. 

As people suggested, this draft is positioned as a problem statement draft on the issues of the HBH options header only. We have just uploaded this initial 00 version and will continue to working on it. 

The changes already made and those to be made are listed in my another email to the working group. Your suggestions on any further improvements are always welcomed. Thank you! 

Best regards, 
Shuping  

> From: v6ops [mailto:[email-masked]] On Behalf Of Nick Hilliard
> Sent: Tuesday, October 12, 2021 4:55 AM
> To: [email-masked]
> Subject: Re: [v6ops] I-D Action: draft-ietf-v6ops-hbh-00.txt
> 
> Section 1: there is nothing in this section which isn't already said in rfc9098.
> 
> forwarding plane interaction, but then changes to a general discussion about
> HBH, most of which is repetition of other ietf documents.
> 
> It states a list of aspirations for HBH processing that, if anything, belong to a
> standards track document, but they're difficult to mandate in a standards
> document for reasons which have already been discussed at some length in
> the draft-hinden-6man-hbh-processing discussion.
> 
> Once this is done, there's not much left in this draft, and what's left is either
> not relevant to the core of the document (detailed discussion of forwarding
> hardware mechanisms) or else has been restated in other drafts, e.g.
> draft-hinden-6man-hbh-processing, or else doesn't fit together in this
> document (section 2, 8).
> 
> Ideally people want general EHs (i.e. not just HBHs) to work a bit better - we
> all agree on that.  If this is the case, then
> Sorry if this review comes across as harsh, but there's been a good deal of
> discussion about several other documents on the v6ops mailing list recently,
> and it's just difficult to see what this document brings that is new.
> 
> Nick
>

---

From: Nick Hilliard <[email-masked]>
Date: Tue, 12 Oct 2021 15:13:36 +0100

Pengshuping (Peng Shuping) wrote on 12/10/2021 02:01:
> As people suggested, this draft is positioned as a problem statement
> draft on the issues of the HBH options header only.
ok, and this is the point I'm making: we already have a problem 
statement which covers HBH issues - RFC9098, along with an attempted fix 
which is specific to HBH: draft-hinden-6man-hbh-processing.

Nick

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 15 Oct 2021 18:56:57 -0400

Hi Nick

The goal of RFC  9098 from a IPv6 operations and security perspective is to
shed light on the issues surrounding all extension headers generalization
as due to the pervasive  Christmas tree issue with excessive header
chaining to issues related to processing of headers in the slow path.

Out of all the headers the one and only that has been historically the most
problematic is HBH and has resulted in operators filtering HBH to avoid
possible DDOS attack vector.

This draft hones in on HBH as it is the most problematic but it is also one
of the most useful for developers to build tools for operators toolbox.

This document also provides  a path forward to make HBH usable and it’s
viability for future development of new features that can be extremely
beneficial to  the internet community.

Kind Regards

Gyan

-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*