Subject: [v6ops] Which IPv4aaS mechanisms should CE routers implement first?

From: Lorenzo Colitti <[email-masked]>
Date: Wed, 24 Nov 2021 11:25:51 +0900

Hi all,

Is there any data on what IPv4aaS transition mechanisms are deployed by
ISPs today? I was approached by a router vendor asking me "how they should
provide IPv6-only" and I was looking for data on which mechanisms are most
common.

Official IETF guidance in RFC 8585 and 8026 is "do all of them and let ISPs
decide, have a nice day", but that's not very helpful to a development team
with finite engineering resources and low margins. In particular, it's not
helpful to vendors of routers that are updatable and that can thus credibly
claim that they can deliver other mechanisms via software update. Those
vendors could reasonably argue that it's better for everyone if they launch
the most common mechanism(s) first, and then deliver the others in software
updates.

It seems like reasonable implementation guidance would be to request
OPTION_S46_PRIORITY and parse it, but only initially implement one or two
of the mechanisms and leave the others for a future release. If a router
did this, what mechanisms should it implement first? MAP-E?

Cheers,
Lorenzo

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 24 Nov 2021 08:37:56 +0100

If you count cellular, clearly the winner is 464XLAT (there are several ISPs that offer mobile broadband), in terms of number of subscribers using it vs all the other transition technologies added together.

Otherwise, DS-Lite is probably the one that has been implemented mostly because the other ones didn’t exist at that time. I’m not seeing a big penetration of MAP-T/E neither lw4o6.

Also take a look at:

https://datatracker.ietf.org/doc/draft-ietf-v6ops-transition-comparison/

Regards,

Jordi

@jordipalet

El 24/11/21 3:26, "v6ops en nombre de Lorenzo Colitti" <[email-masked] en nombre de lorenzo=[email-masked]> escribió:

Hi all,

Is there any data on what IPv4aaS transition mechanisms are deployed by ISPs today? I was approached by a router vendor asking me "how they should provide IPv6-only" and I was looking for data on which mechanisms are most common.

Official IETF guidance in RFC 8585 and 8026 is "do all of them and let ISPs decide, have a nice day", but that's not very helpful to a development team with finite engineering resources and low margins. In particular, it's not helpful to vendors of routers that are updatable and that can thus credibly claim that they can deliver other mechanisms via software update. Those vendors could reasonably argue that it's better for everyone if they launch the most common mechanism(s) first, and then deliver the others in software updates.

It seems like reasonable implementation guidance would be to request OPTION_S46_PRIORITY and parse it, but only initially implement one or two of the mechanisms and leave the others for a future release. If a router did this, what mechanisms should it implement first? MAP-E?

Cheers,

Lorenzo

_______________________________________________ v6ops mailing list [email-masked] https://www.ietf.org/mailman/listinfo/v6ops 

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Ole Troan <[email-masked]>
Date: Wed, 24 Nov 2021 09:03:20 +0100

> On 24 Nov 2021, at 03:26, Lorenzo Colitti <lorenzo=[email-masked]> wrote:
> 
> Is there any data on what IPv4aaS transition mechanisms are deployed by ISPs today? I was approached by a router vendor asking me "how they should provide IPv6-only" and I was looking for data on which mechanisms are most common

IPv4aaS != IPv6 only. 

I doubt you will get an answer here. This is a bike shedding argument as good as any. 

They should check out what’s deployed in their target market. Just like any other feature. 

O.

---

From: Vasilenko Eduard <[email-masked]>
Date: Wed, 24 Nov 2021 10:24:56 +0000

Hi Lorenzo,
A few facts:

464XLAT is the must in MBB just because Android and iOS do not support the other 4 mechanisms. Nothing to discuss.

FBB effectively has the choice from DS-Lite->MAP->464XLAT.
DS-Lite because it is supported by the majority of CPEs. MAP because it is the best technically. 464XLAT because it has synergy with Mobile but typically Carrier’s MBB and FBB departments are different with different budgets.

1.       Lw4o6 has a very limited number of deployments.

2.       RFC 8585 is not very old (May 2019). Basement RFC 7084 did not request anything, except DS-Lite. Hence, the majority of FBB CPEs do not support anything else because Retail did follow RFC 7084 only.
Lee Howard has published it here https://mailarchive.ietf.org/arch/msg/v6ops/OAoush6gNQYv1gkPVGmUdUCWgBQ/. It has the reference to Excel on GoogleDoc. DS-lite was leading FBB in 2017 that is predictable.
DS-Lite market share is the biggest but should only decline in %.

3.       MAP-E/T needs mapping IPv4:port_range to IPv6 which results in the requirement of the limited number of big blocks (not XY of /24). It is a luxury for many Carriers. MAP is not much bigger than Lw4o6, but it has the potential because of technical advantages.
The excel would give you the split for 2017. I do not know the exact split between these 3 for now.

Eduard
From: v6ops [mailto:[email-masked]] On Behalf Of Lorenzo Colitti
Sent: Wednesday, November 24, 2021 5:26 AM
To: [email-masked] WG <[email-masked]>
Subject: [v6ops] Which IPv4aaS mechanisms should CE routers implement first?

Hi all,

Cheers,
Lorenzo

---

From: Paolo Volpato <[email-masked]>
Date: Wed, 24 Nov 2021 11:03:05 +0000

Hi Lorenzo,

In addition to what others have already shared, you may want to take a look at https://datatracker.ietf.org/doc/draft-ietf-v6ops-ipv6-deployment/.
We shared some statistics about the adoption of transition technologies in wireless and wireline networks.
For the former, it has been already shared that 464XLAT is the mechanism commonly adopted.
In wireline, DS-Lite is preferred, with a few operators using other technologies such as 6rd or others.

Best regards
Paolo

From: v6ops <[email-masked]> On Behalf Of Lorenzo Colitti
Sent: Wednesday, November 24, 2021 3:26 AM
To: [email-masked] WG <[email-masked]>
Subject: [v6ops] Which IPv4aaS mechanisms should CE routers implement first?

Hi all,

Cheers,
Lorenzo

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 24 Nov 2021 12:22:26 +0100

'IPv4aaS' in the subject line and 'IPv6-only' in the original vendor's 
question... hmmm... please clarify what is meant?

These two things are very different.

If the vendor wants to do something about providing only IPv6 to 
in-residence network is a different intention than wanting to do 
something about providing IPv4 as a service on that IPv6.

Le 24/11/2021 à 03:25, Lorenzo Colitti a écrit :
> ISPs today? I was approached by a router vendor asking me "how they 
> should provide IPv6-only"

One of the feedback should be to advise the ISP to run a DHCPv6-PD 
server in the CPE.

My ISP CPE still does IPv6 static routes in the CPE towards the 
in-residence subnets, which is difficult to type each time.

Alex

  and I was looking for data on which mechanisms
> are most common.
> 
> Official IETF guidance in RFC 8585 and 8026 is "do all of them and let 
> ISPs decide, have a nice day", but that's not very helpful to a 
> development team with finite engineering resources and low margins. In 
> particular, it's not helpful to vendors of routers that are updatable 
> and that can thus credibly claim that they can deliver other mechanisms 
> via software update. Those vendors could reasonably argue that it's 
> better for everyone if they launch the most common mechanism(s) first, 
> and then deliver the others in software updates.
> 
> OPTION_S46_PRIORITY and parse it, but only initially implement one or 
> two of the mechanisms and leave the others for a future release. If a 
> router did this, what mechanisms should it implement first? MAP-E?
> 
> Cheers,
> Lorenzo
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 24 Nov 2021 12:24:01 +0100

>> Is there any data on what IPv4aaS transition mechanisms are deployed by ISPs today? I was approached by a router vendor asking me "how they should provide IPv6-only" and I was looking for data on…

I agree.

If I were an ISP and wanted to give an 'IPv6-only' connection to an 
in-residence network then I would just put IPv6 on it, not IPv4. 
Further, one might even block any form of IPv4 traffic be that native or 
carried in IPv6 packets.

This is why it is important to know what do they mean by 'IPv6-only'.

Alex

---

From: Ca By <[email-masked]>
Date: Wed, 24 Nov 2021 09:04:57 -0500

On Wed, Nov 24, 2021 at 5:25 AM Vasilenko Eduard <vasilenko.eduard=
[email-masked]> wrote:

> DS-Lite because it is supported by the majority of CPEs. MAP because it is
> the best technically. 464XLAT because it has synergy with Mobile but
> typically Carrier’s MBB and FBB departments are different with different
> budgets.
>
> 2.       RFC 8585 is not very old (May 2019). Basement RFC 7084 did not
> request anything, except DS-Lite. Hence, the majority of FBB CPEs do not
> support anything else because Retail did follow RFC 7084 only.
> Lee Howard has published it here
> https://mailarchive.ietf.org/arch/msg/v6ops/OAoush6gNQYv1gkPVGmUdUCWgBQ/.
> It has the reference to Excel on GoogleDoc. DS-lite was leading FBB in 2017
> that is predictable.
> 3.       MAP-E/T needs mapping IPv4:port_range to IPv6 which results in
> the requirement of the limited number of big blocks (not XY of /24). It is
> a luxury for many Carriers. MAP is not much bigger than Lw4o6, but it has
> the potential because of technical advantages.
>
Related to MAP deployment issues and lessons learned

https://ripe82.ripe.net/wp-content/uploads/presentations/78-ripe82-yanodd-mape.pdf

>
> Eduard
>
> *From:* v6ops [mailto:[email-masked]] *On Behalf Of *Lorenzo
> Colitti
> *Sent:* Wednesday, November 24, 2021 5:26 AM
> *To:* [email-masked] WG <[email-masked]>
> *Subject:* [v6ops] Which IPv4aaS mechanisms should CE routers implement
> first?
>
>
>
> Hi all,
>
>
>
> ISPs decide, have a nice day", but that's not very helpful to a development
> team with finite engineering resources and low margins. In particular, it's
> not helpful to vendors of routers that are updatable and that can thus
> credibly claim that they can deliver other mechanisms via software update.
> Those vendors could reasonably argue that it's better for everyone if they
> launch the most common mechanism(s) first, and then deliver the others in
> software updates.
>
>
>

---

From: Vasilenko Eduard <[email-masked]>
Date: Wed, 24 Nov 2021 14:24:41 +0000

The best MAP use case that I have seen (really rich in technical details) was from Richard Patterson
after Sky did green-field implementation for Italy.
He did it in many please (you could google), I like this version: https://www.ripe.net/participate/meetings/open-house/ripe-ncc-open-house-ipv6-only-networks from 00:37 to 1:09
Ed/
From: Ca By [mailto:[email-masked]]
Sent: Wednesday, November 24, 2021 5:05 PM
To: Vasilenko Eduard <[email-masked]>
Cc: Lorenzo Colitti <[email-masked]>; [email-masked] WG <[email-masked]>
Subject: Re: [v6ops] Which IPv4aaS mechanisms should CE routers implement first?

On Wed, Nov 24, 2021 at 5:25 AM Vasilenko Eduard <vasilenko.eduard=[email-masked]<mailto:[email-masked]>> wrote:
Hi Lorenzo,
A few facts:

Eduard
From: v6ops [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Lorenzo Colitti
Sent: Wednesday, November 24, 2021 5:26 AM
To: [email-masked]<mailto:[email-masked]> WG <[email-masked]<mailto:[email-masked]>>
Subject: [v6ops] Which IPv4aaS mechanisms should CE routers implement first?

Hi all,

Cheers,
Lorenzo
_______________________________________________
v6ops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/v6ops

---

From: Richard Patterson <[email-masked]>
Date: Wed, 24 Nov 2021 17:18:28 +0000

On Wed, 24 Nov 2021 at 14:25, Vasilenko Eduard <vasilenko.eduard=
[email-masked]> wrote:

> He did it in many please (you could google), I like this version:
> https://www.ripe.net/participate/meetings/open-house/ripe-ncc-open-house-ipv6-only-networks
> from 00:37 to 1:09
>
> Ed/
>
>
>
Thanks!

A little update on that, MAP-T is now default-on for all new customers of
Sky Italia, and we've migrated about 95% of existing ones.
The stragglers are those with 3rd party CPEs, who we have now proactively
sent communications to informing them of their impending migration before
the end of the year.  The biggest issue is indeed lack of 3rd party CPE
support, their only real other option is OpenWRT currently.

The Italian regulators have a "Modem Libero" policy that prevents operators
locking customers into a particular CPE, so it would be great to see
additional options become available. (If any CPE vendors want to reach out
to me, I'd be happy to help discuss the requirements and offer up some
inter-op testing)

-Rich

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 24 Nov 2021 18:21:25 +0100

Should we make RFC8585 a “must”?

I think is time to take stronger positions from IETF.

El 24/11/21 18:19, "v6ops en nombre de Richard Patterson" <[email-masked] en nombre de [email-masked]> escribió:

On Wed, 24 Nov 2021 at 14:25, Vasilenko Eduard <vasilenko.eduard=[email-masked]> wrote:

Ed/

Thanks! 

A little update on that, MAP-T is now default-on for all new customers of Sky Italia, and we've migrated about 95% of existing ones.

The stragglers are those with 3rd party CPEs, who we have now proactively sent communications to informing them of their impending migration before the end of the year.  The biggest issue is indeed lack of 3rd party CPE support, their only real other option is OpenWRT currently.

The Italian regulators have a "Modem Libero" policy that prevents operators locking customers into a particular CPE, so it would be great to see additional options become available. (If any CPE vendors want to reach out to me, I'd be happy to help discuss the requirements and offer up some inter-op testing)

-Rich

---

From: Xipengxiao <[email-masked]>
Date: Wed, 24 Nov 2021 17:31:24 +0000

Not sure if my opinion counts, but I support Jordi’s proposal :-)

XiPeng

From: v6ops <[email-masked]> On Behalf Of JORDI PALET MARTINEZ
Sent: Wednesday, November 24, 2021 6:21 PM
To: [email-masked] WG <[email-masked]>
Subject: Re: [v6ops] Which IPv4aaS mechanisms should CE routers implement first?

El 24/11/21 18:19, "v6ops en nombre de Richard Patterson" <[email-masked]<mailto:[email-masked]> en nombre de [email-masked]<mailto:[email-masked]>> escribió:

On Wed, 24 Nov 2021 at 14:25, Vasilenko Eduard <vasilenko.eduard=[email-masked]<mailto:[email-masked]>> wrote:
The best MAP use case that I have seen (really rich in technical details) was from Richard Patterson
after Sky did green-field implementation for Italy.
He did it in many please (you could google), I like this version: https://www.ripe.net/participate/meetings/open-house/ripe-ncc-open-house-ipv6-only-networks from 00:37 to 1:09
Ed/

Thanks!

-Rich

_______________________________________________ v6ops mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Vasilenko Eduard <[email-masked]>
Date: Wed, 24 Nov 2021 17:47:07 +0000

How exactly to do it?
Update RFC 7084? (merge RFC 8585 with RFC 7084)
Or rewrite 8585 as a “standard”? (it is “informational” now)

IMHO: 7084bis is better. Less number of documents.

Eduard
From: v6ops [mailto:[email-masked]] On Behalf Of JORDI PALET MARTINEZ
Sent: Wednesday, November 24, 2021 8:21 PM
To: [email-masked] WG <[email-masked]>
Subject: Re: [v6ops] Which IPv4aaS mechanisms should CE routers implement first?

Thanks!

-Rich

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 24 Nov 2021 18:50:33 +0100

Originally, when I started working on this a few years ago, I tried the RFC7084bis way … but even if initially was supported by the WG, finally the original authors didn’t agree.

So, I think that now it may be easier to “update” RFC8585 to be STD, but I’m not sure if the chairs and AD can suggest something else.

Regards,

Jordi

@jordipalet

El 24/11/21 18:47, "v6ops en nombre de Vasilenko Eduard" <[email-masked] en nombre de vasilenko.eduard=[email-masked]> escribió:

How exactly to do it?

Eduard

 

Ed/

Thanks! 

-Rich