Subject: [VCARDDAV] proper datum/reference system for GEO property

From: "Alexander Mayrhofer" <[email-masked]>
Date: Tue, 26 Feb 2008 17:26:49 +0100

Hi,

I've been looking at the definition of the "GEO" property in
draft-resnick-vcarddav-vcardrev-01. The current specification does not
clarify which datum and reference system is to be used for data in the
GEO property, which is really bad, and can lead to errors up to several
hundred meters (depending on which reference system is used).

I'd suggest clarifying that by adding something like "Coordinates used
in the GEO property MUST use the WGS 84 datum and reference system".
(WGS84 is the most common one, and also used in GPS devices).

cheers

Alex
_______________________________________________
VCARDDAV mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/vcarddav

---

From: Simon Perreault <[email-masked]>
Date: Tue, 26 Feb 2008 11:39:40 -0500

> (WGS84 is the most common one, and also used in GPS devices).

I know absolutely nothing about geographic reference systems. But I see on 
http://en.wikipedia.org/wiki/WGS84 that WGS 84 is supposed to expire in 2010. 
That seems very soon! Can we reword that somehow so that it includes future 
revisions of WGS 84?

Also, would it be better to use a parameter to name explicitly the reference 
system used?

An aside question: when I enter coordinates in Google Maps or whatever, does 
it implicitly interpret them as WGS 84? Because I have a feeling the 
coordinates in vCard better be compatibe with those kind of web sites. ;)
_______________________________________________
VCARDDAV mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/vcarddav

---

From: "Alexander Mayrhofer" <[email-masked]>
Date: Tue, 26 Feb 2008 17:54:59 +0100

> That seems very soon! Can we reword that somehow so that it 
> includes future revisions of WGS 84?

Hmm... i'd be a little hesitant in this case to believe wikipedia. I don't think that my GPS will stop working in 2010. There's a new, more precise earth geopotential model "EGM96", but from what i know it's not a "full" reference system. Anyway, i'm not an expert in reference systems, too, but the GEOPRIV people might be able to help out on this one. Most specifications in the GEOPRIV WG use WGS84.
 
> Also, would it be better to use a parameter to name 
> explicitly the reference system used?

The questions is whether you want to bother/confuse users with this. WGS84 is pretty predominant now, and i guesstimate that about 99% of coordinates you'd see somewhere are in WGS84. 

Since most of the vCards would probably be read by users, it might be better to _not_ confuse them with an additional sub-property.. but that's just my 0.02€

> An aside question: when I enter coordinates in Google Maps or 
> whatever, does it implicitly interpret them as WGS 84? 

Yes, they do (at least according to my tests - i can't find a reference in the documentation right now).

> Because I have a feeling the coordinates in vCard better be 
> compatibe with those kind of web sites. ;) 

Exactly. Make it as user friendly as possible. 

<shameless_plug>
Talking of "user friendly": I've written a draft which proposes a URI scheme and a tiling hierarchy to identify geographic locations: http://tools.ietf.org/id/draft-mayrhofer-geo-uri-02.txt (demo at http://nona.net/tool/geouri/) 
</shameless_plug>

cheers

Alex

---

From: Simon Perreault <[email-masked]>
Date: Tue, 26 Feb 2008 12:04:21 -0500

On Tuesday 26 February 2008 11:54:59 Alexander Mayrhofer wrote:
> The questions is whether you want to bother/confuse users with this. WGS84
> is pretty predominant now, and i guesstimate that about 99% of coordinates
> you'd see somewhere are in WGS84.

Good. I hoped it was this way. I too would prefer not to add a parameter 
needlessly.

> Talking of "user friendly": I've written a draft which proposes a URI
> scheme and a tiling hierarchy to identify geographic locations:
> http://tools.ietf.org/id/draft-mayrhofer-geo-uri-02.txt (demo at
> http://nona.net/tool/geouri/) </shameless_plug>

Neat! I'm at geo:EXZTL3TAR!
_______________________________________________
VCARDDAV mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/vcarddav

---

From: "Alexander Mayrhofer" <[email-masked]>
Date: Tue, 26 Feb 2008 18:32:05 +0100

> Neat! I'm at geo:EXZTL3TAR!

Which reminds me that i need to do the decoding part, too :)

cheers

Alex