Subject: Re: [VCARDDAV] VCARDDAV Digest, Vol 12, Issue 52

From: Jean-Luc Schellens <[email-masked]>
Date: Thu, 21 Aug 2008 16:02:26 +0200

>   1.  Content-type parameter (Cyrus Daboo)
>
>
> Content-Type:text/calendar;component=vevent
>
> For vCard, I think it would make sense to have an optional parameter  
> "kind"
> that reflects the value of the KIND property in the vCard data. That  
> way
> clients can adjust their display of a vcard object simply by  
> examining the
> content-type (e.g. show a single user icon for the "individual"  
> kind, or a
> multi-user icon for group etc). e.g.:
>
> Content-Type:text/vcard;kind=group
>
> Whilst it is not required to have this parameter, CardDAV servers  
> could
> easily determine what value it ought to be and make sure it appears
> correctly in the appropriate WebDAV property, to aid clients.
>
> -- 
> Cyrus Daboo

Hello Cyrus,
In my first e-mail, I noticed:

2 KIND: really key and very useful but if KIND replaces GROUP (see
14), would it still be possible to have a hierarchy like PARENT GROUP
in the Mac Address Book?
8 MEMBER & RELATED would be clarified. For me RELATED is more a MEMBER
value!
9 CATEGORIES has to be clarified. As described, it looks like a mean
to define the activities of an organization and that is fine. But the
Mac Address Book uses CATEGORIES to export the 'GROUPS' in vCard 3.0!
(see my question about GROUP) --> rather ACTIVITIES or SECTOR as
property name
14 Why 'GROUP' is removed? No more hierarchy with 'PARENT GROUP' like
the Mac AB!

Now I'm more deeply confused with the requirements above!
For me, thanks to the MEMBER/RELATED properties, a vCard can link  
together different vCards, e.g. members of the same department/unit or  
my manager and my assistant.
But you can also join together different vCards in permanent or  
temporarily 'groups/categories' (to speak like Mac AB or Outlook) e.g.  
'My colleagues' or a project team or a distribution list!

So I would like to have more examples about the possibles values of  
KIND!
I'm still in trouble with 'group' being a KIND!?!
Regards,
Jean-Luc

_______________________________________________
VCARDDAV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vcarddav

---

From: Simon Perreault <[email-masked]>
Date: Thu, 21 Aug 2008 10:27:58 -0400

Jean-Luc Schellens wrote:
> So I would like to have more examples about the possibles values of KIND!

Did you take a look at the examples in section 7.6.6? If so, what
exactly do you find confusing?

-- 
Please try Numb, a STUN/TURN server implementation.
Free access at http://numb.viagenie.ca/.
_______________________________________________
VCARDDAV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vcarddav