Subject: Re: [VCARDDAV] VCARDDAV Digest, Vol 12, Issue 29

From: Jean-Luc Schellens <[email-masked]>
Date: Tue, 5 Aug 2008 16:17:13 +0200

>   1. Re:  VCARDDAV Digest, Vol 12, Issue 23 (Simon Perreault)
>
> Jean-Luc Schellens wrote:
>>> Just understand that there is no "meaning" associated with  
>>> particular q
>>> values. It's just a way to order languages by preference.
>>
>> Does it mean that we are free to define the meanings?
>
> You mean in the spec or in your head?

Indeed my head being my application!

>
>
>>> I'm sorry I still don't understand.
>>>
>>> - REV cannot have the PID parameter because it's a single-instance- 
>>> only
>>> property.

For me, REV HAS to be a multi-instance property

>>>
>>> - What does the TYPE mean?

TYPE will have 3 values: created, updated, deleted

>>>
>>
>> For me, data quality and synchronization are key! As you probably  
>> know,
>> Outlook is still a nightmare for the CRM solutions (except for  
>> Microsoft
>> ;o)) and for the mobile platforms (except Windows Mobile ;o))
>>
>> So for me, REV HAS to be a multi-value property and TYPE will have 3
>> values: created, updated or deleted.
>
> I still don't understand. Could you answer my two questions above
> directly please?

Regards
Jean-Luc
_______________________________________________
VCARDDAV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vcarddav

---

From: Simon Perreault <[email-masked]>
Date: Tue, 05 Aug 2008 11:45:16 -0500

Jean-Luc Schellens wrote:
>>>> Just understand that there is no "meaning" associated with particular q

Well you're obviously free to think of q values any way you want.

>>>> - REV cannot have the PID parameter because it's a single-instance-only
>>>> property.
> 

Can you say why?

> TYPE will have 3 values: created, updated, deleted

What would they mean?

-- 
Please try Numb, a STUN/TURN server implementation.
Free access at http://numb.viagenie.ca/.
_______________________________________________
VCARDDAV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vcarddav

---

From: "Javier Godoy" <[email-masked]>
Date: Tue, 5 Aug 2008 13:44:24 -0300

Jean-Luc Schellens wrote:

>>>> - REV cannot have the PID parameter because it's a single-instance- only
>>>> property.
>

I think it may be useful to some sychronization engines, while others 
(concerned with "simple devices" not mantaining such properties) will develop 
alternative mechanisms.
Note that giving 3 dates for each property implies too much overhead.

Besides, the current proposal is defining some basic parameters, and leave the 
details to the sync engine. For instance, and implementation could define 
extension properties for creation, deletion and modification dates; it would 
be something like:

EMAIL;PID:1;vnd-foobar-created:20080801T0015Z;vnd-foobar-updated:20080805T1639Z:[email-masked]

Best Regards

Javier