Subject: Re: [VCARDDAV] VCARDDAV Digest, Vol 12, Issue 59

From: Jean-Luc Schellens <[email-masked]>
Date: Thu, 21 Aug 2008 18:06:29 +0200

>   1. Re:  VCARDDAV Digest, Vol 12, Issue 52 (Simon Perreault)
>
> Jean-Luc Schellens wrote:
>> So I would like to have more examples about the possibles values of  
>> KIND!
>> I'm still in trouble with 'group' being a KIND!?!
>
> Did you take a look at the examples in section 7.6.6? If so, what
> exactly do you find confusing?
>
Of course and that's why I'm confused!
The first example is a vCard linking two members (I guess married) in  
a permanent group (I hope) I will communicate to other contacts.
The second is a distribution list which is temporary group I created  
in my address book for personal purposes (sending emails/mails) but  
I'm not necessarily intended to communicate to my contacts.
For me they are different groups!
Regards,
Jean-Luc
_______________________________________________
VCARDDAV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vcarddav

---

From: Cyrus Daboo <[email-masked]>
Date: Thu, 21 Aug 2008 12:22:34 -0400

Hi Jean-Luc,

--On August 21, 2008 6:06:29 PM +0200 Jean-Luc Schellens 
<[email-masked]> wrote:

> The first example is a vCard linking two members (I guess married) in a
> permanent group (I hope) I will communicate to other contacts.
> The second is a distribution list which is temporary group I created in
> my address book for personal purposes (sending emails/mails) but I'm not
> necessarily intended to communicate to my contacts.

Why not use CLASS:PRIVATE on the temporary group vCard. We should probably 
make a better stipulation in the spec as to what is expected with each type 
of CLASS (e.g. clients MUST NOT "export" PRIVATE vCards). CLASS in 
iCalendar is very poorly specified in terms of what should really happen. 
It would be good to be more specific about the different CLASS values in 
vCard 4.0 if we can.

-- 
Cyrus Daboo