Subject: Re: [VCARDDAV] VCARDDAV Digest, Vol 12, Issue 24

From: Jean-Luc Schellens <[email-masked]>
Date: Tue, 5 Aug 2008 16:09:26 +0200

>   1. Re:  VCARDDAV Digest, Vol 12, Issue 8 (Simon Perreault)
>
> Keep in mind that N is based on the X.520 standard. Nickname is not  
> part
> of that.
>
> Also, it is fairly common to have multiple nicknames while still  
> having
> only one name.

OK but you're rarely proud enough to put it on a card ;o)))

>
>> I would like to have a creation/incorporation date for an  
>> organization,
>> a start and en date for an holiday address, etc.
>
> I think that would be better handled by an extension RFC.

Probably but what's the way? Because DATE is a critical property!

>> Your answer is confusing for me! What's the difference then with  
>> KIND??
>
> KIND has predefined values that have semantic meaning.

Predefined values? 'individual', 'group', 'org' only or are we free to  
define others, in vCard 4 or in our applications?

> CATEGORIES has no predefined values. Users are free to create the
> categories they want. It's just a way of tagging vCards.

To group the cards of your family, friends, colleagues ?

>> For me, a person, an organization or a group do not have a GEO and  
>> a TZ.
>> It is totally linked to a street address!
>
> I think you're right. If there is an elegant way to fix this, we  
> should
> do it. Would you have some text to propose?

Being lazy, I suggest to bring 7.5 into 7.3
TZ becomes 7.3.3 and GEO 7.3.4 ;o))

>>>> 4 KEY would be a communications property associated with an email
>>>> address
>>>
>>> I don't quite understand what you mean.
>>
>> For me a public key and certificate is linked to an email address and
>> not to a person, an organization or a group.
>
> In this case I disagree. For example I have a single public key that  
> is
> bound to multiple email addresses. I also use it to sign documents  
> that
> are not sent by email. It's my personal key, not my email's key.

OK accepted!
Regards,
Jean-Luc
_______________________________________________
VCARDDAV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vcarddav

---

From: "Javier Godoy" <[email-masked]>
Date: Tue, 5 Aug 2008 13:36:15 -0300

Jean-Luc Schellens wrote:

>>> I would like to have a creation/incorporation date for an  organization,

See section 12.1.  Registering New vCard Elements, particularly 12.1.3. 
Registration Template for Properties.

>>> Your answer is confusing for me! What's the difference then with  KIND??
>>

You are. See section 12.1.6.  Registration Template for Values.

BTW, I think there should be an initialization table for the IANA mantained 
registry of values (Section 12.1 defines registration templates for 
properties, parameters, data types and values, but Section 12.2 only gives 
initialization tables for properties, parameters and data types).

Best Regards

Javier