Subject: Re: [VCARDDAV] VCARDDAV Digest, Vol 12, Issue 7

From: Jean-Luc Schellens <[email-masked]>
Date: Tue, 5 Aug 2008 08:27:23 +0200

> Javier Godoy wrote:
>> Is there any advantage in providing that separation in the N  
>> property?
>> IMHO is already clear that ?van der Harten? is the last name and it
>> collates as "Harten".
>
> For sorting purposes see the SORT-STRING property. "van der Harten" is
> even given in that example!
>
>         FN:Rene van der Harten
>         N:van der Harten;Rene;J.;Sir;R.D.O.N.
>         SORT-STRING:Harten

How do you know that you have to take 'Harten' and not 'der'?
Is it based on the first capital? Then what if the name is in full caps?
e.g. ''VAN DER MERSCH' or 'van der Mersch' or 'Van der Mersch' (maiden  
name of my wife ;o)
How are you doing the sort?

>
> -- 
> Please try Numb, a STUN/TURN server implementation.
> Free access at http://numb.viagenie.ca/.
>
>
> ------------------------------
>
> _______________________________________________
> VCARDDAV mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/vcarddav
>
>
> End of VCARDDAV Digest, Vol 12, Issue 7
> ***************************************

_______________________________________________
VCARDDAV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vcarddav

---

From: "Javier Godoy" <[email-masked]>
Date: Tue, 5 Aug 2008 03:59:59 -0300

Jean-Luc Schellens wrote:

>> Javier Godoy wrote:
>>> Is there any advantage in providing that separation in the N  property?

Because the value of SORT-STRING is "Harten" and not "der".

[[ The sort string is used to provide family name or given name text that is 
to be used in locale- or national- language-specific sorting of the formatted 
name and structured
      name types. (...)   When this property is present in a vCard, then this 
family name or given name value is used for sorting the vCard. ]] (Section 
7.7.5)

Note this propery is not bound to the family name. For instance 
"SORT-STRING:Rene" specifies sorting by first-name, and "SORT-STRING:xyz" 
specifies sorting by other criteria.

> e.g. ''VAN DER MERSCH' or 'van der Mersch' or 'Van der Mersch' (maiden  name 
> of my wife ;o)

It is based on the SORT-STRING value (when provided) and based on 
application-specific heuristics otherwise.
The SORT-STRING is specified *in addition to* N and FN. Then all of the 
following examples are equivalent to the sorting algorithm:

N:VAN DER MERSCH;;;;
SORT-STRING:Mersch

N:Van Der Mersch;;;;
SORT-STRING:Mersch

N:van der mersch;;;;
SORT-STRING:Mersch

About your comment, I understand you were proposing writing the N propery as 
"N:van der; Mersch;;;;"
I'm not sure it is a good idea because the "family name prefix" is considered 
part of the family name in some cultures (biased opinion), and there are only 
variations when sorting those prefixed family names.

Best Regards

Javier