Subject: Re: [VCARDDAV] VCARDDAV Digest, Vol 12, Issue 8

From: Jean-Luc Schellens <[email-masked]>
Date: Tue, 5 Aug 2008 09:18:41 +0200

>   1. Re:  Some remarks bout the vCard 4.0/0.3 (Simon Perreault)
>
> Jean-Luc Schellens wrote:
>> Please find below some remarks and comments about the last vCard  
>> 4.0 specs
>
> I agree with Javier's comments. Here are some of my own.
>
>> 1 NAME vs. FN: excellent but the specific characteristics and  
>> purposes
>> have to be clarified
>
> Do you have text to propose?

I will try to write a text

>
>> 4 NICKNAME could be a value of N
>
> What would be the advantage of that?

Just because I don't understand why you have a property for NICKNAME  
and not for e.g. middle name or honorific title

>
>
>> 5 BDAY/DDAY seem to be limited. I would like to define Start/End  
>> dates,
>> Move In/Out...
>
> You mean like a birth that spans several days? Please explain.

I would like to have a creation/incorporation date for an  
organization, a start and en date for an holiday address, etc.

>
>
>> 9 CATEGORIES has to be clarified. As described, it looks like a  
>> mean to
>> define the activities of an organization and that is fine. But the  
>> Mac
>> Address Book uses CATEGORIES to export the ?GROUPS? in vCard 3.0!  
>> (see
>> my question about GROUP) --> rather ACTIVITIES or SECTOR as  
>> property name
>
> Do you have text to propose?
>
> Note that CATEGORIES really is a way to specify the categories, or
> groups, that a given vCard belongs to.

Your answer is confusing for me! What's the difference then with KIND??

>
>
>> 11 SORT-STRING would be based on the ?last name prefix? type for the
>> ?aristocratic? sorting like in the ?van der Harten? example.
>
> What if you want to sort on something else?

See my other response sent today

>
>
>> 1 GEO and TZ would be Delivery Addressing properties related to a  
>> street
>> address
>
> Could you be more specific? I don't understand what you're suggesting.

For me, a person, an organization or a group do not have a GEO and a  
TZ. It is totally linked to a street address!

>
>> 3 CLASS would be a general property for ?privacy? purposes --> rather
>> PRIVACY as property name
>
> Let's not change property names and preserve backward compatibility.

Pity!

>
>> 4 KEY would be a communications property associated with an email  
>> address
>
> I don't quite understand what you mean.

For me a public key and certificate is linked to an email address and  
not to a person, an organization or a group.

Regards
Jean-Luc
_______________________________________________
VCARDDAV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vcarddav

---

From: Andy Mabbett <[email-masked]>
Date: Tue, 5 Aug 2008 08:33:59 +0100

In message <[email-masked]>, Jean-Luc 
Schellens <[email-masked]> writes

>not to a person, an organization or a group.

+1

-- 
Andy Mabbett

---

From: Simon Perreault <[email-masked]>
Date: Tue, 05 Aug 2008 08:31:01 -0500

Jean-Luc Schellens wrote:
> Just because I don't understand why you have a property for NICKNAME and 
> not for e.g. middle name or honorific title

Keep in mind that N is based on the X.520 standard. Nickname is not part 
of that.

Also, it is fairly common to have multiple nicknames while still having 
only one name.

> I would like to have a creation/incorporation date for an organization, 
> a start and en date for an holiday address, etc.

I think that would be better handled by an extension RFC.

> Your answer is confusing for me! What's the difference then with KIND??

KIND has predefined values that have semantic meaning.

CATEGORIES has no predefined values. Users are free to create the 
categories they want. It's just a way of tagging vCards.

> For me, a person, an organization or a group do not have a GEO and a TZ. 
> It is totally linked to a street address!

I think you're right. If there is an elegant way to fix this, we should 
do it. Would you have some text to propose?

> not to a person, an organization or a group.

In this case I disagree. For example I have a single public key that is 
bound to multiple email addresses. I also use it to sign documents that 
are not sent by email. It's my personal key, not my email's key.

-- 
Please try Numb, a STUN/TURN server implementation.
Free access at http://numb.viagenie.ca/.
_______________________________________________
VCARDDAV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vcarddav

---

From: Andy Mabbett <[email-masked]>
Date: Tue, 5 Aug 2008 17:29:11 +0100

In message <[email-masked]>, Simon Perreault 
<[email-masked]> writes

>>  For me a public key and certificate is linked to an email address 
>>and  not to a person, an organization or a group.
>

Do we perhaps need to cater for both types of key, then?

---

From: "Javier Godoy" <[email-masked]>
Date: Tue, 5 Aug 2008 13:05:31 -0300

>> For me a public key and certificate is linked to an email address and not 
>> to a person, an organization or a group.
>
> bound to multiple email addresses. I also use it to sign documents that are 
> not sent by email. It's my personal key, not my email's key.

It depends on the key purpose. For instance, Verisign class 1 certificates are 
bound to mail address [1][2].

In my case, I have two keys obtained from Argentina's CA [3]. Each key is 
bound to a mail address. I cannot use these keys for signing legal documents, 
but it is enough for me since digital signatures are not implemented in my 
country.

Best Regards

Javier

[1] http://www.verisign.com/repository/ca-ra.html
[2] 
http://www.verisign.com/authentication/individual-authentication/digital-id/
[3] http://purl.net/net/es2en/ca.sgp.gov.ar/eMail/index-request.html

---

From: Simon Perreault <[email-masked]>
Date: Tue, 05 Aug 2008 11:39:43 -0500

> Do we perhaps need to cater for both types of key, then?

If you can think of a way to do it in a clean way, please propose text! :)