Subject: [VCARDDAV] Issue 385: What to do with PREF parameter

From: Simon Perreault <[email-masked]>
Date: Fri, 31 Oct 2008 09:01:48 -0400

Hello,

I would like to have your opinion on this unresolved issue: What do we
do with the PREF parameter?

1. Status quo.
2. Remove it.
  a. Ordering defines pref. (No two properties may have same pref level.)
  b. Ordering has no meaning.
3. Give it an int value. Most powerful solution.
  a. PREF without value is equivalent to PREF=1 (most preferred).
  b. PREF without value is disallowed.

Thanks,
Simon

-- 
Please try Numb, a STUN/TURN server implementation.
Free access at http://numb.viagenie.ca/.
_______________________________________________
VCARDDAV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vcarddav

---

From: Helge Hess <[email-masked]>
Date: Fri, 31 Oct 2008 14:30:03 +0100

> do with the PREF parameter?

+1

>  a. Ordering defines pref. (No two properties may have same pref  

+0.5

Like in XML files, element ordering should be preserved (not a must, a  
should would be ok).
However, ordering should have no meaning wrt preference.

>  b. PREF without value is disallowed.

Thanks,
   Helge
-- 
Helge Hess
http://zideone.com/