Subject: [VCARDDAV] CLASS values

From: Simon Perreault <[email-masked]>
Date: Fri, 31 Oct 2008 11:25:17 -0400

Hello,

Currently, the CLASS property values are not defined. Although the
associated example is the following, there is no agreed-upon set of values.

        CLASS:PUBLIC

        CLASS:PRIVATE

        CLASS:CONFIDENTIAL

Should we define values in core vCard 4?

If so, what do current implementations use?

Thanks,
Simon

-- 
Please try Numb, a STUN/TURN server implementation.
Free access at http://numb.viagenie.ca/.
_______________________________________________
VCARDDAV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vcarddav

---

From: Helge Hess <[email-masked]>
Date: Fri, 31 Oct 2008 16:31:00 +0100

> Should we define values in core vCard 4?

+1

> If so, what do current implementations use?

Outlook has (PR_SENSITIVITY):
- none     		(PUBLIC)
- personal 		(X-PERSONAL)
- private  		(PRIVATE)
- company-confidential	(CONFIDENTIAL)

Maybe it makes sense to add 'PERSONAL'?

Greets,
   Helge
-- 
Helge Hess
http://zideone.com/

---

From: Simon Perreault <[email-masked]>
Date: Fri, 31 Oct 2008 11:34:09 -0400

> associated example is the following, there is no agreed-upon set of values.

Hrmf... This is already being discussed... Carry on...

---

From: Simon Perreault <[email-masked]>
Date: Fri, 31 Oct 2008 11:50:29 -0400

> Maybe it makes sense to add 'PERSONAL'?

Earlier we had the following descriptions, which will be present in -04:

PRIVATE == MUST NOT be shared (they are only readable by its creator).
MAY be exported if explictly authorized and requested by the creator.
CONFIDENTIAL == may be shared with allowed users/systems (e.g. CardDAV +
RFC 3744). The exact confidentiality level is out of scope for the vCard
specification.
PUBLIC == may be shared with anyone (*).

What description could we give PERSONAL? I'm finding it hard to invent
something that makes sense...

---

From: Helge Hess <[email-masked]>
Date: Fri, 31 Oct 2008 17:41:53 +0100

> something that makes sense...

Good question. I would say its exactly like CONFIDENTIAL from an  
access control perspective, just with different semantics.

Thanks,
   Helge

---

From: Anil SRIVASTAVA <[email-masked]>
Date: Fri, 31 Oct 2008 11:28:23 -0700

+1

-- 
_______________
Anil SRIVASTAVA  |  [email-masked]  | Sun Microsystems, Inc
_______________________________________________
VCARDDAV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vcarddav