Subject: Re: [VCARDDAV] Some issues of draft 04 and 05

From: Simon Perreault <[email-masked]>
Date: Wed, 4 Feb 2009 14:01:13 -0500

On Monday 17 November 2008 13:30:56 Markus Lorenz wrote:
> The definition could look like this:
>
>    ; **** X- **** non-standard type
>    param        = x-bin-param / x-txt-param / pid-param
>
>    value        = x-bin-value / x-txt-value
>        ; Value and parameter MUST match
>
>    x-bin-param = ("ENCODING" = "b") / text-param
>
>    x-txt-param = text-param
>
>    x-bin-value = binary-value
>
>    x-txt-value = text-value-list

Thanks, I included it verbatim in -06.

-- 
Please try Numb, a STUN/TURN server implementation.
Free access at http://numb.viagenie.ca/.

---

From: <[email-masked]>
Date: Thu, 12 Feb 2009 09:28:01 +0100

Hi Simon,
I have a question as well on -05.

[quote]
6.3.1.  Extended MKCOL Method

   An HTTP request using the extended MKCOL method
   [I-D.ietf-vcarddav-webdav-mkcol] can be used to create a new address
   book collection resource.  A server MAY restrict address book
   collection creation to particular collections.
[/quote]

What is the purpose of the last sentence?
I feel that this is something that should be said in [I-D.ietf-vcarddav-webdav-mkcol] itself (where I could not find it).

Could we move it from this draft to [I-D.ietf-vcarddav-webdav-mkcol]?
Or, maybe make the "MAY" lowercase at least, so it becomes informative (and does not appear as if we want to clarify another specification here)?

Thank you.

Best regards: Zoltán Ördögh
E-mail: zoltan dot ordogh at nokia dot com
Phone: +358 50 386 0566

---

From: Julian Reschke <[email-masked]>
Date: Thu, 12 Feb 2009 09:50:06 +0100

> What is the purpose of the last sentence?

To say that a server does not need to support address books everywhere 
in its URI space?

> I feel that this is something that should be said in [I-D.ietf-vcarddav-webdav-mkcol] itself (where I could not find it).

I don't think it needs to be stated there, it's specific to address books.

> Or, maybe make the "MAY" lowercase at least, so it becomes informative (and does not appear as if we want to clarify another specification here)?

I think it is normative, and also belongs here. The restriction is on 
address books (semantics), not the method (protocol).

BR, Julian

---

From: <[email-masked]>
Date: Thu, 12 Feb 2009 13:01:36 +0100

Hi Julian,
thank you for the quick response.

>To say that a server does not need to support address books everywhere in its URI space?

Is not this something that should be said much earlier in the spec, say, in 2.2?

---

From: Julian Reschke <[email-masked]>
Date: Thu, 12 Feb 2009 13:12:00 +0100

> Is not this something that should be said much earlier in the spec, say, in 2.2?

Potentially, yes.