Subject: [VCARDDAV] vCard Sound

From: <[email-masked]>
Date: Thu, 26 Mar 2009 02:19:24 +0100

Hi all,
-06 says:

7.7.6.  SOUND
   Purpose:  To specify a digital sound content information that
      annotates some aspect of the vCard.  By default this property is
      used to specify the proper pronunciation of the name property
      value of the vCard.
I am a bit puzzled about the interpretation of this text - in particular, the part about the "default".
How do we indicate that we mean the default - or, something else?

   Encoding:  The encoding MUST be reset to "b" using the ENCODING
      parameter in order to specify inline, encoded binary data.  If the
      value is referenced by a URI value, then the default encoding of
      8bit is used and no explicit ENCODING parameter is needed.

   Value type:  A single value.  The default is binary value.  It can
      also be reset to uri value.  The uri value can be used to specify
      a value outside of this MIME entity.

If the default value is binary value, why do we need ENCODING and "b"?

Thank you.

Best regards: Zoltán Ördögh
E-mail: zoltan dot ordogh at nokia dot com
Phone: +358 50 386 0566

---

From: Simon Perreault <[email-masked]>
Date: Wed, 25 Mar 2009 18:44:42 -0700

[email-masked] wrote:
> *7.7.6.  SOUND*
> I am a bit puzzled about the interpretation of this text - in
> particular, the part about the "default".

I propose to reword as follows:

   Purpose:  To specify a digital sound content information that
      annotates some aspect of the vCard.  It is expected that this
      property be used to specify the proper pronunciation of the name
      property value of the vCard, although other uses are allowed.

> If the default value is binary value, why do we need ENCODING and "b"?

Backward compatibility.

Simon
-- 
STUN/TURN server    --> http://numb.viagenie.ca
Interplanetary news --> http://reeves.viagenie.ca
vCard 4.0           --> http://www.vcarddav.org

---

From: <[email-masked]>
Date: Thu, 26 Mar 2009 03:09:07 +0100

Hi Simon,

>      property value of the vCard, although other uses are allowed.

This is much better, thank you.

>> If the default value is binary value, why do we need 

I am not sure how to interpret your response.
"Value type:  A single value.  The default is binary value."
So, if the default is binary already, why do we need ENCODING?
If the default is binary, ENCODING would be needed only in case the value is a URI.

---

From: Simon Perreault <[email-masked]>
Date: Wed, 25 Mar 2009 19:11:59 -0700

> If the default is binary, ENCODING would be needed only in case the value is a URI.

Let me rephrase my answer: because that's how it was done in 3.0.

I know, it doesn't make sense. But it doesn't hurt one bit.

Simon

---

From: <[email-masked]>
Date: Thu, 26 Mar 2009 03:25:03 +0100

Hi Simon,

>-----Original Message-----
>From: ext Simon Perreault [mailto:[email-masked]] 
>Sent: 26 March, 2009 04:12
>To: Ordogh Zoltan (Nokia-D-MSW/Tampere)
>Cc: [email-masked]
>Subject: Re: [VCARDDAV] vCard Sound
>

This is why I am confused. So, for the sake of backwards compatibility we keep text that does not make sense. OF that's the consensus of the WG, let it be then. I was just hoping we could get rid of a few shortcomings.