Subject: [VCARDDAV] MEMBER role/related

From: Renato Iannella <[email-masked]>
Date: Mon, 29 Jun 2009 15:19:40 +1000

For the 7.6.5 MEMBER property, it would be useful to indicate some of  
the roles undertaken my the members of the group. For example, the  
"Chair" or "Team leader" etc. (the usual role values plus any  
extensions)

Can we support this by adding the RELATED property (could be do it  
with ROLE?)

Example:

     KIND:group
     FN:The Foo Taskforce
     MEMBER:urn:nicta.com:billie
     MEMBER:urn:nicta.com:corky
     MEMBER:urn:nicta.com:murphy
     RELATED;TYPE="x-chair":urn:nicta.com:corky

Cheers...  Renato Iannella
NICTA

---

From: "Javier Godoy" <[email-masked]>
Date: Mon, 29 Jun 2009 04:14:19 -0300

Renato Iannella wrote:

> For the 7.6.5 MEMBER property, it would be useful to indicate some of the 
> roles undertaken my the members of the group. For example, the "Chair" or 
> "Team leader" etc. (the usual role values plus any extensions)
>
>  Can we support this by adding the RELATED property (could be do it with 
> ROLE?)
>
> Example:
>
>    KIND:group
>    FN:The Foo Taskforce

Hi Renato,

Both RELATED and MEMBER allows URI values, hence your example is valid 
according to draft-07

About using the ROLE property, it could be included in Corky's vCard as 
ROLE:chair but I think the semantics of this approach is ambiguous as it 
doesn't specifies the group of which Corky is chair.

Best Regards

Javier

---

From: Renato Iannella <[email-masked]>
Date: Tue, 30 Jun 2009 15:26:34 +1000

Perhaps if we added support for the type-param as well:

   KIND:group
   FN:The Foo Taskforce
   MEMBER;TYPE="chair":urn:nicta.com:corky
   MEMBER:urn:nicta.com:billie
   MEMBER:urn:nicta.com:murphy

where type-value-role = "chair" / "contact" / .... / x-name

---

From: Simon Perreault <[email-masked]>
Date: Tue, 30 Jun 2009 08:20:35 -0400

> where type-value-role = "chair" / "contact" / .... / x-name

That's a good idea, but I would prefer for this to be a separate extension.

Simon
-- 
Please try Numb, a STUN/TURN server implementation.
Free access at http://numb.viagenie.ca/.