Subject: Re: [VCARDDAV] ABNF comments, Re: I-D Action:draft-ietf-vcarddav-vcardrev-07.txt

From: Simon Perreault <[email-masked]>
Date: Wed, 8 Jul 2009 13:44:16 -0400

On Sunday 17 May 2009 14:28:38 Julian Reschke wrote:
> (1) there are a few prose rules containing line ends, these are not
> allowed in ABNF

One I could fix, the other I couldn't. I ended up enclosing all lines in 
brackets. It's a bit silly, but the parser shouldn't complain. Is this OK with 
you?

     iana-valuespec = <a publicly-defined valuetype format, registered>
                      <with IANA, as defined in section 12 of this>
                      <document>

> (2) You may want to consider assigning unique rule names, such as
> "BEGIN-param" and "BEGIN-value" instead of "param" and "value"

Done for -08.

Thanks,
Simon
-- 
STUN/TURN server    --> http://numb.viagenie.ca
Interplanetary news --> http://reeves.viagenie.ca
vCard 4.0           --> http://www.vcarddav.org

---

From: Julian Reschke <[email-masked]>
Date: Thu, 09 Jul 2009 12:02:14 +0200

Simon Perreault wrote:
> ...

Although it's important that it doesn't complain; doing this to silence 
it seems to be the wrong approach. How About:

      iana-valuespec = <value-spec, see Section 12>
                     ; a publicly-defined valuetype format, registered
                     ; with IANA, as defined in section 12 of this
                     ; document

Also, it appears that the link to Section 12 is now Section 11 (*).

BR, Julian

(*) Problems like these can be avoided by using rfc2629.xslt's extension 
which allows <xref> elements inside <artwork>...