Subject: [VCARDDAV] vendor registry lookup service

From: Marc Blanchet <[email-masked]>
Date: Mon, 27 Jul 2009 17:04:44 +0200

Hi,
 there are some discussions about creating/extending a vendor name space
registry for applications protocols
(see http://www3.ietf.org/proceedings/75/slides/apparea-3.pdf as
presented at apps-area meeting this morning).

I made the point at the mike that we already have a vendor registry: the
private enterprise numbers (PEN), which contains 35K entries, on a first
come first serve manner, and automated by IANA. On the contrary, the
proposal is based on the acap registry which contains about a dozen entries.

why should we reinvent another registry with almost same data?

One comment was made about the fact that the PEN are made of digits,
therefore not user-friendly to be shown to the end-user. While I don't
think this is a real issue and can be managed differently, I'm proposing
a simple solution: a lookup service mapping PEN to vendor name, for user
display.

Thereby, this mail announces a PEN lookup service to map the PEN to the
vendor name. This is implemented as a DNS TXT record under the
enterprise-numbers.org domain name. It is available now.

For example:

dig 31474.enterprise-numbers.org TXT
...
31474.enterprise-numbers.org. 86400 IN	TXT	"Viagenie inc."

dig 5842.enterprise-numbers.org TXT
...
5842.enterprise-numbers.org. 86400 IN	TXT	"Cisco Systems"

Regards, Marc.

-- 
=========
IPv6 book: Migrating to IPv6, Wiley. http://www.ipv6book.ca
Stun/Turn server for VoIP NAT-FW traversal: http://numb.viagenie.ca
DTN news service: http://reeves.viagenie.ca

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 27 Jul 2009 19:10:09 +0200

Marc,

The name that is associated with a PEN is the name on the form submitted
to IANA at the moment of the request. Nothing less, nothing more. 

Dan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Marc Blanchet
> Sent: Monday, July 27, 2009 6:05 PM
> To: [email-masked]; [email-masked]
> Subject: vendor registry lookup service
> 
> Hi,
>  there are some discussions about creating/extending a vendor 
> name space registry for applications protocols (see 
> http://www3.ietf.org/proceedings/75/slides/apparea-3.pdf as 
> I made the point at the mike that we already have a vendor 
> registry: the private enterprise numbers (PEN), which 
> contains 35K entries, on a first come first serve manner, and 
> automated by IANA. On the contrary, the proposal is based on 
> the acap registry which contains about a dozen entries.
> 
> One comment was made about the fact that the PEN are made of 
> digits, therefore not user-friendly to be shown to the 
> end-user. While I don't think this is a real issue and can be 
> managed differently, I'm proposing a simple solution: a 
> lookup service mapping PEN to vendor name, for user display.
> 
> Thereby, this mail announces a PEN lookup service to map the 
> PEN to the vendor name. This is implemented as a DNS TXT 
> record under the enterprise-numbers.org domain name. It is 
> available now.
> 
> For example:
> 
> Stun/Turn server for VoIP NAT-FW traversal: 
> http://numb.viagenie.ca DTN news service: http://reeves.viagenie.ca
> 
> _______________________________________________
> Apps-Discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>

---

From: Dave Cridland <[email-masked]>
Date: Mon, 27 Jul 2009 18:42:07 +0100

On Mon Jul 27 16:04:44 2009, Marc Blanchet wrote:
> registry: the

Right, that's largely because we've reused that registry in a couple  
of other protocols already, and "short tag" names seem to be  
particularly useful.

> a simple solution: a lookup service mapping PEN to vendor name, for  

You'd need one the other way around, too - existing protocols, and  
all. And existing protocols are real issues, like it or not.

> enterprise-numbers.org domain name. It is available now.

I'm absolutely not against combining the ACAP vendor registry with  
the PEN registry, but since existing protocols use both names and  
numbers (more technically, OID arcs), I think we need both  
registered. Moreover, most protocols have severe limitations on what  
characters can be included in those names - you'll have noticed that  
one of the changes I've made between the ACAP vendor registry and my  
draft is that I've drastically sliced the possible characters  
involved. So the vast majority of the names included in the PEN  
registry are simply unsuitable from the get-go.

I'd even be happy to see a DNS based lookup, actually - it might be  
entertaining to translate to and from "vendor.isode" <=>  
"1.3.6.1.4.1.453", and it can certainly have a *very* long TTL.

Of course, whilst you're at it, one could conceivably map the whole  
of the OBJECT IDENTIFIER space to DNS.

Dave.
-- 
Dave Cridland - mailto:[email-masked] - xmpp:[email-masked]
  - acap://acap.dave.cridland.net/byowner/user/dwd/bookmarks/
  - http://dave.cridland.net/
Infotrope Polymer - ACAP, IMAP, ESMTP, and Lemonade