Subject: [VCARDDAV] [Fwd: I-D Action:draft-cridland-acap-vendor-registry-00.txt]

From: Alexey Melnikov <[email-masked]>
Date: Mon, 06 Jul 2009 14:17:51 +0100

Hi Simon,

Several IETFs ago I've recommended that vCard 4.0 should use the ACAP 
vendor registry. I've convinced Dave Cridland to post an updated draft 
that makes this registry non-ACAP-specific. The draft still needs a bit 
of work (and has some open issues), but I think it is a good start.

Subject: I-D Action:draft-cridland-acap-vendor-registry-00.txt
From: [email-masked]
To: [email-masked]
Date: Mon, 6 Jul 2009 06:00:01 -0700 (PDT)
List-Id: Internet Draft Announcements only <i-d-announce.ietf.org>

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : The Internet Assigned Number Authority (IANA) Application Configurations Access Protocol (ACAP) Vendor Subtrees Registry
	Author(s)       : D. Cridland
	Filename        : draft-cridland-acap-vendor-registry-00.txt
	Pages           : 6
	Date            : 2009-07-06

The original ACAP specification included a vendor registry now used
in other protocols.  This document updates the description of this
registry, removing the need for a direct normative reference to ACAP,
and removing ambiguity.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-cridland-acap-vendor-registry-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Simon Perreault <[email-masked]>
Date: Wed, 8 Jul 2009 16:05:15 -0400

> of work (and has some open issues), but I think it is a good start.

Thanks a lot.

To be able to integrate it in vCard, the vendor-tag production would need to 
be constrained a little bit. We need to be able to have property names like 
the following:

VENDOR-MUDPIE-FOO:...

So MUDPIE would be the vendor-tag, and it must adhere to the grammar of a 
vCard property, which is basically 1*(ALPHA / DIGIT / "-"). Far from the whole 
UTF-8.

Also, vCard properties are case-insensitive so vendor tags also need to be.

Right now in the IANA registry there are a few with slashes in them... :( This 
doesn't even match iana-vendor-tag...
<http://iana.org/assignments/acap-registrations/acap-registrations.xhtml#acap-
registrations-4>

Simon
-- 
STUN/TURN server    --> http://numb.viagenie.ca
Interplanetary news --> http://reeves.viagenie.ca
vCard 4.0           --> http://www.vcarddav.org

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 08 Jul 2009 23:50:25 +0100

>vCard property, which is basically 1*(ALPHA / DIGIT / "-"). Far from the whole 
Right. This is close to iana-vendor-tag, which (apart from the missing 
"-") also allows SP.
We can probably map it to something else.

(In general I think allowing characters outside of ASCII for vendor 
names might be problematic.)

>Also, vCard properties are case-insensitive so vendor tags also need to be.
Hmm.
This is probably a reasonable restriction for the ACAP vendor registry 
as well.

><http://iana.org/assignments/acap-registrations/acap-registrations.xhtml#acap-
These are bugs in registrations and I can deal with them by talking 
directly to IANA. RFC 2244 didn't allow slashes.