Subject: [VCARDDAV] Batch request for CardDAV

From: Jong Yoon Lee <[email-masked]>
Date: Mon, 16 Nov 2009 12:13:30 -0800 (PST)

Hello,

This is to follow up the request I made at vcarddav session last week in Hiroshima.  To recap, it would be nice to have a batch request mechanism for creating multiple vCards in CardDAV protocol.  Currently CardDAV client needs to submit a PUT request for each vCard to be created.  When a user wants to import an addressbook containing multiple vCards using CardDAV client, it would result in a series of PUT requests being made to the server at once.  In some circumstances the service provider running the CardDAV servers may employ rate limiter or some form of abuse detection mechanism based on the request rate, and the group of PUT requests could trigger such defense mechanism and could block the user agent.  It would be nice to have a mechanism to create a number of vCards in a single request.

Jong Lee

---

From: Simon Perreault <[email-masked]>
Date: Mon, 16 Nov 2009 15:32:03 -0500

> This is to follow up the request I made at vcarddav session last week in Hiroshima.  To recap, it would be nice to have a batch request mechanism for creating multiple vCards in CardDAV protocol.…

I just remembered that I mentioned this issue at IETF 71 (Philadelphia) as part
of my CardDAV implementation report. See the very last line at
http://www.viagenie.ca/publications/2008-03-11-ietf-vcarddav-carddav-implementation.pdf

Sadly I can't find minutes for this meeting.

However we have the full audio here:
ftp://videolab.uoregon.edu/pub/videolab/media/ietf71/ietf71-ch4-tue-am-vcarddav.mp3

My presentation was the last one.

I'm sure there is some insight in there...

Simon
-- 
DNS64 open-source   --> http://ecdysis.viagenie.ca
STUN/TURN server    --> http://numb.viagenie.ca
vCard 4.0           --> http://www.vcarddav.org