Subject: [VCARDDAV] add to vCard properties: Salutation Form

From: Nick Levinson <[email-masked]>
Date: Sat, 14 Nov 2009 15:01:03 -0800 (PST)

Namespace: global

Property name: SALUTATION-FORM

Purpose: Whether to address someone as Ms. Jones or as Ida varies by culture and individual. I suggest that Salutation Form specify a format for a given vCard. The value components (the concept of components being akin to that for the N property) could, for example, be "Honorific Prefix;space;Surname" to represent "Ms. Jones". A speed advantage is that the same string could be pasted into many vCards and, being common, should be defined in a case-insensitive list largely composed of abbreviations, begun in Value Type.

Value Type: text, as follows:
--- hpsfn or default: Honorific Prefix;space;Surname
--- gn: Given Name
--- gns: Given Name Surname (e.g., traditional use of this form by Friends (Quakers))
--- hiss: Honorific Infix;space;Surname
--- hpsgn: Honorific Prefix;space;Given Name (rare; e.g., hairstylists in U.S.)
--- title: Title (e.g., "[Dear ]Judge")
--- role: Role (e.g., "[Dear ]Engineer")
--- hpstitle: Honorific Prefix;space;Title (e.g., "[Dear ]Ms. Chief Justice")
--- special: any custom entry (e.g., for an Associate Justice of the U.S. Supreme Court, "[Dear ]Mr. Justice Brennan")

Description:

Because families often use joint salutations (e.g., Dr. and Mr. Example or The Example Family) and a family is a group or organization, vCards of all Types may require Salutation Forms.

I'm unclear on the meaning of any-param, which appears for most properties, so perhaps it belongs in this ABNF definition, too.

ABNF format definition:

SALUTATION-FORM-param = "VALUE=text" / any-param
SALUTATION-FORM-value = "hpsfn" / "gn" / "gns" / "hiss" / "hpsgn" / "title" / "role" / "hpstitle" / "special"

Example: SALUTATION-FORM:hpstitle

Thank you.

-- 
Nick

---

From: Simon Perreault <[email-masked]>
Date: Sun, 15 Nov 2009 20:34:01 -0500

> Property name: SALUTATION-FORM

I don't understand what this property does.

Simon
-- 
DNS64 open-source   --> http://ecdysis.viagenie.ca
STUN/TURN server    --> http://numb.viagenie.ca
vCard 4.0           --> http://www.vcarddav.org