Subject: [VCARDDAV] vCard: possible errata

From: Nick Levinson <[email-masked]>
Date: Sat, 14 Nov 2009 15:31:43 -0800 (PST)

Re RFC draft 09:

Section 5 has an example that is not in double quotation marks, but the preceding text gives it as an example of the use of the quotation marks. Perhaps I misunderstand the point being made?

Sec. 5.3, first paragraph, includes the word "explicity", which probably should be "explicitly".

Sec. 5.4, first paragraph, includes the word "preferrredness", which probably should be "preferredness".

For both instances of "preferredness", would not "preference" suffice? In non-IT conversations, we speak of strong and weak preferences already.

Sec. 6.2.2 discusses Additional Names, in which "Individual text components can include multiple text values (e.g., multiple Additional Names) separated by the COMMA character (ASCII decimal 44)." implies that any individual text component can include an Additional Name. However, "In the N property, additional names are now subsumed into the given names list." (sec. A.2) and "In N property, removed additional names, and replaced with multiple given names." (sec. B.6) imply that specificity to given names was intended. If that specificity is intended, please clarify sec. 6.2.2.

Thank you.

-- 
Nick

---

From: Simon Perreault <[email-masked]>
Date: Sun, 15 Nov 2009 21:01:43 -0500

> Section 5 has an example that is not in double quotation marks, but the preceding text gives it as an example of the use of the quotation marks. Perhaps I misunderstand the point being made?

Wow, good catch!

In -01, the example contained a URN as PID value, which contained a 
colon. Now that PID takes a single integer, I can't think of an example 
that would require double quotation marks.

Therefore I have removed the example in -10.

> Sec. 5.3, first paragraph, includes the word "explicity", which probably should be "explicitly".

Fixed, thanks.

> For both instances of "preferredness", would not "preference" suffice? In non-IT conversations, we speak of strong and weak preferences already.

Yes, that would be better. Fixed, thanks.

> Sec. 6.2.2 discusses Additional Names, in which "Individual text components can include multiple text values (e.g., multiple Additional Names) separated by the COMMA character (ASCII decimal 44)."…

You're right. I think the "(e.g. ...)" is confusing and unneeded. I just 
removed in in -10.

Many thanks,
Simon
-- 
DNS64 open-source   --> http://ecdysis.viagenie.ca
STUN/TURN server    --> http://numb.viagenie.ca
vCard 4.0           --> http://www.vcarddav.org