Subject: [VCARDDAV] add to vCard value components of N: Honorific Infix

From: Nick Levinson <[email-masked]>
Date: Sat, 14 Nov 2009 15:09:41 -0800 (PST)

N: value component: Honorific Infix

Value: any literal

Purpose:

--- The Roman Catholic Church uses honorific infixes for high-profile leaders and many people address them accordingly. In "His Eminence Aloysius Cardinal Ambrozic" (<http://www.archtoronto.org/about_us/cardinal_ambrozic.html>, recently accessed), "Cardinal" is one of his honorifics, and, being between given and family names, is an infix.

--- Furthermore, an infix's proper position within an FN must be identified within an N, i.e., immediately prior to the Surname or prior to a specified Additional Name.

--- I propose that the text constituting the Honorific Infix be entered as if it is an Additional Name in its proper position and that the fact that it is an Honorific Infix be indicated by an additional semicolon at the end of the N property. The additional semicolon is thus optional; its absence means the lack of an Honorific Infix. The syntax of the latter should be declared by amending sec. 6.2.2, Special Note, first sentence, to read "The structured property value corresponds, in sequence, to the Surname, Given Names, Honorific Prefixes, Honorific Suffixes, and Honorific Infixes."

Conformance: N

Example: N:Ambrozic;Aloysius,Cardinal;His Eminence;;

Thank you.

-- 
Nick

---

From: Simon Perreault <[email-masked]>
Date: Sun, 15 Nov 2009 20:37:53 -0500

> N: value component: Honorific Infix

In the current vCard 4.0 draft, component lists cannot be extended. For 
this extension you would need to define a new property or a new 
parameter. Not sure which is better.

Simon
-- 
DNS64 open-source   --> http://ecdysis.viagenie.ca
STUN/TURN server    --> http://numb.viagenie.ca
vCard 4.0           --> http://www.vcarddav.org