Subject: [VCARDDAV] [Fwd: Re: Coordination issue: vCard, iCalendar vs JavaScript contact and calendaring APIs]

From: Marc Blanchet <[email-masked]>
Date: Thu, 28 Jan 2010 07:40:35 -0500

Does the wg think we should do something regarding this thread within w3c?

Marc.

-------- Message original --------
Sujet : Re: Coordination issue: vCard, iCalendar vs JavaScript contact 
and calendaring APIs
Date : Thu, 28 Jan 2010 13:18:19 +0100
De : Thomas Roessler <[email-masked]>
Pour : Mark Nottingham <[email-masked]>
Copie à : Thomas Roessler <[email-masked]>, public-ietf-w3c 
<[email-masked]>, [email-masked], Eliot Lear 
<[email-masked]>, Kurt Zeilenga <[email-masked]>, Marc Blanchet 
<[email-masked]>, [email-masked], Robin Berjon 
<[email-masked]>, Dominique Hazael-Massieux <[email-masked]>
Références : <[email-masked]> 
<[email-masked]>

Thanks, Mark.

I'd be particularly interested in hearing more about the relevant WGs' 
attitudes toward subsetting of the data formats defined.

I'll also note that the Device API WG's specifications will describe 
both APIs to manipulate calendaring and contact data, an a mapping of 
the vCard and iCalendar data models into JavaScript objects.  The latter 
might potentially turn into a canonical JSON mapping for these objects.

Regards,
--
Thomas Roessler, W3C  <[email-masked]>

On 28 Jan 2010, at 04:02, Mark Nottingham wrote:

> Thomas,
> 
> I've CC'ed the chairs of the relevant WGs:
>  * <vcarddav http://www.ietf.org/dyn/wg/charter/vcarddav-charter.html>
>  * <calsify http://www.ietf.org/dyn/wg/charter/calsify-charter.html>
> 
> Cheers,
> 
> 
> Begin forwarded message:
> 
>> From: Thomas Roessler <[email-masked]>
>> Date: 28 January 2010 3:00:37 AM AEDT
>> To: Mark Nottingham <[email-masked]>
>> Cc: Thomas Roessler <[email-masked]>, Dominique Hazaël-Massieux <[email-masked]>, public-ietf-w3c <[email-masked]>, Frederick Hirsch <[email-masked]>, Robin Berjon <[email-masked]>
>> Subject: Coordination issue: vCard, iCalendar vs JavaScript contact and calendaring APIs
>> 
>> The Device API and Policy Working Group is drafting APIs to manipulate contact and calendar data.  I'd like to check in on how to best coordinate with whatever IETF efforts are going on in the space.
>> 
>> An FPWD for the contacts API has already been published:
>>  http://www.w3.org/TR/2010/WD-contacts-api-20100121/
>> 
>> I'll follow up with a pointer to the Calendaring API draft when it becomes available.
>> 
>> Thanks,
>> --
>> Thomas Roessler, W3C  <[email-masked]>
>> 
>> 
>> 
>> 
>> 
>> 
>> 
> 
> 
> --
> Mark Nottingham     http://www.mnot.net/
> 
>

---

From: Joseph Smarr <[email-masked]>
Date: Thu, 28 Jan 2010 10:35:38 -0800

This is one of the major values of Portable Contacts--a clear JSON mapping
of vCard (plus some extra fields and some modernization, plus a well defined
discovery/auth/invocation protocol). See
http://tools.ietf.org/id/draft-smarr-vcarddav-portable-contacts-00.txt for
those that haven't taken a look before (I presented PoCo at a previous
vCardDAV IETF meeting, see
http://josephsmarr.com/2009/03/25/portable-contacts-and-vcarddav-ietf-74/).
And we also have running code to convert vCard to/from Portable Contacts,
see http://www.plaxo.com/pdata/vcardTest for a demo).

So hopefully we don't need to invent yet-another way to represent vCard in
JSON (or XML for that matter--we still need to reconcile the current
vcardxml draft and PoCo), and one could certainly do something similar for
iCalendar, though we've only focused on contact info for now.

Thanks, js

On Thu, Jan 28, 2010 at 4:40 AM, Marc Blanchet <[email-masked]>wrote:

> Sujet : Re: Coordination issue: vCard, iCalendar vs JavaScript contact and
> calendaring APIs
> Copie à : Thomas Roessler <[email-masked]>, public-ietf-w3c <
> [email-masked]>, [email-masked], Eliot Lear <[email-masked]>,
> Kurt Zeilenga <[email-masked]>, Marc Blanchet <
> [email-masked]>, [email-masked], Robin Berjon <
> [email-masked]>, Dominique Hazael-Massieux <[email-masked]>
> Références : <[email-masked]> <
> [email-masked]>
>
> Thanks, Mark.
>
> I'll also note that the Device API WG's specifications will describe both
> APIs to manipulate calendaring and contact data, an a mapping of the vCard
> and iCalendar data models into JavaScript objects.  The latter might
> potentially turn into a canonical JSON mapping for these objects.
>
> Regards,
> --
>>> Cc: Thomas Roessler <[email-masked]>, Dominique Hazaël-Massieux <[email-masked]>,
>>> public-ietf-w3c <[email-masked]>, Frederick Hirsch <
>>> [email-masked]>, Robin Berjon <[email-masked]>
>>> The Device API and Policy Working Group is drafting APIs to manipulate
>>> contact and calendar data.  I'd like to check in on how to best coordinate
>>> with whatever IETF efforts are going on in the space.
>>>
>>  _______________________________________________
> VCARDDAV mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/vcarddav
>