Subject: [VCARDDAV] Last call comment: please add version parameter to Mime type

From: Cyrus Daboo <[email-masked]>
Date: Sun, 30 May 2010 10:36:23 -0400

Hi,
Could we please add a "version" parameter to the text/vcard MIME Content type? That would greatly help when trying to do content negotiation in CardDAV. E.g. A server supporting both 3.0 and 4.0 vcard formats could allow clients to use the http Accept header to request a particular version be returned by the server. This will greatly aid in transitioning clients from 3.0 to 4.0. That said it would also be useful to have some recommendations on how to convert between 3.0 and 4.0 formats. 

-- 
Cyrus Daboo
(Tapped out on my iPad)

---

From: Simon Perreault <[email-masked]>
Date: Mon, 31 May 2010 16:24:32 -0400

On 2010-05-30 10:36, Cyrus Daboo wrote:
> Could we please add a "version" parameter to the text/vcard MIME
> Content type? That would greatly help when trying to do content
> negotiation in CardDAV. E.g. A server supporting both 3.0 and 4.0
> vcard formats could allow clients to use the http Accept header to
> request a particular version be returned by the server. This will
> greatly aid in transitioning clients from 3.0 to 4.0.

RFC2425 and 2426 specified text/directory while we specify text/vcard. 
Isn't this sufficient for content negotiation?

As for future versions, I've heard that the world is moving toward XML... ;)

> That said it
> would also be useful to have some recommendations on how to convert
> between 3.0 and 4.0 formats.

We created Appendix A exists exactly for this purpose. Could you be a 
bit more specific?

Thanks,
Simon
-- 
NAT64/DNS64 open-source --> http://ecdysis.viagenie.ca
STUN/TURN server        --> http://numb.viagenie.ca
vCard 4.0               --> http://www.vcarddav.org