Subject: [VCARDDAV] KIND:group vs. KIND:org

From: Kevin Wu Won <[email-masked]>
Date: Tue, 13 Jul 2010 16:24:45 +1000

What is the difference between the values "group" and "org" for the KIND
 property?  The draft-12 isn't very clear about the meaning of these values.

Thanks,
Kevin.

---

From: "Javier Godoy" <[email-masked]>
Date: Tue, 13 Jul 2010 05:08:54 -0300

Hi Kevin,

KIND:"org" means the vCard instance represents the organization itself. In 
this case the organization name is given in ORG and there is no N property 
(because there are no surnames or given names). In vCard 3.0 it was not clear 
how to represent organizations, because the N property had always to be 
present.

KIND:"group" means the vCard represents a "group of individuals", such as a 
mailing list, a set of contacts, etc. A group may have MEMBERs, while other 
kinds of vCard can't.

Best Regards

Javier

----- Original Message ----- 
From: "Kevin Wu Won" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, July 13, 2010 3:24 AM
Subject: [VCARDDAV] KIND:group vs. KIND:org

> _______________________________________________
> VCARDDAV mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/vcarddav
>
>

---

From: Dan Brickley <[email-masked]>
Date: Tue, 13 Jul 2010 10:50:29 +0200

On Tue, Jul 13, 2010 at 10:08 AM, Javier Godoy <[email-masked]> wrote:
> (because there are no surnames or given names). In vCard 3.0 it was not
> clear how to represent organizations, because the N property had always to
> be present.
>

Is this recursive? Can the members of a group be groups?

Dan

---

From: "Javier Godoy" <[email-masked]>
Date: Tue, 13 Jul 2010 06:59:47 -0300

> Is this recursive? Can the members of a group be groups?

I think it is allowed (defining "group" as "group of individuals" was an 
oversimplification).  The value of MEMBER is a URI that is not required to 
identify a vCard of the "individual" KIND, hence I understand recursive groups 
are allowed. Moreover, it is not required to identify a vCard instance: it may 
be a resource other than a vCard (such as a mailto: URI).

Best Regards

Javier

---

From: Simon Perreault <[email-masked]>
Date: Tue, 13 Jul 2010 09:00:49 -0400

On 2010-07-13 02:24, Kevin Wu Won wrote:
>  property?

Only vCards with KIND:group may have the MEMBER property.

Simon
-- 
NAT64/DNS64 open-source --> http://ecdysis.viagenie.ca
STUN/TURN server        --> http://numb.viagenie.ca
vCard 4.0               --> http://www.vcarddav.org

---

From: Simon Perreault <[email-masked]>
Date: Tue, 13 Jul 2010 09:01:25 -0400

On 2010-07-13 04:50, Dan Brickley wrote:
> Can the members of a group be groups?

Yes. Any URI will do.

Simon