Subject: Re: [VCARDDAV] Questions about vCard 4.0 (draft rev-11)

From: Simon Perreault <[email-masked]>
Date: Fri, 09 Jul 2010 13:26:55 -0400

On 2010-06-23 01:05, Javier Godoy wrote:
> About case sensitiviy for "T" and "Z", they are defined in section 3.4.3
> "Characters used as designators" of ISO 8601:2004 as: «
> In representations the following characters are used as designators:
>   [Z] is used as UTC designator.
>   [T] is used as time designator
> »
> 
> It seems they are specified as uppercase (at least, there is no example
> with
> lowercase designators), so in this case we should the ABNF.
> 
> utc-designator = "Z"
> zone   = utc-designator / utc-offset
> 
> time-designator = "T"
> date-time = date-noreduc  time-designator time-notrunc
> timestamp = date-complete time-designator time-complete
> date-and-or-time = date-time / date / time-designator time

I'm processing this now, and I realize that I don't understand exactly
what you're suggesting. What's the difference with the existing ABNF
except that you've factored out the "Z" and "T" strings?

Simon
-- 
NAT64/DNS64 open-source --> http://ecdysis.viagenie.ca
STUN/TURN server        --> http://numb.viagenie.ca
vCard 4.0               --> http://www.vcarddav.org

---

From: "Javier Godoy" <[email-masked]>
Date: Fri, 9 Jul 2010 23:28:17 -0300

Simon Perreault wrote,

> except that you've factored out the "Z" and "T" strings?

Sorry, my mistake. It should be:
  utc-designator  = %d90; uppercase "Z"
  time-designator = %d84; uppercase "T"
  date-time = date-noreduc  time-designator time-notrunc

Best Regards

Javier

---

From: Simon Perreault <[email-masked]>
Date: Sat, 10 Jul 2010 08:47:14 -0400

>  date-time = date-noreduc  time-designator time-notrunc

Thanks. It will be that way in -12.

Simon