Subject: [VCARDDAV] Mapping between different versions of vcard

From: Ciny Joy <[email-masked]>
Date: Fri, 27 Aug 2010 09:53:00 -0700

Hello,
    There was some discussion on this mailing list a while back on a  
document defining the mapping of vCard3 to vCard4? Does such a  
document exist? If not, is there an easy way to understand the  
differences between the two versions and the best way to handle them  
when converting from one version to another?

Thanks,
Ciny

---

From: Daisuke Miyakawa <[email-masked]>
Date: Fri, 27 Aug 2010 11:09:55 -0700

Hi,

2010/8/27 Ciny Joy <[email-masked]>

> Hello,
>   There was some discussion on this mailing list a while back on a document
> defining the mapping of vCard3 to vCard4?

I think no. Actually there are some elements which are incompatible with
each other.
For example, SORT-STRING in vCard3 doesn't have multiple fields in it, while
SORT-AS (parameter) in vCard4 has.

Also, there are de-facto properties used in vCard3 and probably abandoned in
vCard4, which I think this group can't (and probably shouldn't) take care
of.
For example, as for the case above, I saw
X-PHONETIC-FIRST-NAME/X-PHONETIC-MIDDLE-NAME/X-PHONETIC-LAST-NAME,
which can be converted into SORT-AS in vCard4. But I'm not sure whether we
should explicitly say so. as we never know all the aspect of vCard3 world.

> If not, is there an easy way to understand the differences between the two
> versions and the best way to handle them when converting from one version to
> another?
>

Currently no. I agree with you in that we need this kind of practical (not
for-specification) document. But I'm new to here and I don't know whether
here is a good place to talk about the doc.

Thanks,

> Thanks,
> Ciny
> _______________________________________________
> VCARDDAV mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/vcarddav
>

-- 
Daisuke Miyakawa (宮川大輔)
[email-masked]

---

From: Simon Perreault <[email-masked]>
Date: Fri, 27 Aug 2010 14:21:03 -0400

On 2010-08-27 14:09, Daisuke Miyakawa wrote:
> But I'm new to here and I don't know
> whether here is a good place to talk about the doc.

I think it is!

Simon
-- 
NAT64/DNS64 open-source --> http://ecdysis.viagenie.ca
STUN/TURN server        --> http://numb.viagenie.ca
vCard 4.0               --> http://www.vcarddav.org

---

From: Ciny Joy <[email-masked]>
Date: Mon, 30 Aug 2010 13:33:23 -0700

Thank you for your response.

On Aug 27, 2010, at 11:09 AM, Daisuke Miyakawa wrote:

> document defining the mapping of vCard3 to vCard4?
>
> I think no. Actually there are some elements which are incompatible  
> with each other.
> For example, SORT-STRING in vCard3 doesn't have multiple fields in  
> it, while SORT-AS (parameter) in vCard4 has.
>
> Also, there are de-facto properties used in vCard3 and probably  
> abandoned in vCard4, which I think this group can't (and probably  
> shouldn't) take care of.
> For example, as for the case above, I saw X-PHONETIC-FIRST-NAME/X- 
> PHONETIC-MIDDLE-NAME/X-PHONETIC-LAST-NAME,
> which can be converted into SORT-AS in vCard4. But I'm not sure  
> whether we should explicitly say so. as we never know all the aspect  
> of vCard3 world.
>
> If not, is there an easy way to understand the differences between  
> the two versions and the best way to handle them when converting  
> from one version to another?
>
> Currently no. I agree with you in that we need this kind of  
> practical (not for-specification) document.
Right. If folks who have solved this completely or even partially send  
samples like you mention above, we could compile it and form an  
unofficial document.

Ciny
> But I'm new to here and I don't know whether here is a good place to  
> talk about the doc.
>
> Thanks,
>
> Thanks,
> Ciny