Subject: [VCARDDAV] contacts coordination

From: Marc Blanchet <[email-masked]>
Date: Wed, 08 Sep 2010 10:17:08 -0400

Hello,
  W3C initiated a discussion with the various groups involved in 
contacts, such as W3C device API, Portable Contacts, IETF vcarddav, OMA 
CAB. A conf call was scheduled. Minutes are posted at:
http://www.w3.org/2010/09/03-contacts-minutes.html.

There are multiple variations of contact info from each group. It might 
be possible to have some set of fields who have a one-to-one mapping 
between each format. It might be possible to converge the formats.

One of the outcome was the need to have a good understanding of the 
differences between the specifications. Would someone in this wg want to 
look at these and come back?

I see the following options for our working group:
a) forget all this. go IETF last call.
b) wait until a diff between the specs gives us a good understanding and 
then decide what to do. (with some time bomb)
c) work on a converged version of all formats
d) ???

What should the working group do?

Marc, co-chair.

====================
Some URLs:

Minutes of the contacts coordination call:
http://www.w3.org/2010/09/03-contacts-minutes.html

W3C device api: http://www.w3.org/TR/contacts-api/

OMA specifications:
http://member.openmobilealliance.org/ftp/Public_documents/COM/COM-CAB/Permanent_documents/OMA-TS-CAB_XDMS-V1_0-20100831-D.zip

http://member.openmobilealliance.org/ftp/Public_documents/COM/COM-CAB/Permanent_documents/OMA-TS-CAB-V1_0-20100901-D.zip

Comparisons of formats:
http://factoryjoe.com/blog/2008/06/04/inventing-contact-schemas-for-fun-and-profit-ugh/
http://spreadsheets.google.com/pub?key=pSGbbhtwI4kN_nJ1GXeQ7Qg

-- 
=========
IPv6 book: Migrating to IPv6, Wiley. http://www.ipv6book.ca
Stun/Turn server for VoIP NAT-FW traversal: http://numb.viagenie.ca
DTN news service: http://reeves.viagenie.ca
NAT64-DNS64 Opensource: http://ecdysis.viagenie.ca

---

From: Joseph Smarr <[email-masked]>
Date: Wed, 8 Sep 2010 07:32:37 -0700

And don't forget Portable Contacts:
http://portablecontacts.net/draft-spec.html (which is also now being used as
the schema for W3C Contacts).

On Wed, Sep 8, 2010 at 7:17 AM, Marc Blanchet <[email-masked]>wrote:

> Hello,
>  W3C initiated a discussion with the various groups involved in contacts,
> such as W3C device API, Portable Contacts, IETF vcarddav, OMA CAB. A conf
> call was scheduled. Minutes are posted at:
> There are multiple variations of contact info from each group. It might be
> possible to have some set of fields who have a one-to-one mapping between
> each format. It might be possible to converge the formats.
>
> _______________________________________________
> VCARDDAV mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/vcarddav
>

---

From: Renato Iannella <[email-masked]>
Date: Thu, 9 Sep 2010 10:12:41 +1000

On 9 Sep 2010, at 00:32, Joseph Smarr wrote:

> And don't forget Portable Contacts: http://portablecontacts.net/draft-spec.html (which is also now being used as the schema for W3C Contacts).

Hi Joseph - can you provide a link to W3C's use of PoCo?

Cheers

Renato Iannella
http://renato.iannella.it

---

From: Renato Iannella <[email-masked]>
Date: Thu, 9 Sep 2010 10:18:05 +1000

On 9 Sep 2010, at 00:17, Marc Blanchet wrote:

> b) wait until a diff between the specs gives us a good understanding and then decide what to do. (with some time bomb)

I think the group (*all* the groups) should work towards C).

It is a sad scenario to have so many "contacts" specs springing up all over the place.

If we, as "standards people" don't get it, then how can we expect hat the wider communities will !

Cheers

Renato Iannella

---

From: Joseph Smarr <[email-masked]>
Date: Wed, 8 Sep 2010 17:57:38 -0700

Sure, look at
http://www.w3.org/TR/2010/WD-contacts-api-20100701/#idl-def-ContactProperties
(scroll
up a bit to see the note about how their schema is based on PoCo).

On Wed, Sep 8, 2010 at 5:12 PM, Renato Iannella <[email-masked]> wrote:

> http://portablecontacts.net/draft-spec.html (which is also now being used
> as the schema for W3C Contacts).
>
>

---

From: Renato Iannella <[email-masked]>
Date: Thu, 9 Sep 2010 16:26:09 +1000

On 9 Sep 2010, at 10:57, Joseph Smarr wrote:

> Sure, look at http://www.w3.org/TR/2010/WD-contacts-api-20100701/#idl-def-ContactProperties (scroll up a bit to see the note about how their schema is based on PoCo).

I am actually quite surprised by this (and no offence to PoCo ;-)

All of the attributes listed in that Working Draft are pretty much what is in vCard (the industry standard with the widest deployment, from the IETF). I did not see the xtra social attributes listed (eg food, heroes, etc)

I tried to look thru the email archives to see why....and found a small discussion [1] with the argument:

  "As PoCo represents a larger set of Contact attributes, I'd like to propose that we make PoCo the basis of the DAP Contacts API"

Again, this "larger set" is not evident in the WD. Was this the right decision to make?

And, ironically, the Introduction [2] says "The API itself is agnostic of any underlying address book sources"

Cheers

Renato Iannella

[1] http://lists.w3.org/Archives/Public/public-device-apis/2009Nov/0045.html
[2] http://www.w3.org/TR/2010/WD-contacts-api-20100701/#introduction

---

From: Julian Reschke <[email-masked]>
Date: Thu, 09 Sep 2010 14:17:46 +0200

On 08.09.2010 16:17, Marc Blanchet wrote:
> such as W3C device API, Portable Contacts, IETF vcarddav, OMA CAB. A
> conf call was scheduled. Minutes are posted at:
> ...

Just an observation: if the WG decides to do anything bug a), we may 
want to revisit the decision to block the progress of 
draft-ietf-vcarddav-carddav, which has been in the RFC Editor queue for 
over 5 months now.

(As far as I recall, that could be done by removing the SHOULD-level 
requirement for vcard4 support, which of course is tricky after IESG 
approval)

Best regards, Julian