Subject: [VCARDDAV] Proposal: Eduction

From: Renato Iannella <[email-masked]>
Date: Tue, 5 Oct 2010 11:41:58 +1000

I would like to propose to add the EDUCATION field to vCard.

A person's educational background is an important part of their identity and career and is captured by many online professional services (such as LinkedIn, Plaxo, Xing etc)

I have attempted to represent the new field below (but I did not do a good job of the ABNF!)
There are other subfields that could be considered,such as the years attended at the institution.

Cheers

Renato Iannella
http://renato.iannella.it

====

6.6.7.  EDUCATION

   Purpose:  To specify the educational background of the individual represented by this vCard.

   Value type:  A single text value.

   Cardinality:  (0,n)

   Special notes:  The TYPE parameter MAY be used to characterize the
      level of education.  The understood types are:

      *  "primary" means elementary education consisting of the first 5–7 years of formal structured education.

      *  "secondary" means high school level education

      *  "tertiary" means higher university or college education leading to undergraduate and postgraduate degrees

      *  "adult" means less formal educational services, such as trade courses

      Other types may be registered to IANA as described in
      Section 10.2, and private extensions may be used.

    ABNF:

     EDUCATION-param = "VALUE=text" / language-param / pid-param / pref-param
                / type-param / altid-param / any-param
     EDUCATION-param-text = "VALUE=text" / language-param

     EDUCATION-param =/ pid-param / pref-param / altid-param / type-param
                    / any-param

     type-param-education= "primary" / "secondary" / "tertiary" / "adult"
                       / iana-token / x-name
       ; type-param-education MUST NOT be used with a property other than
       ; EDUCATION.

   Examples:

   EDUCATION;TYPE=tertiary:Bond University
   EDUCATION;TYPE=adult:Billie's Music School
 
======

---

From: Cyrus Daboo <[email-masked]>
Date: Tue, 05 Oct 2010 08:30:14 -0400

Hi Renato,

--On October 5, 2010 11:41:58 AM +1000 Renato Iannella <[email-masked]> 
wrote:

> A person's educational background is an important part of their identity
> and career and is captured by many online professional services (such as
> LinkedIn, Plaxo, Xing etc)
>
>

This is probably a good field to include in a draft standardizing a whole 
bunch of social networking properties. i.e. an extension rather than 
something for the base spec.

-- 
Cyrus Daboo

---

From: Simon Perreault <[email-masked]>
Date: Tue, 05 Oct 2010 08:44:06 -0400

On 2010-10-05 08:30, Cyrus Daboo wrote:
> This is probably a good field to include in a draft standardizing a
> whole bunch of social networking properties. i.e. an extension rather
> than something for the base spec.

+1

Simon
-- 
NAT64/DNS64 open-source --> http://ecdysis.viagenie.ca
STUN/TURN server        --> http://numb.viagenie.ca
vCard 4.0               --> http://www.vcarddav.org

---

From: Renato Iannella <[email-masked]>
Date: Fri, 8 Oct 2010 21:55:26 +1000

On 5 Oct 2010, at 22:30, Cyrus Daboo wrote:

> This is probably a good field to include in a draft standardizing a whole bunch of social networking properties. i.e. an extension rather than something for the base spec.

Cyrus, how does one make this call? (ie where do you draw the line and say that is vCard and that is "social" ?)

For example, the vCard Introduction says that it represents "information normally stored within an address book or directory application" - we now have online "directory" applications (aka, LinkedIn, Plaxo, Xing, Google Profile, etc...) - there are not that many X.520 directories left ;-(

What about ANNIVERSARY, RELATED (parent/child/sibling/spouse/family/friend) - sounds very social ;-)

Cheers

Renato Iannella