Subject: [VCARDDAV] Slides for vCard 4.0

From: Simon Perreault <[email-masked]>
Date: Fri, 05 Nov 2010 08:02:09 -0400

Group,

These are the slides we intend to use for next week's meeting in Beijing:

http://www.ietf.org/proceedings/79/slides/vcarddav-0.pdf

There are 23 slides with at least one proposal each. We have one hour.
We'll need to be extremely efficient. Therefore, please get ready in
advance.

Let me know if we missed anything or need to fix the slides in any way.
During the meeting we won't have time for anything that is not already
on the slides.

Thanks,
Simon
-- 
NAT64/DNS64 open-source --> http://ecdysis.viagenie.ca
STUN/TURN server        --> http://numb.viagenie.ca
vCard 4.0               --> http://www.vcarddav.org

---

From: Renato Iannella <[email-masked]>
Date: Fri, 5 Nov 2010 22:16:58 +1000

On 5 Nov 2010, at 22:02, Simon Perreault wrote:

> Let me know if we missed anything

1 - Date Range Proposal
  See discussion starting here:
  http://www.ietf.org/mail-archive/web/vcarddav/current/msg01793.html

Cheers

Renato Iannella
http://renato.iannella.it

---

From: Simon Perreault <[email-masked]>
Date: Fri, 05 Nov 2010 08:52:49 -0400

>   http://www.ietf.org/mail-archive/web/vcarddav/current/msg01793.html

Right, sorry about that. I wonder how I missed it.

I added this in a slide:

Date ranges
- Proposal: add EFFECTIVE parameter
  - Indicates when a given property is/was/will be effective.
    - Example use case: past employers listed in ORG
  - Value type (named "period") is a date range
    e.g. <start>/<end>
  - Open-ended ranges: * or (nothing)
  - <start> is inclusive, <end> is exclusive
    (like iCalendar DTSTART/DTEND)
- Proposal: restrict to date granularity
  - Argument for: should point to iCalendar otherwise

Simon