Subject: [VCARDDAV] Remove BINARY, was Re: IETF79 vcarddav wg meeting notes

From: Cyrus Daboo <[email-masked]>
Date: Mon, 15 Nov 2010 14:08:01 -0500

Hi Marc,

--On November 15, 2010 1:46:50 PM -0500 Marc Blanchet 
<[email-masked]> wrote:

> - Remove BINARY
>    - Problem: BINARY value type is redundant with data: URI scheme.
>    - Resolution: Remove BINARY property, remove FMTTYPE and ENCODING
> parameters.

Actually FMTTYPE needs to remain as it is still useful to tag non-data URIs 
with a MIME type. e.g.:

PHOTO;FMTTYPE=image/jpeg:http://example.com/images/me.jpg

-- 
Cyrus Daboo

---

From: Simon Perreault <[email-masked]>
Date: Mon, 15 Nov 2010 14:09:55 -0500

On 2010-11-15 14:08, Cyrus Daboo wrote:
> Actually FMTTYPE needs to remain as it is still useful to tag non-data
> URIs with a MIME type. e.g.:
> 

You want to override the HTTP Content-Type header?

Simon
-- 
NAT64/DNS64 open-source --> http://ecdysis.viagenie.ca
STUN/TURN server        --> http://numb.viagenie.ca
vCard 4.0               --> http://www.vcarddav.org

---

From: Cyrus Daboo <[email-masked]>
Date: Mon, 15 Nov 2010 14:17:02 -0500

Hi Simon,

> You want to override the HTTP Content-Type header?

No. I want to give clients a hint about what type is there. In the case of 
multiple photos of different types, a client may prefer one format over 
another.

-- 
Cyrus Daboo

---

From: Simon Perreault <[email-masked]>
Date: Mon, 15 Nov 2010 14:28:57 -0500

On 2010-11-15 14:17, Cyrus Daboo wrote:
> No. I want to give clients a hint about what type is there. In the case
> of multiple photos of different types, a client may prefer one format
> over another.

So what's wrong with just using the HTTP HEAD method in that case?

What if the hint conflicts with the Content-Type header?

<not too sure>
Shouldn't the resolution method for any URI provide the media type?
</not too sure>

Simon