Subject: [VCARDDAV] Dropping the XML property

From: Simon Perreault <[email-masked]>
Date: Tue, 02 Nov 2010 09:38:42 -0400

> 6.1.5. XML
> 
> I think this is totally unnecessary and a bad idea because it
> violates DRY.
> 
> Seriously? An XML property that represents all the rest of the data
> in the same vCard? Ugh. Which do you trust? The XML or the actual
> vCard properties?

There is an important element which I think you are missing:

      The content of this property is a single XML element
      whose namespace [...] MUST NOT be the vCard 4 namespace

Therefore, it is impossible to duplicate properties already present in
the vCard since these would go into the vCard 4 XML namespace.

Simon
-- 
NAT64/DNS64 open-source --> http://ecdysis.viagenie.ca
STUN/TURN server        --> http://numb.viagenie.ca
vCard 4.0               --> http://www.vcarddav.org

---

From: Kevin Marks <[email-masked]>
Date: Wed, 3 Nov 2010 17:14:18 -0700

On Tue, Nov 2, 2010 at 6:38 AM, Simon Perreault <[email-masked]
> wrote:

> the vCard since these would go into the vCard 4 XML namespace.<https://www.ietf.org/mailman/listinfo/vcarddav>

I'd suggets you add clarifying language like this to make it clear that this
XML  MUST NOT duplicate any vCard properties.

---

From: Julian Reschke <[email-masked]>
Date: Thu, 04 Nov 2010 07:23:49 +0100

On 04.11.2010 01:14, Kevin Marks wrote:
>
>
> On Tue, Nov 2, 2010 at 6:38 AM, Simon Perreault
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>      > 6.1.5. XML
>      >
>     the vCard since these would go into the vCard 4 XML
>     namespace.<https://www.ietf.org/mailman/listinfo/vcarddav>
>
>
>
> I'd suggets you add clarifying language like this to make it clear that
> this XML  MUST NOT duplicate any vCard properties.

Another conformance requirement is not needed (and would be confusing), 
because it directly follows from what's already said. But of course, it 
wouldn't hurt to state the fact that this means what you just said.

Best regards, Julian

---

From: Simon Perreault <[email-masked]>
Date: Thu, 04 Nov 2010 09:32:27 -0400

> this XML  MUST NOT duplicate any vCard properties. 

Agreed. I added the sentence inside parentheses at the end:

    The content of this property is a single
    XML element whose namespace MUST be explicitly specified using the
    xmlns attribute and MUST NOT be the vCard 4 namespace
    ("urn:ietf:params:xml:ns:vcard-4.0"). (This implies that it cannot
    duplicate a standard vCard property.)

Simon