Subject: Re: [VCARDDAV] Problems with quoting parameter values

From: Simon Perreault <[email-masked]>
Date: Mon, 01 Nov 2010 14:54:50 -0400

While applying these changes I had a question...

On 2010-10-05 12:12, Mike Douglass wrote:
> Section 5.9 SORT-AS:
> 
>      sort-as-param = "SORT-AS=" sort-as-value
> 
>      sort-as-value = param-value *("," param-value)
> 
> The examples need to be adjusted to match.

In what way? I don't see any change to the examples being needed...

> Section 5.11 TZ change
>      tz-param  = "TZ=" DQUOTE (text / uri) DQUOTE
> to
>      tz-param  = "TZ=" param-value / DQUOTE uri DQUOTE

I added parentheses:

tz-param  = "TZ=" (param-value / DQUOTE uri DQUOTE)

Simon
-- 
NAT64/DNS64 open-source --> http://ecdysis.viagenie.ca
STUN/TURN server        --> http://numb.viagenie.ca
vCard 4.0               --> http://www.vcarddav.org

---

From: Mike Douglass <[email-masked]>
Date: Mon, 01 Nov 2010 16:11:39 -0400

> In what way? I don't see any change to the examples being needed...

For example

            N;SORT-AS="Harten;Rene":van der Harten;Rene,J.;Sir;R.D.O.N.

change to

            N;SORT-AS="Harten,Rene":van der Harten;Rene,J.;Sir;R.D.O.N.

-- 

Mike Douglass                           [email-masked]
Senior Systems Programmer
Communication&  Collaboration Technologies      518 276 6780(voice) 2809
(fax)
Rensselaer Polytechnic Institute 110 8th Street, Troy, NY 12180

---

From: Simon Perreault <[email-masked]>
Date: Mon, 01 Nov 2010 16:20:12 -0400

>            N;SORT-AS="Harten,Rene":van der Harten;Rene,J.;Sir;R.D.O.N.

Ah, right, thanks.

Simon