Subject: [VCARDDAV] Dropping the VERSION property

From: Simon Perreault <[email-masked]>
Date: Mon, 01 Nov 2010 16:05:54 -0400

> 5.12. VERSION
> 
> I don't think this is necessary, and in fact encourage future breaking as well as pushing the burden of handling multiple versions of a property onto implementations.
> 
> Let's NOT add this, and instead work hard to:
> 
>     * specify forward compatible parsing rules (i.e. ignore any params you don't recognize)
>     * keep properties backward compatible in general, just adding detail params (like TZ and GEO) where it progressively enhances the property without breaking any existing semantics. 

This property has been there since at least 2.1. We're not "adding"
anything. This is for backward compatibility rather than forward. We
want people to move to XML.

Simon
-- 
NAT64/DNS64 open-source --> http://ecdysis.viagenie.ca
STUN/TURN server        --> http://numb.viagenie.ca
vCard 4.0               --> http://www.vcarddav.org

---

From: Simon Perreault <[email-masked]>
Date: Mon, 01 Nov 2010 16:08:22 -0400

Scratch that. You were referring to the VERSION *parameter*. Ignore this
thread please.

Simon