Subject: Re: [VCARDDAV] New vCard 4.0 fields

From: <[email-masked]>
Date: Wed, 8 Dec 2010 15:19:31 +0100

Some of these fields such as expertise, hobby, interest could be put in the
core specification because they are not "CAB specific" but are generic
fields.

So, are there other opinions on that ? 

Dany

-----Message d'origine-----
De : Peter Saint-Andre [mailto:[email-masked]] 
Envoyé : mardi 30 novembre 2010 00:48
À : CAUCHIE Dany RD-MAPS-LAN
Cc : [email-masked]
Objet : Re: [VCARDDAV] New vCard 4.0 fields

On 11/26/10 6:27 AM, [email-masked] wrote:
> Hello,
> 
> The OMA-CAB group defines vCard 2.1 extensions which are :
>  
> attributes      
>       X-CAB-PCC-TYPE : To specify the kind of object the vCard represents.
>       X-CAB-CONTACT-STATUS : To specify the CAB status of the object the
vCard represents (updated, temporary, subscription active, ...)
>       X-CAB-SEX : looks like SEX/GENDER
>       X-CAB-LANG : To specify the language(s) that may be used for
contacting the individual associated with the vCard.
>       X-CAB-SERVICE : To specify the aliases used on different sites by
the object that the vCard refers to.
>       X-CAB-EXPERTISE : To specify the expertise(s) of the object that the
vCard refers to.
>       X-CAB-HOBBY : To specify the hobbies of the object that the vCard
refers to.
>       X-CAB-INTEREST : To specify the interest(s) of the object that the
vCard refers to.
>       X-CAB-PUBLICNOTE : To specify additional information associated with
the object the vCard refers to.
>       X-CAB-ORG-DIRECTORY : To specify the organization-directory of the
object the vCard represents.
> 
> Parameters used in the new attributes definitions
>       X-CAB-CONTACT-ID-REF 
>       X-CAB-INDEX
>       X-CAB-LANGUAGE-PROFICIENCY-TYPE 
>       X-CAB-LANGUAGE-FLUENCY-TYPE 
>       X-CAB-LEVEL
> 
> The OMA-CAB group defines these extensions with an "IETF like"
description.
> 
> My question is : can we introduce these extensions as standard fields in
the vCard 4.0 in order to be compliant with "OMA-CAB vCard extensions" ?

These extensions are more appropriate as extensions, not as part of the core
specification of vCard 4.0.

Peter

--
Peter Saint-Andre
https://stpeter.im/

---

From: Julian Reschke <[email-masked]>
Date: Wed, 08 Dec 2010 16:08:16 +0100

On 08.12.2010 15:19, [email-masked] wrote:
> ...

Commenting as bystander: please finish this spec. It's past all LCs. In 
particular this means not to add anything new unless there's a really 
really wide consensus that it's essential.

There's an extension point for a reason.

Best regards, Julian

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 08 Dec 2010 08:15:57 -0700

> There's an extension point for a reason.

Yes, and it was designed for things like hobbies, expertise, interests.
Folks who care about those fields are very much welcome to submit
Internet-Drafts proposing extensions. But I agree with Julian that it's
time to finish up the core of vCard 4.0.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Joe Hildebrand <[email-masked]>
Date: Thu, 09 Dec 2010 00:27:41 -0700

> There's an extension point for a reason.

Agree.  We really need this done, please.

-- 
Joe Hildebrand