Subject: [VCARDDAV] [Technical Errata Reported] RFC6351 (3047)

From: RFC Errata System <[email-masked]>
Date: Thu, 8 Dec 2011 14:39:39 -0800 (PST)

The following errata report has been submitted for RFC6351,
"xCard: vCard XML Representation".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6351&eid=3047

--------------------------------------
Type: Technical
Reported by: Christian Mollekopf <[email-masked]>

Section: Appendix A.

Original Text
-------------
# 6.4.1
property-tel = element tel {
    element parameters {
      param-altid,
      param-pid,
      param-pref,
      element type {
        element text { "work" | "home" | "text" | "voice"
                     | "fax" | "cell" | "video" | "pager"
                     | "textphone" }+
      }?,
      param-mediatype
    }?,
    (value-text | value-uri)
  }

Corrected Text
--------------
# 6.4.1
property-tel = element tel {
    element parameters {
      param-altid,
      param-pid,
      param-pref,
      element type {
        element text { "work" | "home" | "text" | "voice"
                     | "fax" | "cell" | "video" | "pager"
                     | "textphone" | x-name | iana-token }+
      }?,
      param-mediatype
    }?,
    (value-text | value-uri)
  }

Notes
-----
x-name and iana-token is missing in a couple of explicit listings of values, the above is just an example. RFC6350 allows extending these values with own x-names though.

This should be corrected in:
param-type
param-calscale
property-tel

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6351 (draft-ietf-vcarddav-vcardxml-11)
--------------------------------------
Title               : xCard: vCard XML Representation
Publication Date    : August 2011
Author(s)           : S. Perreault
Category            : PROPOSED STANDARD
Source              : vCard and CardDAV
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 08 Dec 2011 16:24:47 -0700

Does this one seem accurate?

-------- Original Message --------
Subject: [Technical Errata Reported] RFC6351 (3047)
Date: Thu,  8 Dec 2011 14:39:39 -0800 (PST)
From: RFC Errata System <[email-masked]>
To: [email-masked], [email-masked],
[email-masked], [email-masked]
CC: [email-masked], [email-masked], [email-masked]

Section: Appendix A.

Original Text
-------------
# 6.4.1

Corrected Text
--------------
# 6.4.1

Notes
-----
x-name and iana-token is missing in a couple of explicit listings of
values, the above is just an example. RFC6350 allows extending these
values with own x-names though.

Instructions:
-------------

---

From: Simon Perreault <[email-masked]>
Date: Fri, 09 Dec 2011 08:37:08 -0500

Confirmed.

Thanks,
Simon

On 2011-12-08 17:39, RFC Errata System wrote:
> Reported by: Christian Mollekopf<[email-masked]>
>
> Section: Appendix A.
>
> Original Text
> -------------
> # 6.4.1

-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca