Subject: [VCARDDAV] Fwd: [Technical Errata Reported] RFC6321 (3050)

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 13 Dec 2011 08:46:46 -0700

This report appears to be correct. Verification appreciated.

-------- Original Message --------
Subject: [Technical Errata Reported] RFC6321 (3050)
Date: Tue, 13 Dec 2011 05:35:35 -0800 (PST)
From: RFC Errata System <[email-masked]>
To: [email-masked], [email-masked], [email-masked],
[email-masked]
CC: [email-masked], [email-masked]

The following errata report has been submitted for RFC6321,
"xCal: The XML Format for iCalendar".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6321&eid=3050

--------------------------------------
Type: Technical
Reported by: Christian Mollekopf <[email-masked]>

Section: Appendix A

Original Text
-------------
   type-bysecond = element bysecond {
       xsd:positiveInteger
   }

   type-byminute = element byminute {
       xsd:positiveInteger
   }

   type-byhour = element byhour {
       xsd:positiveInteger
   }

Corrected Text
--------------
type-bysecond = element bysecond {
       xsd:nonNegativeInteger
   }

   type-byminute = element byminute {
       xsd:nonNegativeInteger
   }

   type-byhour = element byhour {
       xsd:nonNegativeInteger
   }

Notes
-----
Those values can be 0 and xsd:positiveInteger doesn't allow this

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary.

--------------------------------------
RFC6321 (draft-daboo-et-al-icalendar-in-xml-11)
--------------------------------------
Title               : xCal: The XML Format for iCalendar
Publication Date    : August 2011
Author(s)           : C. Daboo, M. Douglass, S. Lees
Category            : PROPOSED STANDARD
Source              : IETF - NON WORKING GROUP
Area                : N/A
Stream              : IETF
Verifying Party     : IESG

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 13 Dec 2011 09:10:22 -0700

Oops, wrong list. That's what I get for working on the train into the
office. :)

On 12/13/11 8:46 AM, Peter Saint-Andre wrote:
> _______________________________________________
> VCARDDAV mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/vcarddav

-- 
Peter Saint-Andre
https://stpeter.im/